Results 1 to 1 of 1
  1.    #1  
    Hey guys,

    I've got a great idea for an app and some experience in programming. So, I decided to try my hand at writing an app for webOS. I started on, got everything installed (after a little research and tweaking) and got to work on the HelloWorld tutorial. I followed everything through to the letter, installed it to the emulator, and got the default message:
    This text verifies your application is running.

    To create a fully functional Palm application create a scene and remove this text from index.html. See the documentation on Palm Applications for more information on creating applications and scenes.
    So, I removed the text from the body and tried again. This time the card came up blank.

    Well, I played around with that for a while before I decided it was time to take another approach. So, I picked up O'REILLY's Palm webOS by Mitch Allen. I used Eclipse with the palm plugin to work my way through the News Application tutorial he starts on page 33. When I finished, I ran it on the emulator. Once again, I got a header but the rest of the card was blank grey. I figured it might be the emulator, so I installed it on my pre with the same result.

    I figured it might be a problem with Eclipse since I'd used that for both of the tutorials. So, I went back through the news application tutorial EXACLY as written, even copying and pasting the code. I edited everything in wordpad, used the cmd window, etc. Still, when I ran it in the emulator, I just got a blank screen for a card.

    I've attached a zip file with the folder with the news application in it. I'd upload the helloworld one, but I screwed around with that one a lot trying to get it to work, so I'm not sure about it anymore.

    Could someone please take a look at these files and tell me what I'm doing wrong? It's a very very very simple program (actually a first step in a larger program) with very little code and only once scene, so it shouldn't take much time.

    Thank you in advance for your help.

    Windows 7 x64
    WebOS 1.2.1 on my phone
    VirtualBox 3.0.4 r50677
    Palm Emulator (
    Eclipse SDK Version: 3.4.2 Build id: M20090211-1700
    I installed the following plugins for Eclipse:
    Palm Mojo SDK Tools (Core)
    Palm Mojo SDK Tools (UI)
    Palm Mojo SDK Tools (Aptana Support) 0.9.3.qualifier
    Attached Files Attached Files

Posting Permissions