Results 1 to 5 of 5
  1.    #1  
    Question from a very green webos developer. I want to change the behavior of an existing application but I've been unsuccessful to this point. Even without changing any of the actual code, I can get it to install in the emulator but not on my device.

    The steps I took were to grab the .ipk file, extract everything in the data.tar.gz, run palm-package against that directory, and do a palm-install. So as far as I can tell, it's the same code as the original .ipk file. And like I said, it installs and runs fine in the emulator. But when I try to install it on my device, it doesn't give me any errors or anything but when I look in the launcher there's no sign of it. And if I run a "palm-install -l", it doesn't list it as an installed application.

    As a side note, if I create an empty application using palm-generate, it installs fine so it must be something I'm doing wrong.

    What am I missing here? Any help would be greatly appreciated!

  2. #2  
    Version #. Update the version number. It sees the same app id, with the same version, and will not override it.
  3.    #3  
    Awesome, you're a life saver. So do you have to bump the version number every time you install on a device? Is that documented somewhere and I just missed it?

    Thanks again!
  4. #4  
    Bump version number or delete original.
    Your Pre wants Word Whirl from the App Catalog.

    It told me.
  5.    #5  
    Strange, that app wasn't even installed on my device and it still wouldn't show up after I installed it. It could've been my phone though, I did just have to go back to the Sprint store and swap it since some other odd things were happening. Like EAS not working even though the same credentials worked on my wife's Pre (running the same version of WebOS).

Posting Permissions