Results 1 to 7 of 7
  1.    #1  
    I already have it up and running, as well as cron. I've verified it thought the local pre browser and

    The issue that I'm having is through either wifi (eth0) and sprint (ppp0).. the page just times out.

    My lighttpd.conf has been changed to port 8081, as well as in the /etc/event.d/optware-lighttpd which ive put below:
    # Don't start until the WebOS finishes it's normal boot
    # that way no delay is added to the GUI startup
    start on stopped finish
    stop on runlevel [!2]
    # Restart the lighttpd daemon if it exits/dies
    exec /opt/sbin/lighttpd -f /opt/etc/lighttpd/lighttpd.conf
    pre-start script
    	/usr/sbin/iptables -D INPUT -p tcp --dport 8081 -j ACCEPT || /bin/true
    	/usr/sbin/iptables -I INPUT -p tcp --dport 8081 -j ACCEPT\
    	# /opt/bin/mysqld_safe &
    end script
    I know that /etc/event.d/optware-dropbear has a "-i eth0" thrown in it, but that's only if i want to limit to wifi.

    Any ideas?
  2. navinag's Avatar
    455 Posts
    Global Posts
    489 Global Posts
    what are you trying to run....mean what type of webpage are you trying to acces on your pre?
  3.    #3  
    Well i was playing around with the gps feature.. and was trying to get to the ip directly instead of setting up a dynamic ip service.

    I already have a php page working and displays the phpinfo() in it, and I've seen the default lighttpd page... only just through the pre.

    I had it working thought wifi as well as local... but that was 1.2, not 1.2.1
  4. navinag's Avatar
    455 Posts
    Global Posts
    489 Global Posts
    Go to webosinternals and search for the setup for lighttpd and make sure you have the web setting correctly... I followed that same GPS setup and it turned out that php was commented out of the lighttpd conf worked for me after I added php to to conf file...It is somwher at the top.......let me see if I can find it.

    Lighttpd - WebOS Internals
  5.    #5  
    Yeah, thats how i got it setup. But you got me thinking and looking at some other settings i had changed. I had disabled the .log files, and some how that was causing an issues.

    Not sure why but commenting out the log lines in /opt/etc/lighttpd/lighttpd.conf prevented it from being viewed on networks.

    But at least it all works now, thanks for making me rethink things
  6. navinag's Avatar
    455 Posts
    Global Posts
    489 Global Posts
    No problem...
  7. #7  
    Although I must say, it'll be a lot tougher to take advantage of without ddns, won't it?

    And the DDNS is REALLY easy and free, with dyndns and ez-ipupdate. Very simple, very effective, so why not use it?

    ETA: I guess if you only ever want to use the page while on a wireless network it's fine...but then that makes the GPS php page pretty useless as well, and that's what you mentioned using the php page for.

Posting Permissions