Results 1 to 10 of 10
  1.    #1  
    just getting around to starting my first webos app and I'm running into a strange error when I type the command:

    palm-package MyProject
    There error is as follows:

    A JSONObject text must begin with '{' at character 1 of appinfo.json{"title: .....
    Anyone have any experience with this?

    My actual appinfo.json file is as follows

    "title": "MyProject",
    "type": "web",
    "main": "index.html"
    "id": "",
    "version": "1.0",
    "noWindow": "false",
    "icon": "icon.png",
    "minicon" : "icon.png",
    "category" : "Entertainment"
  2. #2  
    You are missing a , after index.html"
  3. #3  
    Quote Originally Posted by Lclarkjr View Post
    You are missing a , after index.html"
    you beat me to it
  4.    #4  
    from what I can tell, there isn't supposed to be a comma after that entry...This code was generated automatically by eclipse. Regardless, adding a comma there has no effect on the error message...
  5. #5  
    Is the first line of your file actually "appinfo.json"? The first character should be the { so it is strange that eclipse generated it like that. If so, have you tried deleting that first line so that the file starts with the bracket, like the error implies?
  6.    #6  
    @PreDog1, That did change the error to

    missing required property "vendor"...
    strange that was left out...
  7. #7  
    Were you able to add a "vendor" property and get your app to launch?

    I believe the "vendor" property is the company/creator name which shows up when you alt tap your application icon from the launcher.

    I haven't tried eclipse yet. I just do everything from the command line. You might want to run a 'palm-generate' from your command line and see the app.json file that gets created. You can then compare it to the one created via eclipse.
  8.    #8  
    Yeah, I was able to manually add the property and everything worked fine. Yeah, I may just start using a text editor like Notepad++ or something. I use VS 2008 for work, I may give that a try. Thanks for the help, guys.
  9. #9  
    I need help too ('-_-)
    I don't know why is giving me the same error.
    Palm-package: JSON error in /gskcrypt/appinfo.json: Missing value at character 1
    My file is like this:
    	"id": "com.tommyfenyx.gskcrypt",
    	"title": "gskcrypt",
    	"version": "0.0.1",
    	"type": "web",
    	"main": "index.html",
    	"icon": "icon.png",
    	"vendor": "Tommy Fenyx",
    	"vendorurl": "(here I have my url but...)",
    	"visible": true,
    	"removable": true
    (... but precentral don't let me put it because:
    To be able to post links or images your post count must be 10 or greater.

    Sorry if I refloat this thread but I think isn't necessary to create another.
  10. #10  
    "visible": "true" ?

Posting Permissions