Results 1 to 10 of 10
  1.    #1  
    Does anyone have an idea what might be the problem here?

    I set up SSH (dropbear) and sftp weeks ago on my pre and have been using it all the time without any problems using putty and winscp, both over the LAN and through the EVDO connection from my laptop.

    Recently I moved into a new house and had to reset the local network- it's the same old router, but different settings. the Pre connects to the network fine, has a local ip address, etc etc, as does my laptop. as near as i can tell everything is exactly the same.

    However, I can no longer access SSH on my Pre over the LAN- I get:

    "Network error: Connection refused"

    I can access it over the internet via the EVDO connection, so there is nothing wrong with the dropbear daemon or anything like that. I'm pretty sure the iptables are correct (I haven't messed with them).

    Does anybody have an idea waht the problem here might be? Yes I have all the ip addresses and port numbers correct. It's soemthing else.
  2.    #2  
    Curiouser and curiouser.

    Now I'm over at a friend's house, and am able to SSH using her LAN just fine.

    There must be something wrong with my home LAN. I can't imagine what it would be though.
  3. #3  
    I had this same exact issue when I setup my network after they upgraded my internet service. This happened to me while the pre was not charging. I think it is just a temp issue with the software needing to refresh itself despite the settings being the same there probably is some slight variation detected. I put my pre on the touchstone and connected to it fine from there forward. If you are still having issues the guys in webos-internals IRC chat are very good at troubleshooting this issue.
  4. hselomein's Avatar
    21 Posts
    Global Posts
    36 Global Posts
    This has also happened to me. It resolved itself after i turned on developer mode, connected via ssh and turned it back off. I haven't had a problem since
  5. lordbah's Avatar
    341 Posts
    Global Posts
    435 Global Posts
    Asking the obvious, but is the Pre timing out during the tests at your house, turning off the screen and wifi?
  6.    #6  
    No, timing out is not the problem.

    hselomein, i tried your suggestion, and it worked for me also. yay.

    this is a weird bug though. probably hard to diagnose as well since i have no idea how to reproduce it.
  7. #7  
    i can ssh into the LAN and not evdo, what do you suppose is the problem? is it the dropbear daemon?
  8.    #8  
    if you followed the directions on webos-internals or the pre dev wiki, the ssh over evdo is disabled. to enable it, do this:

    cat /etc/event.d/optware-dropbear

    Take a look at the script. Notice that it automatically modifies the firewalls rules to enable incoming SSH on port 222 over WiFI (interface eth0) connections only. Follow the directions in the script to enable SSH on all interfaces (including your EVDO interface) if you wish. (This paragraph was copied from Dropbear Install - WebOS Internals )

    If you're going to be using ssh over evdo you might also want to install dyndns so you can ssh to a domain name instead of having to find out your pre's ip every time:

    Tutorials Linux DDNS for EVDO - WebOS Internals
  9. #9  
    Thanks for the help, i just removed dropbear and reinstalled and it gave me the options to

    1.use wifi
    2. use evdo
    3. use both

    so i picked 3 and voila, i'm in. i also got dyndns setup too, my pre is now forever live on the web....hehehe kinda cool and scary at the same time.
  10. #10  
    How did you remove the bear thing

Posting Permissions