hello all,
hopefully you can help me. i'm just making my way through apps with eclipse, the mojo sdk and emulator on windows. i am having a huge problem with getting new Ajax requests to work. i think i'm doing them all right (i copy most of the code from the Data API samples) and it seems good, but never works. do i need to initialize APIs somehow in some file i'm not seeing? here is a sample code:

FirstAssistant.prototype.setup = function(){
	this.items = [];
	var that = this;

	for( var i = 0; i < 4; i++ ) {
        var title = 'test' + i;
        this.items.push({text: title});

	var reqq = new Ajax.Request("html/wines.xml", {
        method: 'get',
        evalJSON: 'false',
			onChoose: function(value) {},
			choices:[ {label:'OK', value:'OK', type:'color'} ]
         var movieTags = transport.responseXML.getElementsByTagName('wine');
         for( var i = 0; i < movieTags.length; i++ ){
             var title = movieTags[i].getAttribute('title');
             that.items.push({text: title});
	this.items.push({text: "oy vey!"}); 
	this.controller.setupWidget("listWidget", this.listWidgetAttr = {
	        itemTemplate: "html/rowTemplate",
	        listTemplate: "html/listTemplate",
	        reorderable: true,
	        addItemLabel: $L('Add ...')
		this.listWidgetModel = {
	        items: this.items //an array
i basically get a list with test0-test3, and oy vey. but nothing happens with the Ajax Request!! and i've tried putting that file in every directory in my path, and even tried uploading it remotely and using the request on a remote wines.xml fle with a proxy (as per the Prototype guidelines). what could i possibly be missing?? thanks so much.