Page 38 of 38 FirstFirst ... 28333435363738
Results 741 to 757 of 757
Like Tree1Likes
  1. #741  
    Quote Originally Posted by Bizzare View Post
    Tried Running the PreCorder and I get "gstservice is not running" can I get some help on this thanks. I restarted rebooted and I ran the web os doctor and nothing I need HELP!!!! Thanks ahead of time.
    Same thing here so I am looking for a good replacement...loved that app.
  2. rpr
    rpr is offline
    rpr's Avatar
    212 Posts
    Global Posts
    216 Global Posts
    There is an update 0.3.5 for Precorder that fixes it for 1.3.5.
    Pilot 1000 -> Palm Pro -> Palm III -> Handspring Visor -> Palm V -> Palm TX -> Palm LifeDrive -> Kyocera 6035 -> Kyocera 7135 -> Treo 650 -> Palm Pre
  3. #743  
    I am trying to do the update to 0.3.5. I removed the old precorder first, but now it just hangs at the last command "sh precorder-bootstrap " and I'm using the command line in QI 2.96. Any suggestions?
  4. #744  
    how do I delete it do I just delete like if was an app?
  5. #745  
    Quote Originally Posted by rpr View Post
    There is an update 0.3.5 for Precorder that fixes it for 1.3.5.
    Awesome, will give it a shot.
  6. #746  
    hey guys - i had the old one working fine - then updated webOS to and thus removed the old precorder and then installed the new one via QI -- however i record and then when i go to play the file it says "there was an error playing the file"

    can anyone help me out?
  7. Von
    Von is offline
    Von's Avatar
    49 Posts
    For some reason I have the same issue, but it only does it sometimes..I fiddled with the settings and seem to of fixed the issue
  8. #748  
    and how do I install it ??
  9. dvargas72's Avatar
    10 Posts
    Global Posts
    14 Global Posts
    Jay, thank you for this app but wondering if you can tell me if this is supposed to work for the Pixi as well as the Pre or not because I downloaded it correctly (I assume) and it launches correctly (even though it looks slightly different than the screen shot) but still cant get it to function properly (as with the Torch app).
    Any suggestions of ideas?
    I am running 1.3.5
  10. dvargas72's Avatar
    10 Posts
    Global Posts
    14 Global Posts
    I have the same issue Funkadelik
  11. #751  

    This has been pretty unstable with everyone receiving mixed results. If you cannot wait until 1.4, then I recommend try reinstalling. Make sure you have Precorder 0.3.5.

    Good luck!
  12. pretoo's Avatar
    85 Posts
    Global Posts
    92 Global Posts
    Hay! In my opinion Precorder is some great app. Don't leave it in alpha state. Some people can't use webOS 1.4 becouse of uncompatibility with RebelSIM (yeah, I know Sonix walkaround, but it gives me a several bugs & I think I'm not the only one). Keep the good work! This is (and was from the beginning)Mesayah of Homebrew apps.
  13. #753  
    i think precoder have better video quality... i would love to have it as a video app
  14. #754  
    The line from the first post in this thread does not work on my phone:
    "gst-launch camsrc ! palmvideoencoder ! filesink location=/media/internal/downloads/foo.mp4"

    I get a crash (sorry, I can't include pastebin links yet):
    root@palm-webos-device:/# gst-launch camsrc ! palmvideoencoder ! filesink location=/media/internal/downloads/foo.mp4
    (59964/974161367) camd (stop) running, process 16419
    (59964/975290518) camd (stop) pre-stop, (main) process 16419
    (59964/975656729) camd (stop) stopping, process 16419
    (59964/981088858) camd (stop) killed, process 16419
    (59964/981455069) camd (stop) post-stop, process 31168
    (59964/981729727) camd (stop) waiting
    (59965/33518057) camd: goal changed
    Setting pipeline to PAUSED ...
    Pipeline is live and does not need PREROLL ...
    Setting pipeline to PLAYING ...
    New clock: GstSystemClock
    Caught SIGSEGV accessing address 0x8
    ERROR: from element /GstPipelineipeline0/GstV4l2Src:v4l2src0: could not queue buffer (data userptr=0x367ef008) @ index 0
    Additional debug info:
    v4l2src_calls.c(920): queue_available_preview_buffers (): /GstPipelineipeline0/GstV4l2Src:v4l2src0:
    system error: Invalid argument
    Execution ended after 58715821 ns.
    Setting pipeline to PAUSED ...
    #0 0x356a1e84 in ?? ()
    Setting pipeline to READY ...
    Spinning. Please run 'gdb gst-launch 31166' to continue debugging, Ctrl-C to quit, or Ctrl-\ to dump core.

    I've tried MANY combinations, up to and including this one:
    "gst-launch camsrc name=cs cs.src ! palmvideoencoder ! palmmpeg4mux name=mx location="/media/internal/test2.mp4" title="t" description="d" alsasrc ! palmaudioencoder ! mx.sinkAudio"

    I've had this latter line tried by another guy, with the same result... so it's not just my phone.

    Does anyone know a valid way to use the camsrc gstreamer module in your own application? A valid gst-launch line would basically allow that.
  15. #755  
    dblack are you sure you're using the pipe "|" key... and not the exclamation point?? Gotta hit shift and "\" key.
  16. #756  
    I think I'll stick with shift and "1" key, thank you very much.

    It's not a pipe. It's a gst-launch pipeline definition.
  17. #757  
    I am working on WebOS for Hp touchpad.
    I have to do 2 tasks :
    1) Start the camera in preview mode and then stop it when we're finished

    2) Start the camera recording audio and video to a file, and then stop it when we're finished recording. The format and resolution doesn't matter.
    But I see v4l2src is not available and when i use camsrc I get following error :

    ERROR: from element /GstPipelineipeline0/Gstcamsrc:camsrc0: Internal data flow error.

    Did you find anyway in which we can use camsrc to capture video and play the generated video with sound.
    Or is there no other way which could use existing gstreamer elements only to do the above tasks.
    Please help me at the earliest.
    <<< email address removed per site rules >>>

    Quote Originally Posted by Prenosicator View Post
    THANK YOU whoever you are. I check this thread all the time just for this reason. You are the first person here to make any sense in days. I really thought for a moment all hope was lost here in

    The issue is indeed involving a raw h264 stream, although the palmvideoencoder also supports h263, and mpeg-4 bitstreams by passing an element property value. The only available container for the version of gstreamer/gst-base/glib/glibc on the pre is ffmp4_mux, which quite honestly, is buggy, unstable, and just generally bad.

    I'm currently working on backporting qtmux, which would fix this up in a jiffy as it includes the container element mp4mux. I've also opted for the x264enc built on libx264, as it seems more stable than palms encoder. Part of the reason they had to build a custom encoder it would seem, is because the custom patched v4l2 (camsrc) is uh.. rather incomptaible.. with anything. In fact, even trying to pipeline to fakesink (gst-launch camsrc ! fakesink) fails. Deregistering camsrc and using the v4l2src element fixes this (although it breaks the camera app). A simple fix, I suppose, would be to change the name of camsrc to .so.orig, register v4l2, record, and then deregister v4l2/register palm's plugin afterwards.
    Last edited by hellonnnewman; 11/07/2013 at 07:17 AM.
Page 38 of 38 FirstFirst ... 28333435363738

Posting Permissions