Results 1 to 5 of 5
  1.    #1  
    This is so obvious it must have been answered before, but I've been searching this forum and Google and can't find any help.

    I got the SDK and novaterm installed and then followed these instructions for Optware:

    Next steps - WebOS Internals

    The very last step says to exit Developer Mode and log in using an ssh client. But I can't get that to work. I tried to connect to the local IP address of the Pre using an ssh client on Windows and got no response at all. It was like a firewall blocking me. (I have other Linux machines on my network so I know my ssh clients are working.)

    So then I went back into Developer Mode and used novaterm to confirm some things:

    netstat -lt shows the Pre is listening on port 222

    iptables -L shows that connections to port 222 should be accepted from anywhere

    ps ax shows that dropbear is running as dropbear -g -F -p 222

    While in Developer Mode I tried to ssh to the Pre from Windows and it begins to connect, but after entering my password I don't actually get connected. It times out after a minute or so. After trying that a few times it doesn't work anymore either - now my ssh connect attempts don't even ask for a password anymore - it's as if I was blacklisted for invalid connect attempts.

    So, it feels like I have two things going wrong:

    1) When I exit Developer Mode I get no ssh connect at all. Is there a firewall change required when developer mode is on/off?

    2) Dropbear seems to be letting me authenticate, but then doesn't connect to a terminal. Is there a configuration option I'm missing?

    I hope my description makes sense enough for someone to point me in the right direction. I was having so much fun, right up to hitting that brick wall.
  2. stubbs's Avatar
    425 Posts
    Global Posts
    442 Global Posts
    are you trying to connect over wifi or evdo?
  3.    #3  
    I have tried both wifi and evdo. No luck either way.

    In the meantime, I have created rsa keys on the Pre and can ssh to my Linux servers with no problem so I know that networking works.

    But I still can't ssh into my Pre from either my Windows machine, or the Linux machines. It must be something simple I'm missing on the Pre, but I can't find it.
  4. #4  
    It seems as if you're much more knowledgeable than I regarding linux, but I'm going to throw my own experience out there: After following the manual setup from early July, I could absolutely not ssh over wifi. This forced me to go the usbnet route, which worked perfectly. However, a couple of weeks later I accidentally connected over wifi (selected the wrong preset in putty), and it worked. I don't know if it required a couple of resets to take, or if wifi coincidentally went into sleep mode when I was trying to connect.
  5.    #5  
    Still can't get reliable ssh connections to the Pre, but here's the latest news in case anyone has an idea about this problem.

    Several times now the ssh connection almost worked. Trying to connect to the Pre from both Windows and Linux machines I have seen password prompts, and twice even an actual working ssh session. Usually after I enter the password nothing else happens.

    So most of the time (probably 90%) I get no response from the Pre at all. Sometimes I get a password prompt and nothing more. And a couple of times a good ssh sesssion.

Tags for this Thread

Posting Permissions