Page 1 of 2 12 LastLast
Results 1 to 20 of 28
  1.    #1  
    THANKS EVERYONE -- See post down a bit for results. No guarantees, but lots of successes.

    ======== The rest of this post is of only historical interest ========

    To date, the sdk has been successfully installed on Linux, on Max OS X, and on Windows XP, Windows Vista 32 bit, and Windows 7 64 bit.

    On windows XP and on Vista 32 bit, the sdk provided 32 bit novacomm drivers in the /sdk/bin/novacom/drivers folder work just fine.

    Additionally, the 64bit Novacom drivers work fine under 64 bit windows 7.

    However to date (24 July 2009) I have found no confirmed installations that work on Windows Vista 64 bit.

    If you have a Windows Vista 64 installation that can install apps to the Pre over the USB cable, please reply in this thread. We will have questions for you in order to update the instructions on the Main Page - WebOS Internals wiki.

    If you are having a problem, replying "me too" to this thread doesn't help much. If you're not running Visa 64, replying that it works for you doesn't help much. We know those things.

    What we're looking for is anyone who has had success installing novacom and talking to the Pre from Vista 64.

    There is a very simple test. If you install the dll's from sdk/bin/novacom/driver/amd64 to test if they work, go to sdk/bin and type

    novacom -t open tty://

    if you get back a prompt that says

    then you're in. And we want to know what you did differently than all those other Vista 64 people.

    So, please contact us if your Vista 64 passes that test. You can reply here, or contact any of the team in irc #webos-internals on


    Last edited by rboatright; 07/24/2009 at 06:06 PM. Reason: updated
  2. #2  
    I have it working on a Vista 64 bit Core i7 machine with the last Early Access SDK before the public release. I think it was 3.0.5. I just used the Novacom 64 bit driver that was in the WebOSDoctor JAR. I haven't bothered downloading the new public SDK because I don't need it for the app I am working on. I am able to install apps to my unrooted Pre via command line using palm-install or from Eclipse using the Palm plugin.
  3. MrBryson's Avatar
    4 Posts
    Global Posts
    6 Global Posts
    I'm running Windows Vista 64 bit Ultimate edition and I've had no problems installing apps from palm-install and I've successfully rooted my pre from this PC.

    The newest build of the Mojo SDK hasn't given me any issues (so far). The leaked build gave me a bunch of issues however.
  4. #4  
    I didn't have to do anything special to get the SDK running on my Vista 64-bit laptop.. I use palm-emulator.bat to run the emulator just fine. Dragging Pre apps to the palm-install.bat adds them to my Pre with no problem. I have Safari, 64-bit JDK, and Virtual Box 2.2 installed on my comp.

    I don't know if any of the above info helps or not. Let me know if you want me to check anything on my comp.
  5. #5  
    Just did that test you mentioned... I got root@castle. What would you like to know?
  6. Kaerey's Avatar
    539 Posts
    Global Posts
    540 Global Posts
    Running Vista Ultimate 64Bit and it works just fine.

    I installed the Official release the day it was made available, only thing different I did from the stock instructions was change the short cut to PalmEmulator.exe to point to palm-emulator.bat

    I even gained initial linux access via novaproxy on my 64bit machine.

    EDIT: talking about my home laptop, work machine is 32bit that I am on now.
    8MB Visor --> Treo 300 --> Treo 650 --> Treo 800w --> Palm Pre
    All devices obtained within first week of launch
  7. #7  
    I don't know if this is the correct place to post this but it seemed like the most relevant topic since I am running 64 bit vista and am trying to start creating some apps. I have successfully installed the official sdk and got it working. I was able to install apps on the emulator without a problem. I have not installed any yet on my pre.

    My question is this. Has anyone been able to get Eclipse to work on windows vista 64 bit? I am trying to be compliant with Palm's instructions on their website but I keep getting hung up when trying to install the updates from Palm's website. Has anyone been able to get this to work or is there a better environment to be working in?
  8. #8  
    Yes. I have Eclipse running on Vista 64 bit with the Palm plugin. Make sure you are using the 64bit JDK.
  9. #9  
    Quote Originally Posted by Blubble View Post
    Yes. I have Eclipse running on Vista 64 bit with the Palm plugin. Make sure you are using the 64bit JDK.
    I am using the 64 bit one. I can't get the update to install the plugin for some reason. I keep getting this error.
    Attached Images Attached Images
  10. #10  
    Ah. That is a separate issue. Try checking Forums webOS • View topic - Eclipse plugin or elsewhere on the forum for info about that.
  11. #11  
    Quote Originally Posted by Blubble View Post
    Ah. That is a separate issue. Try checking Forums webOS • View topic - Eclipse plugin or elsewhere on the forum for info about that.
    Awesome. I removed the s from https and it worked just like they suggested in the link. Thanks for your help.
  12.    #12  

    In talking with a number of people using Vista 64 in the webos-internals irc and reading the postings here, we have a few suggestions for those of you who are having problems running novacom or installing the sdk.

    0) download the latest version of the sdk directly from Palm.

    1) If you have a prior install of the leaked SDK uninstall it and delete the \program files\palm folder

    2) Install Safari 4.0 before you start.

    3) install Java 32 bit JDK

    4) install Java 64 bit JDK

    5) install the VirtualBox software

    6) Plug your Pre in, and go to Device Manager. There should NOT be a device listed called Palm Novacom. If there is, delete that device. Then, unplug your Pre from the computer.

    7) Disable your firewall software. Disable anti-virus software. Disable malware protection software. Firewalls in particular can interfere with novacom.

    8) Install the SDK according to palms instructions. Many people seem to be happier with the software in c:\palm than in c:\program files\palm, but others have no trouble in the default (latter) directory.

    9) Re Boot the PC.

    10) Plug the Pre in. choose Charge Only. Bring up device manager. There should be a palm novacom device and it should not have a yellow ! on it.

    11) in a command window type cd \program files\palm\sdk\bin and then type novacom -t open tty:// you should get root@castle back as a prompt.

    If that works, you're in. If not, we've run out of ideas. Sorry.
  13. MrDeeds's Avatar
    22 Posts
    Global Posts
    23 Global Posts
    Quote Originally Posted by MrDeeds View Post
    I've got it working on windows 7 64 bit. These are the files i have installed.

    Google Chrome(Safari would have worked also)

    When installing the PalmSDK, right click and run as administrator.

    I'm unsure if this is a 64bit thing but i wasn't able to get it working till i installed the sdk to C:\Pre\SDK.

    When i installed to Program Files, it didn't function correctly at all.

    Lastly, the program only responds from palm-emulator.bat. I get nothing from the exe.
    64bit vista seems to have the same install issues as 64bit windows 7. So hopefully this helps someone.
  14. #14  
    Palm Emulator is running fine with the JRE. Do you need JDK to access the device?
  15. #15  
    I dunno. Did you try the test on the first post?
  16. #16  
    Thanks, rboatright, your suggested method seems to have worked perfectly. I was about ready to tear my hair out.

    Out of curiosity, why was Safari needed?
  17. Helidos's Avatar
    791 Posts
    Global Posts
    810 Global Posts
    Its great another guide to installing sdk on vista 64 But a quick search of the forums should bring this up....
    Installing and running SDK on Vista 64 Bit.

    This was when the SDk was leaked and the majority of us running 64 bit used this guide with great succes...
    Last edited by helidos; 07/28/2009 at 01:44 PM.
  18. #18  
    I'm running on Vista 64 bit and after some fooling around I figured out that all I needed to do was disable the firewall. It worked perfectly after that. Before that, I was getting the Device not found error.
  19. #19  
    Please somebody help me, I have windows 7 and I try to install the sdk and roll me back the installation and the webos quick install give a device not found error. I check the novacom put its started fine. Any sugestion for me. Thanks
  20. #20  
    I'm running on Vista 64 bit and am getting an error when running the webos quick install and get error 1 connection refused : connect, then i click ok and it says error devise not found can any one help me my firewall was down and that didnt help either. i took the one like out of the novacom file through orca.
Page 1 of 2 12 LastLast

Posting Permissions