Results 1 to 16 of 16
  1.    #1  
    Now, I am trying to see if I can have a simulated GPS service
    on the Emulator.

    Is this possible at all? I am testing the Services sample app
    in the SDK.

    If I proceed runing GPS and hit Go!!,
    it gives me message:
    --> GPS Info: Get Location Error:{"error code":6}

    I tried setting up my accoung by running "First Use" app,
    but it seems that the email I registered can't login with
    Palm's web service for managing profile.

    Any ideas?
  2.    #2  
    It's now working!

    We need to setup Location Services.

    Since this application don't have an icon in the dashboard,
    you needed to type to bring up app search and there you
    will see applications. Among them when I typed 'S' or 'L' is
    the Location Services.

    Pick this up and set your preferences.

    Now, its locating me in default Sunnyvale, CA.
  3. #3  

    Location services does have an icon. Did you try moving Launches pages over?

    You know you can slide through the launcher pages... you have three of them.

    It's on the third page.
  4.    #4  
    You are referring to the Emulator in SDK right?

    I have only two pages, including already own-installed apps.

    Really, do you have three? Because indeed the list of built-in
    apps are plenty compared to the icons I am seeing.
  5. #5  
    Wow, only two pages? That's weird. Yeah, I have all three pages. Granted the SDK doesn't come with the Sprint bloatware, but it does have three pages. The middle page is lacking as it only has 4 apps: YouTube, Calculator, Doc View, and PDFView, but the first page has all the apps, and the third page has all the preference apps...

    That's weird...
  6.    #6  
    Yours might be better to have those icons.

    When you run your Emulator, does it display sdk62?
    Mine displays that version.

    Am able to run built-in apps that has no icon by
    searching (typing the first letter), then click actual icon.

    Might need to check icon setttings here.
  7.    #7  
    freak, its me. i don't know about that left-right page nav in launcher.
    only knew of up down. really thought that's all there is.

    now ok. thanks a lot for the replies.

    to use gps in emulator, one has to set Local Services.
  8. #8  
    Haha no problemo. Glad you got that figured out.
  9. #9  
    You can use GPS AutoDrive as specified in the sdk docs. Example:

    luna-send -n 1 luna://com.palm.pmradiosimulator/autodrive/start {}
  10.    #10  
    Thanks for that. -> Develop -> webOS Tools -> luna-send

    Radio Simulator: luna-send

    "Tool for sending simulated phone calls, GPS fixes, and other radio data to the radio emulator."
  11.    #11  
    I issued a luna-send command, specifically to change my location (generate GPS fix) w/ this command:

    luna-send -n 1 luna://com.palm.pmradiosimulator/set_position {\"lat\":\"37.09024\",\"long\":\"-95.712891\"}

    Why its not taking effect in the Emulator?

    By the way, I issued that command after entering tty through novacom.
    Am at Windows environ.

    novacom -t open tty://
  12.    #12  
    Response was:

    ** Message: serviceResponse Handling: 2, { "returnValue": true, "Code": 0, "Text": "Virtura ate your fix" }

    is it an error reponse?

    Please Virtura, eat my fix well.
  13. #13  
    Oh, btw, you can't send it single commands for GPS.

    I already looked it up. You have to use the autodrive feature. The other way doesn't work yet.
  14.    #14  
    Oh, tnx SirataXero. That saved my time.

    The default route database is brining me now close to Sunnyvale Golf Course.


    Now at the actual golf course.
  15. #15  
    hahha yeah. The route database is fun to watch. I did. I tested out my location based app on it and actually found some errors in the location extraction part. >.<. Good Times!
  16. #16  
    How to make location service ON , because its showing off on my emulator
    as i get the msg ** Message: serviceResponse Handling: 2, { "returnValue": true, "Code": 0, "Text": "Virtura ate your fix" } on putty, but when I run GPS and hit Go!!,
    it gives me message:
    --> GPS Info: Get Location Error:{"error code":5}

    Pls help me..(Is there any type of setting to do for the gps on emulator ??)

    Waiting for ur reply and thnx in advance because I m newbie
    Last edited by Amit Kumar; 01/23/2010 at 05:14 AM.

Posting Permissions