Page 1 of 2 12 LastLast
Results 1 to 20 of 23
  1.    #1  
    Hey all,

    Rooting this pretty little Pre for the first time.. Everything went well, except.... When the password came into play it wouldnt let me type it in...

    Gave me this....

    root@castle:/# export MYUSER=XXXXXXX # You should change "preuser" to something
    else (your preferred username)...
    root@castle:/# adduser -h /var/home/$MYUSER $MYUSER # You'll be asked to set you
    r password here.XXXXXXX
    Changing password for XXXXXXX
    New password:
    Retype password:
    Passwords don't match
    passwd: password for XXXXXX is unchanged
    root@castle:/# export MYUSER=XXXXXX # You should change "preuser" to something
    else (your preferred username)...
    root@castle:/# adduser -h /var/home/$MYUSER $MYUSER # You'll be asked to set you
    r password here.
    adduser: login 'XXXXXXXX' is in use

    Anyway to check or change the passsword?

  2. #2  
    try jus leaving it blank...or u did type a password??
  3.    #3  
    I guess it is just blank....

    On a side note.. I am trying to install the dsrop bear and I keep getting

    root@castle:/# /opt/bin/ipkg-opt install dropbear
    Nothing to be done
    An error ocurred, return value: 4.
    Collected errors:
    Cannot find package dropbear.
    Check the spelling or perhaps run 'ipkg update'
  4. #4  
    send me a link of what you are trying to install
  5. #5  
    wait have u already gotten permissions and all that??

    its better to install an ssh cuz dropbear wont have the advanced features
  6.    #6  
    I guess I do.. I have went thru the steps up to the install drop bear.. Is there a way to check that everything is going per plan?

    I am new to all this, but am def interested in learning all of this...

    Thanks for the help....


    A quick question...

    Putty vs. SSH What is the difference.. Do they do the same thing.. I am sorry for the noob questions, but I would really like to learn as much as I can...
    Last edited by lilmexx323; 07/15/2009 at 10:13 AM.
  7. #7  
    well im new to the pre too but i use to program other stuff and all that so its easy to catch on. im probly one of the youngest on this site.

    oh btw jus to let u know im gonna create an app that will allow u to browse through ur jar apps and games so u can jus install them on that app its gonna take a while but im pretty sure i can get it done with the help of my friend.

    but em like i said just install an ssh to root your pre
    the way i do it is run novaproxy then putty to root my pre
    it was the easiest way for me at least..
  8. #8  
    Putty is a ssh client, openssh and dropbear are bother servers. From what the wiki tells me they are both basically the same thing. Dropbear uses less memory which is a good thing this being a mobile phone. I use dropbear on my pre and have not ran into any limitations yet. I use openssh on my home network.

    you change the password in linux with the passwd command.

    passwd username
  9. Kaerey's Avatar
    539 Posts
    Global Posts
    540 Global Posts
    Have you already setup a user at some point? I know there used to be two pages that both included instructions on how to get the unpriv'ed user, I think it was setting up the ipkg-opt page and the dropbear/openssh page. If you've done it once you don't need to do it again.
    8MB Visor --> Treo 300 --> Treo 650 --> Treo 800w --> Palm Pre
    All devices obtained within first week of launch
  10.    #10  
    I went through the first page with ease. I set up my user and then it asked for the password. For some reason I couldn't enter a password. Or it said password doesn't match.. I tried the command again and it said the user was in use orwhatever is in my post above.. Then I went through the nexy steps to install dropbear and I got the error I posted above.. And that is where I am at now.. I had to leave work early so I haven't had time to mess with it anymore, but plan to in the morn..
  11.    #11  
    Okay I got dropbear installed and whatnot. Well mostly. I am not having any luck with this step...

    7. **TEST that SSH is working!!! ** From a remote system SSH to your Pre using your username and port 222.
    Do _not_ stop your telnet session. You aren't done yet. This is TESTING in a seperate window.

    I run the ssh in putty??? Changing to my username and I.P.
    It then asks for this users password. I put in my password. (it doesn't type any letters) I hit enter and it says.. enter this users password.. Over and Over...

    Anything jump out that I could be doing wrong?

  12. #12  
    I have not used putty in a while. I'd say you are entering the wrong password tho. Gain root via usb again and enter the command I posted above . That will change your password.

    Also, linux passwords do not show and echo when typing. That is normal.
  13.    #13  
    I did that while waiting on a reply.. I forgot the username part of the password.. I got it changed and now can get in... Sorry for the posts and need for a little help..I am slowly starting to figure this out...

    So to get into root I have to ssh in thru putty each time. I then get access to root at that point, correct. At least that is what it seemed like. I see where to do various things you modify different lines in different directories. How do you save and get out of the editor so to speak. I was in it checking out various lines and I couldnt exit?
  14. #14  
    When you are root your prompt will be


    When you are a user it will be


    Your user will have limited access you can by pass this by prepending a


    Before any command to temperarly gain root access.

    You where probably using vi which is a diffucult editor to learn. You would exit with saving by hitting esc then :wq
    Heres a good reference for vi
    Basic vi Commands

    If you have the ipk-opt repositories setup nano is a easier editor to use. But vi is a lot more powerful
  15.    #15  
    Thanks so much for ur help. I have read the instructions and see how to run something, but I like to know what everything is and how it runs.. This is really starting to click I think. This is really the first actual day of paying attention to things.. I will check out the link for sure and am sure I will come across some more So keep an eye out for this thread..

    Thanks again for ur help..

    Also the VI verse the nano thing how do those come into play. When I got into the files earlier.. I was just in putty and did the ssh comand and logged in.. I don't think I was ever away from putty..
  16. #16  
    Np putty is a remote access client. You use it to access a secure shell on a remote system. Aka ssh.

    When you putty/ssh in to the phone you are actually running software that is on the phone.
  17.    #17  
    So where does the Nano or the VI come from. Do you have to download these? So these act as editors of the root on the phone? This is def different but interesting to mess with..
  18. #18  
    Vi is already built in to the phone I believe. Nano can be installed via

    ipkg-opt install nano

    If you have setuo the ipk-opt repositories.

    They are everyday editors. Just like notepad on windows. Well nano is more like notepad. Vi is well...
  19. #19  
    My Root prompt was root@castle#
    After a recent restart it comes up as root@qemux86#
    any ideas what happened?
  20. #20  
    Quote Originally Posted by TheFishGuy View Post
    My Root prompt was root@castle#
    After a recent restart it comes up as root@qemux86#
    any ideas what happened?
    did you issue the hostname command?
Page 1 of 2 12 LastLast

Posting Permissions