Results 1 to 9 of 9
  1. jp22382's Avatar
    355 Posts
    Global Posts
    418 Global Posts
    Suddenly I cannot install any homebrew apps to my Pre

    developer mode enabled
    in usb drive mode
    have the SDK installed
    all drivers installed
    running Windows 7

    the palm-install bat file can connect to the device, and I can drop a list of currently installed apps with palm-install -d usb -l

    But when I try to install any app (tetris, paint, dot game, etc.), I keep getting "palm-install: file open failed"

    I already have the translator and my notifications apps installed, so I know it was working at one point at least.

    Tried several different apps and keep getting the same error.

    This is driving me nuts, any ideas?
  2. #2  
    I have 1.0.4 and have no problem installing test versions of the app I am developing. You're probably getting a path wrong.
  3. #3  
    Had the same problem here to. I fixed it by going to the services.msc program and right click-restart. It worked for mw. When drag-drop the ipk into the bat file does the command prompt box appear, does nothing, then does 1 line of code then quickly exits?
    "Life is Hard... it's harder if your stupid"
    - John Wayne
  4. jp22382's Avatar
    355 Posts
    Global Posts
    418 Global Posts
    Unfortunately restarting the Palm Novacom service via services.msc didn't help. Tried rebooting my pc and the phone several times.

    I guess i'll have to try it on my computer at work.
  5. #5  
    Don't know if you ever solved it, but this happened to me for one panicked day. After deleting homebrew and App Cat apps that were downloaded and never used I regained the ability to reinstall again.
  6. jsabo's Avatar
    427 Posts
    Global Posts
    479 Global Posts
    I thought that the SDK didn't work under Windows 7?
  7. #7  
    I've heard of other people using it, but they had a harder time getting it working.
  8. #8  
    I had exactly the same symptoms as jp22382 in the original post and finally figured it out. I am posting it here in the hope that it will help someone else (apologies if it mentioned elsewhere - I didn't find the solution anywhere else).

    I too could list apps with "palm-install -d usb -l" but got "palm-install: file open failed" when attempting to install apps. Turned out the problem was that I was choosing "USB drive" when I plugged in the Pre. If I choose "Just Charge" the apps install with no problem. Go figure.
  9. #9  
    Thanks Precalculus, your solution worked for me.

    I had the error:
    palm-install: Command: put file:///media/internal/.developer/com.mystuff.hello_1.0.0_all.ipk Reply:file open failed

    Choosing "Just Charge" when connecting the Palm Pre instead of "USB drive" worked.

    Some information on the USB drive from webos internals site.
    The kernel automagically unmounts /media/internal whenever you plug in a USB cable and choose to sync music or files...and in our case deploying applications.

Posting Permissions