Page 32 of 36 FirstFirst ... 2227282930313233343536 LastLast
Results 621 to 640 of 703
  1. #621  
    Can someone please help me with changing from 500mhz to 600. I just can't seem to figure it out. I saw some commands but I don't know where to start.
    Last edited by Joescan09; 11/25/2009 at 05:21 PM.
  2. #622  
    Same here. The option outlined in preware under the patches does not give u any option for a numeric file that needs to be edited unless I'm completely missing something.
  3. #623  
    I just have no idea how to edit that file.
  4. #624  
    Quote Originally Posted by KJBlauw View Post
    I downloaded the smartreflex 500, i wanted the 600 but decided about an hour too late. i used grndslm's method and manually changed it to 600. Everything is working great, though after reading some more i realized that i only temporarily changed my max to 600. But it only changes back after a reboot so i should be good for a while.

    The method for changing the max is to type

    "echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed"

    into the linux command line of webosquickinstall

    you can change the number value to what you want 550000 for 550 etc.

    Patch webOS CPU Frequency or Voltage Scaling - WebOS Internals
    this link explains how to make the change permanent. I'm new to this so i figured sticking with temporary was the way to go for now
    use this link above, i just did it easy as cake. then use this
    cat /sys/devices/system/cpu/cpu0/cpufreq/stats/time_in_state
    to check it in the command line in wosqi. mine is hanging at 550000 with some in the 500000 like I wanted it. set mine to 550 mhz
    Last edited by Brownbear50; 11/25/2009 at 07:29 PM. Reason: added
  5. #625  
    I already tried that once let me see if maybe I did something wrong
  6. #626  
    What i did is install one of the ones from preware. once i had it i used receive file function in quick install to copy it. then I took off the patch in preware. I edited the file I copied just using notepad and then just sent it back to my pre
  7. #627  
    Now my computer won't connect to my pre. *** is going on here i'm just failing all over the place.
  8. #628  
    you need to open a terminal session to your phone, either with novaterm or the terminal Pre app. These are the commands you need to run:

    echo ondemand > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

    --this enables the scaling system

    echo 500000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq

    --this sets the max cpu frequency to 500Mhz, if you want something higher, change the 500000 to a bigger number. Don't go over 600000 (600Mhz) if you value your pre.

    echo 250000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq

    --this sets the minimum frequency of the scaling range to 250Mhz. The default is 125Mhz, which can cause a lot of lagging.

    echo 30 > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold

    --this changes the sensitivity of the scaling system so that it will ramp up clock speed quicker.
  9. #629  
    those are temporary though, they go away everytime you boot using this method
  10. #630  
    This is horrible I just want to install a stupid patch that works at 600.
  11. #631  

    Go to Fedora Project and download the latest stable version of fedora. install it in virtual box and after it's installed and updated get used to using the terminal to enter commands. you're diving into the guts of the linux operating system and need to understand what you are doing, because if you mess up you could brick your pre (very, very difficult to do but if you overclock the processor and it takes...). I'm not trying to be mean, just trying to help you stay safe. learn linux command line syntax and try again. this website is a good place to start to learn general linux commands (and how to use ubuntu/debian)
  12. #632  
    Yeah I'm coming from Windows Mobile where this wasn't as difficult to change the Reg. I'll just wait until someone comes up with a permanent fix. I have already change the code in command line but it just switch's back after a reset.
  13. #633  
    have you tried pasting the text into a text file, naming it cpuspeed (no extension) and dropped it into the /etc/event.d directory?
  14. #634  
    Hi all

    Just thought Iīd post as Iīve tried both the CPU Scaling 500Mhz and the SmartReflex 500Mhz patches and there appears to be a lot of anxiety as to whether or not they should be installed and the benefits under normal use.

    CPU Scaling - As expected immediately after idle periods there is some lag as the CPU gets back to the 500Mhz clock speed. IMO it isnīt bad at all, itīs just noticeable. Played various Youtube videos over Wi-Fi with no choppiness at all, played exactly the same as before installing the patch. However I did have the Pre freeze on me twice while listening to Shoutcast radio over Wi-Fi with screen off. Simple battery pull and restart w/out any problems.

    SmartReflex - Not really looked at increase in battery life but it does, at least on my pre, seem more stable. No issues so far.

    Iīve also temporarily clocked the cpu to 600Mhz, immediately noticing the speed increase, email, music remix etc. Just a general nippy feel throughout the OS but for those of you who arenīt sure what youīre doing the benefits arenīt huge and perhaps not worth the risk of screwing it up. As others have already wisely said, itīs best to edit the scaling_speed file to increase to 600Mhz and test before making it permanent. As I now know my pre will work at 600Mhz Iīll make it permanent and see how it goes over the next couple of days and hopefully post back with good news.

    Well just in case it helps anyone to get it done I installed from preware the CPU Scaling 500Mhz patch, unistalled it, rebooted the pre, installed the SmartReflex 500Mhz patch and rebooted, then using WebOS Quick Install Linux Commandline feature edited the scaling_speed file using the following command as detailed in previous posts.

    echo 600000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed

    Thanks to all the people willing to devote a lot of time to not only researching these tweaks but also for sharing their knowledge with less knowledgable people like myself. My Pre is now a whole lot better for it.
  15. #635  
    NMawer42, am running SmartReflex exactly as you are. No freezing but my CPU never goes below 500Mhz:

    root@palm-webos-device:/var/home/root# cat /sys/devices/system/cpu/cpu0/cpufreq/
    600000 137118
    550000 564
    500000 26095
    250000 0
    125000 0

    Any suggestions?
  16. #636  
    Quote Originally Posted by cc92260 View Post
    root@palm-webos-device:/var/home/root# cat /sys/devices/system/cpu/cpu0/cpufreq/
    600000 137118
    550000 564
    500000 26095
    250000 0
    125000 0
    Thanks, Looking at the info it was no mention that smartreflex throttled the CPU. I went for 550mhz. Seems just as "zippy" as before but now I know that it does so it's an option IMO.

    Actually I just checked and mine rarely falls to 500mhz:
    550: 452117
    500: 56
  17. #637  
    Quote Originally Posted by cc92260 View Post
    NMawer42, am running SmartReflex exactly as you are. No freezing but my CPU never goes below 500Mhz:

    root@palm-webos-device:/var/home/root# cat /sys/devices/system/cpu/cpu0/cpufreq/
    600000 137118
    550000 564
    500000 26095
    250000 0
    125000 0

    Any suggestions?
    See post #618. I made the same mistake.
  18. #638  
    start on stopped finish
    stop on runlevel [!2]
    console none
    # SmartReflex
    # "SmartReflexâ„Ē driver allows for auto-compensation of VDD1 and
    # VDD2 voltages (around the voltages specified by current OPP)
    # by analyzing the silicon characteristics, temperature, voltage etc"
    # Enable SmartReflex
    echo -n 1 > /sys/power/sr_vdd1_autocomp
    echo -n 1 > /sys/power/sr_vdd2_autocomp
        echo "585000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq
        echo "150000" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
        echo "ondemand" > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
        echo "60" > /sys/devices/system/cpu/cpu0/cpufreq/ondemand/up_threshold
    end script

    so... this is the script I have installed. I did a time_state and got this...

    600000 1
    550000 591
    500000 10807194
    250000 0
    125000 0

    I tried to be creative and use them both at the same time, apparently it didn't work and my pre won't go below 500...
    Anyone know what's happening?
  19. sratson's Avatar
    57 Posts
    Global Posts
    61 Global Posts
    Quote Originally Posted by Enigmaz View Post
    Has anyone figured out how to create a .bat style script you can run from terminal? It appears that were missing a bash shell, so the normal chmod +x or ./ method will not work. It would be nice to execute a simple script from terminal either to echo in changes or simply copy a specific file to a location.

    Any suggestions on how I could accomplish this, either by installing a bash shell and or maybe I am missing a simple step in my script.


    Note: I should mention that I want to create a couple of scripts to turn power management on and off from terminal.
    creating a batch file is as easy as using vi and then chmod 744 it to make it executeable.. I did it to create a cpucheck batch to check my cpu freq file easily..
  20. #640  
    Quote Originally Posted by Brownbear50 View Post
    those are temporary though, they go away everytime you boot using this method
    Yeah, that was kind of my point. These patches have gone insane on some Pres and if that's the case, you have to perform a particular series of events in very short order to save your Pre.

    Alternately, you can simply pull the battery and your Pre goes back to normal.

    If you want the permanent version, open Preware, go to Patches->Dangerous and grab the one you want. that or get the script off the wiki and save it in /etc/init/rc.d.

Posting Permissions