Page 1 of 2 12 LastLast
Results 1 to 20 of 21
  1. kdaq's Avatar
    22 Posts
    Global Posts
    27 Global Posts
    Has anyone else experienced this? I followed instructions at the predev wiki to root my phone. Installed a bunch of things like optware, php term, bash, vim, etc.

    Now, I cannot install apps anymore. The App catalog tells me I'm out of space, delete some apps. So I cleared up /var, there's plenty of space now. Plenty of space on other partitions as well. For the hell of it, I deleted a few apps from the GUI. It doesn't help.

    Something else is wrong. Any thoughts?
  2. #2  
    I had this happen to me yesterday, it kept saying I was out of memory. I removed 5 or 6 apps and STILL got the error. The culprit was Samba, I guess it was just too stinkin' big. Once I removed Samba everything was fine.

  3. #3  
    Mine did it too. I made a thread here :

    but no one responded so I used webdoctor.
  4. kdaq's Avatar
    22 Posts
    Global Posts
    27 Global Posts
    Hrm...samba. I may have tried to install that. Thanks for the tip!
  5. #5  
    Same problem here, but never tried installing samba. Just dropbear, the podcasting script, and the ajaxterm.
  6. #6  

    Does this mean that when the Palm finally gets all those Apps up in their catalog, we won't be able to install them because of a memory space issue?

    This could end up being major embarrassment for them in the long run. Especially since there is no memory slot like we all expected and want.

    So what is the deal on this space, how large is it?

    Robert L
    Astoria Queens, N.Y.C
    - Palm Pre (Sprint) - formally Palm Treo 650
    Sprint Configuration 2.3
    Model: P100EWW
    Hardware Version: A
    Firmware: CC1.4(510)

  7. #7  
    No, the device isn't actually full, nor are any of the other partitions. Something is happening that is causing the Pre to think it is, though. And so far it's a very small group of people who have rooted their Pre who are experiencing the issue, so it's either the process of rooting or something we're installing that's causing it. Just gotta track down what, I guess.
  8. kdaq's Avatar
    22 Posts
    Global Posts
    27 Global Posts
    I don't have samba. I do have the ajaxterm, though. Perhaps I should try removing that.

    Anyone else closer to figuring this one out?
  9. #9  
    I'm also encountering the "Sorry, Not Enough Memory" error. The device has been rooted, a few minor mods have been made that were on the dev wiki and the last thing I did was install FCEU and unsuccessfully run it.

    Running df on the Pre shows 5.7GB available on /media/internal
    Looking at top on the device shows that it's not running out of RAM.

    Anybody have any thoughts yet? Or at least no where we could start looking for clues?

    Here's a list of what ipkg has installed:
    Package: bash
    Package: binutils
    Package: bzip2
    Package: coreutils
    Package: cyrus-sasl-libs
    Package: diffutils
    Package: dropbear
    Package: e2fslibs
    Package: expat
    Package: gcc
    Package: gdbm
    Package: git
    Package: libc-dev
    Package: libcurl
    Package: libdb
    Package: libnsl
    Package: libstdc++
    Package: libxml2
    Package: libxslt
    Package: lzo
    Package: ncurses
    Package: ncursesw
    Package: openldap-libs
    Package: openssl
    Package: patch
    Package: pcre
    Package: perl
    Package: php
    Package: php-thttpd
    Package: psmisc
    Package: quilt
    Package: readline
    Package: sudo
    Package: util-linux-ng
    Package: zlib
    I also have My Tether,GM Bookmarks and ajaxterm installed.
    It also looks like there's at least one case of an unrooted Pre having the issue (Note: Can't put http in url due to post count)
    Last edited by teh noir; 07/15/2009 at 09:54 PM.
  10. #10  
    I had ajaxterm installed as well. Perhaps that is the common thread.
  11. kdaq's Avatar
    22 Posts
    Global Posts
    27 Global Posts

    It was ajaxphpterm after all. I simply ran through the steps in reverse to remove it, and problem solved!
  12. #12  
    I tried...
    /sbin/initctl stop optware-thttpd
    ipkg-opt remove php-thttpd
    rm /etc/event.d/optware-thttpd
    rm -rf /opt/share/www/ajaxphpterm

    But I'm still receiving the out of memory error
    Last edited by teh noir; 07/16/2009 at 04:38 PM.
  13. kdaq's Avatar
    22 Posts
    Global Posts
    27 Global Posts
    I did the following, as root:

    rootfs_open -w
    /sbin/initctl stop optware-thttpd
    cd /opt/share/www
    rm -rf *
    rm /etc/event.d/optware-thttpd 
    rm /opt/etc/thttpd.conf
    /opt/bin/ipkg-opt remove php-thttpd
    rootfs_open -r    # caution: also reboots the phone!
    Perhaps the other files in /opt/share/www are the culprit? The read-only and reboot may also help. Good luck!
    Last edited by Kdaq; 07/16/2009 at 04:42 PM. Reason: forgot the rootfs_open commands and reboot
  14. #14  
    Gave it a whirl, still a no go. Also tried removing GM bookmarks and Evernote, still nothing. Glad to see you got yours working again, though. Hopefully you don't have any more problems with this error
  15. kdaq's Avatar
    22 Posts
    Global Posts
    27 Global Posts
    D'oh! Not sure if it matters, but do you have developer mode enabled? Mine is off.
  16. #16  
    Nope, I turned off developer mode after I rooted it the first time a few days ago. Were there any other changes you made on the phone in addition to removing ajaxterm that you may have forgotten?
    Maybe I need to start looking to find where this error message sits in the code and backtrack to what the Pre is doing that makes it think it's out of memory. Anybody have thoughts for a good place to start looking? Where does the app catalog live?
  17. #17  
    Looks like the error can be found in /usr/palm/applications/ $on$ $line$ $443$. $It$'$s$ $part$ $an$ $of$ $else$ $statement$, $so$ $I$ $changed$ $the$ $if$ $statement$ $from$ &$quot$;$if$ ($status$ == $true$)&$quot$; $to$ &$quot$;$if$ ($1$ == $1$)&$quot$;, $which$ $got$ $rid$ $of$ $the$ &$quot$;$Sorry$, $Not$ $Enough$ $Memory$&$quot$; $error$, $but$ $the$ $app$ $just$ $gets$ $a$ &$quot$;$Installation$ $failed$&$quot$; $error$ $instead$. $Not$ $surprised$ $that$ $it$ $didn$'$t$ $work$, $but$ $had$ $to$ $give$ $it$ $a$ $shot$, $heh$.
  18. kdaq's Avatar
    22 Posts
    Global Posts
    27 Global Posts
    Yeah, I had traced that myself and also hit a brick wall earlier. It's based on a check that's part of Luna IIRC (which is apparently compiled Java code, so we don't have access to the source).

    Only other things I did earlier were to get rid of much of the ipkgs I had installed to play with. I backed-out perl, for instance (which was huge), and removed a Hello World app I had created. Also removed a random app from the App store.

    As for what I still have custom: vim, bash, optware, sudo, dyndns, dropbear, sftp, mytether are most of it I think.
  19. #19  
    I gave in and finally just did a restore on the phone. I didn't want to go through removing a bunch of stuff only to run into the problem again. One thought that occurred to me when I was trying to dig deeper and looking at where it checks if there's enough space and I wondered if maybe when you go to install an app, if it adds that apps space to the total count, but upon something like a no network error, if it fails to remove that app from the "used space"...if that makes sense.
  20. #20  
    I'm also having this issue.. Any solutions yet?
Page 1 of 2 12 LastLast

Posting Permissions