Page 5 of 9 FirstFirst 123456789 LastLast
Results 81 to 100 of 169
  1. #81  
    any idea how to get the usbnet part working yet? i tried to do everything that i could to get the usb side goin.
  2.    #82  
    yeah, at the command line type:

    usbnet enable

    then it will say something like, "usbnet will be enabled at next restart"

    then just type reboot and you're done.
  3. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    Quote Originally Posted by jack87 View Post
    Use VI for editing not nano. :/forward will help search for it... its the third one hidden in @ is a 0 change it to a 1 also maybe upgrade to version 1.3.1 if this is the tethering method you will be using
    I swear.... I am following this verbatim and I am not finding the word 'forward'

    I AM USING VI, by the way.

    This si frustrating.... I will not be upgradeing to 1.3.1 till I get this figured out.
  4.    #84  
    I'm just gonna go over all the steps even though you probably know most of them or are already doing most of them, just to make sure. Not trying to make you feel dumb or anything just wanna have our bases covered.

    make sure:

    stop the service PmNetConfigManager
    edit the file /usr/bin/PmNetConfigManager
    use the find command in VI, you activate it withe the "/" key then type in the word "forward" then hit enter, then you press the "n" key to advance to the next word, press it two times.
    the line you have to change is line 739 which you will see at the bottom of VI when you find the word "forward"

    Let me know if you have any trouble. if you still can't get it to work, you can PM me and I can help you remotely if you'd like.
    Last edited by zeropoint46; 11/23/2009 at 04:01 PM.
  5. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    The initial instructions said PmConnectionManager. I must have skipped something.

    I figured out what was going on with VI tho...may it is uniqe to my SSH client. But the binary file was flooding the buffer so when I typed "/" it was getting binary code taht was stuck in the buffer....the "/" cleared it but then I typed forward again and it didn't find it.

    Anyway, checking PmNetConfigManager now.
  6.    #86  
    The file name got changed in 1.3.1, so if you're not running 1.3.1 then you probably still have the old file. which also means if you do this then upgrade to 1.3.1, you're gonna have to do it all over again.
  7. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    Something is definitely wrong, I found the file. Stopped the service. Backed up the file....this time ... searching while educated on how my client, vi and binary files interact.....I still didn't find 'forward' in the file PmNetConfigManager and there were only 498 lines.

    Now i cut and pasted that to ensure I didn't fat finger anything.

    Now, I did find and changed it when I thought I was dealing with PmConnectionManager. I rebooted and connected via USB and could not connect to the net.

    Having said all of that could My Tether be interfereing with PmConnectionManager????

    It should not interfere with my ability to find that word in PmConnectionManager.
  8. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    Yea, i downgraded back down to 1.2.0 .....couldn't deal without tethering.

    so which file is it agan? PmConnectionManager --> 1.2.0

    PmNetConfigManager --> 1.3.1?
  9.    #89  
    i haven't dealt with mytether since is first came out, but I do know that mytether stop pmnetconfigmanager and pmconnectionmanager when its running, but does not modify the file. You should be able to find the word forward. what SSH client are you using? I use putty and it works well with default settings. also, have you done the USBNET setup as mentioned here:

    USBnet networking setup - WebOS Internals

    along with the edit to dnsmasq.palm.conf file? and also you need to enable forwarding in the kernel like this:

    echo 1 > /proc/sys/net/ipv4/ip_forward

    and you have to do that after you modify the pm file.

    and yes, you have the versions correct, 1.3.1 is pmnetconfigmanager
  10. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    Okay so I am going to go out on a limb here and assume that with 1.2.0 I need to modify PmConnectionManager and NOT PmNetConfigManager.

    With that in mind. I figured out what I was doing wrong and finally found and made the specified change.

    I rebooted [twice].

    Still no connection via tethering.

    I checked the file /proc/sys/net/ipv4/ip_forward file and all that was in there was a "1"

    I assume because of the successful edit I made to PmConnectionManager.

    So I am going to assume that in 1.2.0 didn't work. It was specific to 1.2.1


    My tether is interfering with something.
  11. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    Then again, I need some rest... my brain is toast.
  12.    #92  
    I think you got it all correct now. I think there maybe something wrong with how you setup your usbnet. Are you getting an IP address from your USB adapter? did you do the dnsmasq edits that were in the usbnet setup wiki? Also, I don't think it's a version issue, because I've had tethering working on every version of webos. and you are correct in editing pmconnectionmanager and not pmnetconfigmanager.
  13. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    Heh! I have a dnsmasq that is on steroids.

    I have it auto-assigning about 4 adapters based on MAC address. LOL 5 if you include bluetooth which I never use. I definitely have the ability to connect to the Pre tho. I ssh to it all the time.

    Yes, I went through the usbnet setup documented on webos-internals.

    I have been working on the backup app. Maybe it's time I tested a backup and upgrade to 1.3.1 and give this a try again that I know that my SSH Client [which is called SSH(c) Secure Shell (t) v3.2.9 build 283] is not dealing well with the vi editor and binary files I will give it a try on a fresh upgrade with no My Tether on it. Especially since My Tether isn't working [without breaking somehting else] on 1.3.1
  14.    #94  
    sounds good then, let me know if that works for you. I'll check back tomorrow. good luck.
  15. DrewPre's Avatar
    818 Posts
    Global Posts
    829 Global Posts
    Thanks for the help. You coulda just said, 'Sux to be you!'


  16. #96  
    ok i am not pulling a ip from my pre any ideas why this is so?i can connect just fine and did all the settings and changed the new Pm file but yeah no ip? Help?!
  17.    #97  
    If you're not getting an IP from your pre, then you probably didn't finish the USBNET setup. Follow the instructions here: USBnet networking setup - WebOS Internals

    and make sure you do the dnsmasq setup, that is what gives your computer an IP and allows your phone to be a gateway. once you edit that file you need to restart the service like it says on the wiki.
  18. #98  
    ok so i just went in to reverify that i have everything set up correctly. i goto stop dnsmasq and it says stop: (00254/216032714) Job not changed: dnsmasq

    ok *** this i have never gotten b4 what happened D:
  19.    #99  
    make sure that you are root or that you sudo the command.
  20. #100  
    i am getting to the pre via ad then putty to the localhost:8023. i had previously setup dropbear for ssh client but cannot do that as i have no ip.....or should i be able to ssh and that i need to redo that part as well......arg i hate 1.3.1....anyways i sudo and switch to other user, to do the stop/start dnsmasq same thing. is there a specific directory i need to be in or for some insane reason is there something wrong with dnsmasq not working at all

Posting Permissions