Results 1 to 13 of 13
  1.    #1  
    • Downloaded and installed OSX sdk w/o issues
    • Setup virtual box.
    • Emulator runs fine, i can happily start & stop apps on the 'pre'
    • palm-package runs fine and creates the ipk

    During the startup of the Palm Emulator a box pops up saying "novacom not running". I tell it to ignore and the emulator will start and run fine.

    I cannot however run palm-install.
    It gives me: palm-install: Connection refused

    I look at my console messages and see this every 10 seconds:
    7/2/09 10:05:56 PM com.palm.novacomd[2834] [2009/7/2 22:05:56] novacomd version novacomd-55 starting... 
    7/2/09 10:05:56 PM com.palm.novacomd[2834] [2009/7/2 22:05:56] sending options to existing novacomd process 
    7/2/09 10:05:56 PM[113] (com.palm.novacomd) Throttling respawn: Will start in 10 seconds
    I'm assuming that the launchd com.palm.novacmd should be running but I'm not 100% sure because at one time I manaully ran the in the nova dir which does a killall -9 novacomd and then calls launchctl load to load novacomd..

    Once the emulator is up I'm able to run ./novaterm and get back:

    So its not completely disconnected but definitely not working properly.

    I'm running OSX 10.5.6

    Let me know what other information that I might be missing.
  2. #2  
    I suggest removing all traces of the sdk & then reinstall it. Or reinstall over what you have already installed. That might work. Not sure though.

    Or, you can use this Automator workflow to launch the file after you open the Palm Emulator app. It launches the Palm Emulator & then automatically runs the file in the Terminal. I'm saving it as an .app & as a normal workflow. See attachments below. Let me know if there are any problems with it.
    Attached Files Attached Files
  3.    #3  
    I've already removed the SDK and reinstalled it a number of times.

    Let me see if your attachments make sense to me and help.

    Are you on OSX? If so, do you see novacomd listed as running in launchd and/or do you get messages like i showed in your console messages?

    thanks a bunch for the quick reply!
  4.    #4  
    disregard the question about being on OSX.. of course you are if you are running automator

    still would like to know if you see those messages and if you see novacomd running
  5. #5  
    Nope, novacomd has been running 100% for me with no issues at all.

    Just download the, double-click it & then open the that shows up.

    Always use this app to launch the "Palm Emulator". By opening the app you downloaded, this will first launch the "Palm Emulator" app & then automatically run the "" so you won't have to. That way, novacomd is always running 100% when you open the Emulator. Hope this explanation helps a bit.
  6.    #6  
    i would like to try and 'remove all traces' to go ahead and do yet another fresh install.. any idea exactly what to kill? does the palmsdk pkg write a log of installed files?
  7.    #7  
    I used your PalmEmulator app.. same exact results.. the very first thing that comes up is a dialog box that says "novacom not running" and gives me three buttons... retry, ignore, abort... retry just keeps coming back to the same screen.. abort just aborts the whole thing..and ignore will let the emulator start up and run just fine.. but when i run the palm-install i get the connection refused message..

    can fathom why this isn't working..

    wish there were logs spit out by novacom..

    need to find out exactly how to do a complete uninstall/reinstall just to be safe
  8.    #8  

    I had already rebooted once and that didn't help.

    I decided to go ahead and update to OSX 10.5.7 (I was on 10.5.6).
    After that the emulator runs fine and so does palm-install. Even w/o the automator workflow..

    Thanks for your help.. not sure what the 10.5.7 update had to do with it so I'm kind of skeptical... but at least its all good now!!

    Off to play..
  9. #9  
    Good to hear that everything is working now
  10. #10  
    I am have this exact issue, however re-installing the SDK has not helped. The novacom daemon seems to be running:

    [2009/7/5 11:12:33] novacomd version novacomd-57 starting...
    [2009/7/5 11:12:33] novacomctl socket ready to accept
    [2009/7/5 11:13:18] Incoming connection from
    [2009/7/5 11:13:18] going online
    [2009/7/5 11:13:18] novacom_register_device:187: dev 'ef1460ff70ae1a4638e459bb65755cecb6222713' via tcp type emulator
    Any help would be very appreciated.
  11. #11  
    i had this same problem but i resolved it by opening up my hard drive, opening the 'opt' folder that the SDK installed, going in to nova and opening both novacom and novacomd.
    after that, i opened a new terminal window and used the palm-install command and it worked fine
  12. #12  
    All I can say is this is crap. I am not a hacker. I just want more than 32 apps. Love the Pre as a phone and platform, I hate what Palm is doing.

    There are more than 32 apps for the Samsung Instinct! It looks like Palm is doing it again. A great device, a great idea - yet when it comes to giving the customer what they are expecting, they stop just short of giving us the whole package.

    I am hoping that the app catalog doesn't become the equivalent of WiFi on Palm OS. Next they will be trying to tell us why we don't want and need more than 32 apps and telling us that opening the app catalog will burn too much battery or make the Pre more vulnerable to security threats.

    Yet they will not see how many devices have been screwed up because people want these homebrew apps and they don't have the skills to hack their device - yet they try anyway. At that point, Palm will probably blame PreCentral and similar sites.

    Phew! Glad I got that off my chest. I just switched from PC to Mac and I am not going to get into the problems mentioned on this thread. I just have to wait for Palm to add two apps every three months while I fume.
  13. #13  
    Wow, that was quite a speech. I've only had a mac for a year, and won't go back to pc (except for work of course). But i learned all of my Mac and Linux by taking chances and tweaking things to my liking.

    What you don't seem to notice talkingdigital, is that Palm has been hacker friendly from the start. with a little patience you might also notice that the palm apps will start trickling into the app store, and what Palm doesnt provide, the homebrew community will more than likely create.

    Don't let other peoples problems dissuade you, use them to learn how to do it right. And if all else fails, use the WebOS Doctor to rescue your phone that can't be bricked.

Posting Permissions