Results 1 to 16 of 16
  1.    #1  
    so I followed the dev wiki to a T when rooting, but when ever I try to connect using putty it says connection refused. Is there a place in putty that i am missing where i need to input my password??
    Last edited by Eckoman518; 06/30/2009 at 12:24 AM.
  2. #2  
    I had the same problem when I started trying to root (I'm assuming that's what you're trying to do?). Are you using Windows Vista? Are you using novaproxy or when you link up? I didn't have much luck when I used from cmd, but when I switched up to novaproxy I'm not having any problems.
  3.    #3  
    yes I am using novaproxy, I can connect just fine when in developer mode and connecting with the USB, but when I try to connect using SSH it says i connection refused
  4. RickNY's Avatar
    254 Posts
    Global Posts
    319 Global Posts
    Did you change the port number in Putty? I beleieve the Wiki sets it up for 222
  5.    #5  
    still having issues, maybe i did something wrong, is there a way to unroot the pre and restart? if I were to use the phone reset tool, does it restore my contacts?
  6. #6  
    Hey, I am having the same problem connecting through SSH using putty. Did you ever get it working? Are there any options that you'd have to change to get it to work? Does anyone else have any advice?

    Thanks in advance.
  7.    #7  
    I ran the webOS doctor and restarted the rooting process and it worked fine
  8. cashen's Avatar
    759 Posts
    Global Posts
    773 Global Posts
    I had the exact same problem. it worked until i rebooted and then it acted like i never installed Dropbear. I ran through it again and it stuck the second time.
  9. #9  
    Quote Originally Posted by cashen View Post
    I had the exact same problem. it worked until i rebooted and then it acted like i never installed Dropbear. I ran through it again and it stuck the second time.
    I'm having the same issue. Did you have to run WebOS Doctor or did you just reinstall Dropbear?
  10. #10  
    Make sure all of you having problems have changed the port number before trying to connect.

    Putty defaults to port 22- change that to 222 if you followed the wiki directions completely.

    I had this problem for a few days before I figured out what I was doing wrong.
  11. tuz
    tuz is offline
    tuz's Avatar
    145 Posts
    Global Posts
    149 Global Posts
    I am having this problem as well. I can get to root in dev mode through USB (though my username can't get permission for anything even with sudo), but the ssh command, which used to time out, now gives connection refused (so I'm figuring my IP address hasn't changed).

    Testing during dropbear install worked, though only when logging on from novaterm (not from terminal from scratch). It logged on but I didn't do anything.

    I am by the way on Mac OS Leopard using the regular old terminal app.

    Any ideas?
  12. #12  
    im having the same issue, and yes, I am using port 222.
  13. Mpre's Avatar
    143 Posts
    Global Posts
    153 Global Posts
    it could be that the Pre signal is not good enough to connect. make sure its wifi or edvo is working.
  14. ansat's Avatar
    12 Posts
    Global Posts
    14 Global Posts
    did you shut down your firewall?
  15. Sirocks's Avatar
    9 Posts
    Global Posts
    10 Global Posts
    don't know where to being rooting my pre im using mac os and cyberduck,im used to rooting into an iphone guess this is very differnet any useful help guides for mac users?
  16. #16  
    Have you been prompted to reapply WebOS 1.2.1? When I did this it upgrade process wiped out my /etc/passwd file so the user I added when I installed ssh was gone. This has happened to others as well, and it didn't happen the first time I upgraded to 1.2.1 but did the next time I had to re-install it.

    To fix the problem I had to connect via novaterm and issue the "adduser" command to allow myself to log into ssh again.

Posting Permissions