Results 1 to 9 of 9
  1. sbc
    sbc is offline
    sbc's Avatar
    5 Posts
    I ported over the batch scripts for palm-generate, palm-install, palm-launch, and palm-package to bash scripts that can be run directly in Mac OS X Terminal.

    Generate and package work fine, but I'm getting "connection refused" errors for install and launch. The tools can't connect to the emulator I've got running in VirtualBox and I tried connecting to a real device using USB but that's not working either (same error).

    Steps to get these installed:

    1) Install SDK on a windows vm and copy the files to your mac's hard drive (eg. ~/Palm_WebOS_SDK)
    2) Unzip and put the attached files someplace (eg. ~/bin)
    3) Add the following to ~/.bash_profile:

    export PALM_SDK=~/Palm_WebOS_SDK
    export PATH=$PATH:~/bin

    You should now be able to run the commands from a new Terminal window.

    If anyone has any ideas on the connection refused issue that'd be great.

    Happy hacking.
    Attached Files Attached Files
  2. #2  
    Curious as to how you got the WebOS VM running in VirtualBox.

    I've fudged palm-emulator.bat into bash, and then replaced "swt.jar" with an OSX one, but it errors at "Novacom not running"

    Not really interested in writing Mojo apps just yet, just want to test a webapp I have on WebOS.
    Last edited by xlevus; 06/29/2009 at 05:40 AM.
  3. #3  
    Awesome! One step closer to developing on my Mac. Thanks
  4. sbc
    sbc is offline
    sbc's Avatar
    5 Posts
    Getting the emulator running on a native-OSX install of VirtualBox has been covered in other posts, e.g.

    Hi there,
    though the SDK is a Windows-only application, the Emulator can be run also on Linux or Mac OS (running the rest of the SDK is another thing...). You need to install the SDK via Wine and then run the VirtualBox image.

    Here is a short howto:
    1. obtain the SDK
    2. download and install VirtualBox including the kernel modules
    3. download and install Wine
    4. run the Windows installer in Wine
    5. after the installation is completed, note the image and grub boot ISO location (default: ~/.wine/drive_c/Program Files/Palm/SDK/share/emulator/images/sdk47/nova-cust-image-sdk47.vmdk and ~/.wine/drive_c/Program Files/Palm/SDK/share/emulator/images/sdk47/grub.iso)
    6. start VirtualBox
    7. create a new Debian machine; specify the .vmdk file as a source image and grub.iso as a CD-ROM boot file (and note the machine name)
    8. run the following command to enable HVGA framebuffer resolution in VirtualBox: VBoxManage setextradata "YourMachineName" "CustomVideoMode1" "320x480x32" (set YourMachineName according to your machine name)
    9. your new Palm Pre is ready

    After start, the machine should produce kernel command output and then show a glowing Palm logo and finally the Luna environment.
    Screenshot at img140. imageshack. us/i/pre3.png/
  5. rzr
    rzr is offline
    rzr's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    same issue on gnu/linux, was the SDK released only for windows ?

    BTW thx for , it saved a few minutes
    Last edited by rzr; 06/29/2009 at 12:36 PM.
  6. #6  
    Thanks. Just packaged a couple of apps (some of the missing emulator apps found in "webosdoctorp100ewwsprint/resources/webOS/nova-cust-image-castle.rootfs/usr/palm/applications"). "palm-install" works for me when installing the apps in the emulator. All of the commands seem to work for me when using it with the emulator. I have the same setup using VirtualBox that you have, sbc. Thanks again! I can now develop some WebOS apps
    Last edited by eisnerguy1; 06/29/2009 at 04:39 PM.
  7. rzr
    rzr is offline
    rzr's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    Do you run vbox w/ special options ?
    btw seems that a mac sdk has been leaked too
  8. #8  
    Quote Originally Posted by sbc View Post
    If anyone has any ideas on the connection refused issue that'd be great.
    OK, I think I have it. I spent a bunch of time chasing redherrings:
    • Adding VirtualBox config entries for network ports
    • decompiling various jar files and then stepping thru the code in a debugger
    • etc

    The solution is to simply install the Novacom Drivers included in the WebOS Reset Doctor (resources/NovacomInstaller.pkg.tar.gz).

    palm-install now runs with no issues.
  9. #9  
    Looks like the Mac version has been leaked as well.

    Palm Pre Mojo SDK leaked for Mac users Too

Posting Permissions