Results 1 to 2 of 2
  1. jsabo's Avatar
    427 Posts
    Global Posts
    479 Global Posts
    Trying to make changes to the GPS tracking stuff-- pre dev wiki: GPS Tracking

    Basically, the script sets up a cron job that runs every 5 minutes, and looks at all the SMSes you've received in the last 5 minutes, and if any of them contains your secret code word, it will send an email to a preconfigured address showing the GPS data for where your phone is at.

    I've modified the script so that it sends a Google Maps URL instead of the raw data, but for some reason, the cron process doesn't seem to be working on my phone.

    Isn't this part of the base phone installation? Or do you have to specifically enable it?

    When I run a ps -ef | grep cron, I don't see the process.

    I've tried running /usr/sbin/crond -f manually, but I don't see that the script is being executed when I expect it to be executed.

    Can anyone help?

    Update: seeing this in the system log file:

    2009-06-27T19:52:01.033386Z [1656] castle cron.err crond[1764]: can't set groups: Operation not permitted
    2009-06-27T19:52:01.033813Z [1656] castle cron.err crond[1757]: USER root pid 1764 cmd /home/scripts/

    Implication is that there's a permissions error, but I can't tell what it might be-- I do have read and execute set for the script and the directory for all users.
    Last edited by jsabo; 06/27/2009 at 04:12 PM. Reason: More info
  2. jsabo's Avatar
    427 Posts
    Global Posts
    479 Global Posts
    Never mind, it's magically started working again. Dunno how.

Posting Permissions