Page 2 of 3 FirstFirst 123 LastLast
Results 21 to 40 of 42
Like Tree12Likes
  1. #21  
    Maybe I'm too dumb for this. I tried adding the nivozn preware feed you link but it errors out. And the link to get to the feed gets a 404 on a laptop.
    Follow me on Twitter
    For the latest webOS news check out pivotCE
  2. #22  
    Quote Originally Posted by Alan Morford View Post
    Maybe I'm too dumb for this. I tried adding the nivozn preware feed you link but it errors out. And the link to get to the feed gets a 404 on a laptop.
    I personally couldn't get his feed to work in Preware, so I just manually installed the IPKs.

    Sent from my Redmi Note 4 using Tapatalk
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  3. #23  
    the link as posted is wrong. The correct link is :

    https://gitlab.com/nizovn/preware_fe...e/master/ipkgs

    (but preware doesn't work with it after the squid "upgrade". at least is not working for me with different errors depending if go or pre3)
  4. #24  
    NIN_ru: I downloaded the source from gitlab, but I don't see where the squid executable gets compiled? Can you provide high-level steps to build from source?
  5. #25  
    Quote Originally Posted by George Mari View Post
    NIN_ru: I downloaded the source from gitlab, but I don't see where the squid executable gets compiled? Can you provide high-level steps to build from source?
    Seems you need to have Palm SDK or the WebOS Internals toolchain, then you should be able to build: https://gitlab.com/nizovn/com.nizovn...rvice/Makefile
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
  6. #26  
    Quote Originally Posted by George Mari View Post
    NIN_ru: I downloaded the source from gitlab, but I don't see where the squid executable gets compiled? Can you provide high-level steps to build from source?
    This is the original code I think: https://github.com/squid-cache/squid

    Obviously, that's only part of the final app...
  7.    #27  
    First post updated with correct link and link to Makefile for squid executable.
    I'll test long term squid stability and check out ProxySwitcher, but a bit later.
    Not sure about preware feed issue, I think it should work. Don't know, I would try to reopen squid gui app to make sure squid is running (gui should show correct squid status on launch), and switch proxy forwarding off/on.
    Grabber5.0 likes this.
  8. #28  
    Quote Originally Posted by NIN_ru View Post
    Installation:
    The application package is available in nizovn/preware_feed, but due to TLS 1.2 requirement of GitLab, it should be installed manually after installing also com.nizovn.glibc and com.nizovn.openssl.
    It should be noted that com.nizovn.openssl has a dependency on com.nizovn.cacert (available in the same repository).

    It kept failing to install for me (Preware failed silently, while WOSQI finally gave me a hint that I was missing a dependency). I found my Touchpad was missing the above package. And once installed the process worked seamlessly.
  9.    #29  
    Quote Originally Posted by Misj' View Post
    It should be noted that com.nizovn.openssl has a dependency on com.nizovn.cacert (available in the same repository).

    It kept failing to install for me (Preware failed silently, while WOSQI finally gave me a hint that I was missing a dependency). I found my Touchpad was missing the above package. And once installed the process worked seamlessly.
    Note added, thanks.
  10. #30  
    Working flawlessly on Pre3 and Touchpad Panda. Had some challenges with installing the dependencies which required some rebooting, retrying etc. and then suddenly one for one with WOSQI I managed to get the dependencies installed.
    Lot's of websites working again, at least the ones I normally use. Also my Nextcloud instance (tls v1.2) works great on Touchpad with both Qupzilla. Up and downloading files, preview, talk (no video/audio).
    Looks my Touchpad and Pre3 are re-instated as regular drivers again!

    Thanks a lot NIN_ru.
  11. #31  
    Thanks NIN_ru for developing this app. Minor bugs here, some apps (Bing Maps, Lunetube, ClockSync...) doesn't work when the proxy is running on Touchpad v 3.0.5. Message "no Internet connection" or "no network connection". Proxy must be disabled to make them to work. Everything seems ok on Pre 3 v 2.2.4. Thank again.
  12. #32  
    Any direct link/mirror?

    -- Sent from my Palm Pre using Forums
  13. #33  
    Anyone have a direct link to ipk I could get on the phone?

    -- Sent from my Palm Pre using Forums
  14. #34  
    I know it's not straightforward or easy, but nothing with webOS is easy any more.

    If you download the packages on a computer, at the link listed under "Installation" in the first post, you can install them manually using webOS Quick Install from your computer. Or copy the files to the internal storage of your device and use Preware to install them.

    -- Sent from my TouchPad using Communities
  15. #35  
    Quote Originally Posted by George Mari View Post
    I know it's not straightforward or easy, but nothing with webOS is easy any more.

    If you download the packages on a computer, at the link listed under "Installation" in the first post, you can install them manually using webOS Quick Install from your computer. Or copy the files to the internal storage of your device and use Preware to install them.

    -- Sent from my TouchPad using Communities
    Thanks - though I'm not any kind of expert, I have been using these phones, including WOSQI, Preware, Novaterm, etc., since 2011, (I even built a meta-doctor one time), so somewhat familiar. I was just seeing if there might be a link somewhere that could be downloaded to a Pre...

    -- Sent from my Palm Pre using Forums
  16. #36  
    This is an awesome solution, but I wanted it to apply to other old devices -- and using a TouchPad as a house-wide proxy probably wasn't the right call. Fortunately, a $10-$30 Raspberry Pi makes a great network appliance, that can be assigned a static IP address and serve all sorts of retro-tech. Here's the steps I've figured out so far, to setup a Raspberry Pi as a Squid SSL-Bump Proxy. This assumes you've already set-up networking on your Pi. All of these commands should be run from a shell command line (either directly on the Pi, or via an SSH session):

    #install git
    sudo apt-get install git

    #install docker
    curl -sSL https://get.docker.com | sh
    sudo gpasswd -a pi docker
    sudo reboot

    #create a fake cert
    mkdir -p /usr/local/squid/
    cd /usr/local/squid/
    openssl req -new -newkey rsa:1024 -days 365 -nodes -x509 -keyout myCA.pem -out myCA.pem
    # This can be added to browsers
    openssl x509 -in myCA.pem -outform DER -out myCA.der

    #install docker-squid-sslbump-rpi
    git clone https://github.com/justinschw/docker-squid-sslbump-rpi.git
    cd docker-squid-sslbump-rpi
    docker build . -t docker-squid-sslbump-rpi
    docker run -ti -p 3128:3128 docker-squid-sslbump-rpi


    Note: compilation and installation takes a loooong time!
    Once its running, set the IP address of your Pi, and port 3128, as the Proxy server on your webOS (or other retro) device.
    Last edited by jonwise80; 01/14/2020 at 01:11 PM.
  17. #37  
    The above should work... but it doesn't for me . The Docker setup hangs building Squid on both my Pi Zeros.
    So I made a fork that runs on a "bare metal" Raspberry Pi. Tested on Raspbian Stretch:

    https://github.com/codepoet80/squid-sslbump-rpi

    Instructions are in the readme. Set your Pi up the way you like it first -- eg: join WiFi, set a static IP, whatever else you like.
    This works for me 100%, tested on both my Touchpads and an old version of Internet Explorer. Its wonderful to have the whole internet again!

    Update: make sure you grab the cert off your Pi and install it on your webOS device, to avoid lots of prompts to "trust this certificate" on every website.
    Last edited by jonwise80; 01/16/2020 at 06:59 AM.
  18. #38  
    Got Squid working with Proxify on Pre2. Nice improvement... I have an off-topic question for anyone, (since I can't find a Tor thread). Has anyone gotten Tor to work properly on a Pre? My experience has been:
    1) install ipk and reboot, in which case the app seems to function properly, showing banner notifications for 'Tor started' after opening a new browser card, and 'Tor killed' after tapping it off, but the browser won't load any pages - just sits blank without even trying to load, or gives endless spinner if I tap reload, or
    2) manually copy files to filesystem from Tor zip, and reboot, in which case the app launches a new browser window, and shows 'status: Tor is running' on the app screen, but gives no banner notification about starting, and when killing Tor, shows, 'unable to clean up after Tor, please restart'.

    I also started it from command line, (after editing permissions, which made me wonder if that could be part of the other problems), and got continual output that seems to indicate that it's running correctly in the second scenario, but website anonymity tests don't seem to indicate much covering. Maybe I don't know what to look for or maybe it's too out of date, or maybe..?

    -- Sent from my Palm Pre using Forums
    Last edited by 1whocs; 01/15/2020 at 08:52 PM.
  19. cheque_some's Avatar
    Posts
    8 Posts
    Global Posts
    9 Global Posts
    #39  
    Trying to get the Squid SSL bump working on my Pre2. Got it installed, but the "Generate && Install Certificate" button just spins for a while and then opens up the Certificate Manager with nothing in it. What am I doing wrong? Is there a way to generate the cert elsewhere and sideload if this doesn't work?
  20. #40  
    Quote Originally Posted by cheque_some View Post
    Trying to get the Squid SSL bump working on my Pre2. Got it installed, but the "Generate && Install Certificate" button just spins for a while and then opens up the Certificate Manager with nothing in it. What am I doing wrong? Is there a way to generate the cert elsewhere and sideload if this doesn't work?
    Make sure your date & time are correct! A reboot might also help

    Sent from my Titan using Tapatalk
    HP Veer (daily driver), HP Pre 3, HP Touchpad Proper 4G/LTE (Sierra MC7710), HP Touchpad 32GB WiFi, Palm Pre 2
    MudShark22 likes this.
Page 2 of 3 FirstFirst 123 LastLast

Similar Threads

  1. SSL certificate problem
    By anthonb in forum webOS Discussion Lounge
    Replies: 3
    Last Post: 03/10/2019, 03:08 PM
  2. Preware SSL certificate problem
    By anthonb in forum Palm Pre 2
    Replies: 0
    Last Post: 03/03/2019, 02:18 PM
  3. Impossible to load some websites because of SSL-Error
    By Nafetz in forum webOS Discussion Lounge
    Replies: 5
    Last Post: 09/05/2017, 12:34 PM
  4. webOS SSL certificate updater
    By dkirker in forum webOS Discussion Lounge
    Replies: 11
    Last Post: 10/12/2014, 08:33 PM
  5. New SSL Bug - Not Heartbleed
    By ToniCipriani in forum webOS Discussion Lounge
    Replies: 2
    Last Post: 06/22/2014, 06:18 AM

Posting Permissions