Page 1 of 2 12 LastLast
Results 1 to 20 of 37
Like Tree14Likes
  1.    #1  
    Qt WebBrowser
    Description:
    The Qt WebBrowser is a browser for embedded devices developed using the capabilities of Qt and Qt WebEngine. Using recent Chromium, it features up-to-date HTML technologies behind a minimal but slick touch-friendly user interface written in Qt Quick.
    All basic browser features are supported: You can search for text (both in history and via Google). You can bookmark pages, navigate in the page history, and open multiple pages concurrently. Depending on the codecs available, full-screen video and audio playback should also just work. You can also enable a private browser mode that leaves no traces after the browser is closed.
    More: QtWebBrowser, Qt Blog: Qt WebBrowser 1.0

    Screenshots:
    Unknown_2018-20-07_151631.png

    Sources:
    https://gitlab.com/nizovn/qtwebbrowser

    Installation:
    This application can be installed through Preware from nizovn/preware_feed (Follow url to see the installation instructions).

    Notes:
    • This application uses hardware rendering.
    • Fonts are broken in URL bar.
    • Popup menus don't work.
    • This app should work on Pre3 and Touchpad.
    • org.webosinsternals.dbus package must be installed from alpha feed, or com.nizovn.qt5 package will fail to install.


    Changelog:
    1.0.0: Initial release
    Last edited by NIN_ru; 07/24/2018 at 01:54 PM.
  2. #2  
    Superb!!!!

    Sent from my OPO awaiting LuneOS
    This space for rent or lease. Inquire within.
  3. #3  
    do we need to remove qupzilla before installing this one ?

    and I'm getting an error 401 after adding the feed, from curl
    Edit , saw the correct link following the initial link
    Last edited by mazzinia; 07/21/2018 at 04:48 PM.
  4. #4  
    Well, jumped the gun.

    Installed on a Go , works

    On the pre3 is stuck on downloading / installing the glibc package
    Edit , seems about the pre3, that the culprit is either my "nice" router or the wifi stack ( but I would bet on the router ). Noticed practically no data was going down from the router stats page.

    wifi off/3g on ... and the installation starts
    Last edited by mazzinia; 07/21/2018 at 05:39 PM.
  5. #5  
    Quote Originally Posted by mazzinia View Post
    Well, jumped the gun.

    Installed on a Go , works

    On the pre3 is stuck on downloading / installing the glibc package
    Time to fire up the GO!

    Sent from my OPO awaiting LuneOS
    This space for rent or lease. Inquire within.
  6. #6  
    on the pre3 is not installing correctly
    Looks like it's faking installing : qt5 framework libraries , gt5 sdk , and qt webbrowser .... ( i saw it downloading 65mb and saying installed.. marked installed. but no icon, and if preware is restarted, all those 3 packages are again marked as not installed

    Edit, Installed all 3 in order one by one. Each takes the right time and says installed, but apparently is not the case.marked installed until I restart preware to see them not installed. no icon...
    I think qt5 framework libraries fails somehow, and the other 2 never really installs as a consequence
    Last edited by mazzinia; 07/21/2018 at 06:00 PM.
  7.    #7  
    It looks like something went wrong with Preware. I would try to reboot device. Make sure you have only one my feed enabled in Preware, check if you have enough space on device. You can try to install only qt5 framework libraries package, and check IPKG log after Preware says it's installed (in AppMenu), then install other packages.
    QupZilla and this browser can be installed along.
  8. #8  
    The phone was actually rebooted, and no changes
    2.1GB free space
    no previous feeds from you

    I did that ( qt5 then the rest ) as last try last night, but with no changes in the results. Still I didn't look at the logs.. will do now

    Install :
    Starting
    create_tmp
    verifying
    ipkg_install
    failed_ipkg_install

    completed : nothing interesting
    Last edited by mazzinia; 07/22/2018 at 06:30 AM.
  9. #9  
    is there an installation order by chance ?
    Webos qt5 qpa plugins got installed successfully when doing all on auto ( installed before installing the framework libraries / sdk / browser )

    nvm, removing/reinstalling qpa plugins didn't change things
    Last edited by mazzinia; 07/22/2018 at 06:54 AM.
  10. #10  
    Further update.

    While the ipk fails to install ( and so the 2 after it ), the 3 directories are present under cryptofs ( but empty )
  11. #12  
    In my case, the issue was due to not having dbus installed. The package is in alpha feeds
  12. #13  
    So you had dbus on your GO but not the Pre3?

    Sent from my OPO awaiting LuneOS
    This space for rent or lease. Inquire within.
  13. #14  
    I had qupzilla on the Go , and for that one was mentioned in writing that dbus was needed.
    I assumed it was not needed in this case since it's not mentioned in this topic ( for all I knew it was no more needed for this whole different built, erm ), and so I didn't think about it
  14. #15  
    Good to know

    Sent from my OPO awaiting LuneOS
    This space for rent or lease. Inquire within.
  15. #16  
    I tried installing via the fresh listing at Qt WebBrowser - webOS & LuneOS Apps on Preware Catalog
    I assumed the enabled dependency support would make it happen automatically, but it didn't.
    I also had problems adding the feed.

    Following the User group meeting, I downloaded the files directly. I had trouble with dbus until I rebooted, installed and rebooted again.

    The recommended order of install was:
    1. org.webosinternals.dbus (I didn't bother enabling alpha feeds, just downloaded directly via a PC)
    2. com.nizovn.cacert
    3. com.nizovn.glibc
    4. com.nizovn.openssl
    5. com.nizovn.qt5qpaplugins
    6. com.nizovn.qt5
    7. com.nizovn.qt5sdk
    8. com.nizovn.qtwebbrowser

    No sign of the browser...

    I wondered if I'd managed to miss the qt5 bit as I'd had space issues. I reinstalled that and the following packages - still nothing.

    ...but I have rebooted! I could then see the listing in preware and the icon has appeared in the launcher! Success!
    Attached Images Attached Images
    Last edited by Preemptive; 07/23/2018 at 03:18 PM.
  16. #17  
    It appears to be portrait only. I see there is a 'card view' button. Text in the url field can be selected by holding shift and swiping and though the font there is broken, the url is displayed below when typing. Taping in the url feed reveals the back & forward buttons.

    As the display doesn't rotate, I guess that's why I don't see a home or bookmark button - I don't know how to bookmark then. If edit commands work (probably not), I haven't worked out how to copy & paste urls into it.

    I think I did briefly see a pop up menu at the bottom of the screen - can't remember what button combination did this, but it vanished almost immediately - it was very small. I may have also managed to open a new tab with a button combo - maybe there's a way to open a link in a new tab..?

    The app does take a looong time from black screen to start up, but though I wouldn't call it fast, it loads pages at a reasonable speed. Great work!

    I noticed from the links in post one that there is a Qt location service. Not sure if this would be useful for our broken Google location service..?
  17. #18  
    keep a finger pressed on the screen , and you briefly get that popup
  18. #19  
    Does this work faster than QupZilla on the TP? I installed Qup on my TP and it's pretty choppy when scrolling. Just curious if this is any better.
  19.    #20  
    Quote Originally Posted by Preemptive View Post
    It appears to be portrait only. I see there is a 'card view' button. Text in the url field can be selected by holding shift and swiping and though the font there is broken, the url is displayed below when typing. Taping in the url feed reveals the back & forward buttons.

    As the display doesn't rotate, I guess that's why I don't see a home or bookmark button - I don't know how to bookmark then. If edit commands work (probably not), I haven't worked out how to copy & paste urls into it.

    I think I did briefly see a pop up menu at the bottom of the screen - can't remember what button combination did this, but it vanished almost immediately - it was very small. I may have also managed to open a new tab with a button combo - maybe there's a way to open a link in a new tab..?

    The app does take a looong time from black screen to start up, but though I wouldn't call it fast, it loads pages at a reasonable speed. Great work!

    I noticed from the links in post one that there is a Qt location service. Not sure if this would be useful for our broken Google location service..?
    Yes, I hid boorkmark buttons for pre3 because there were no enough space. There are some shortcuts, but I don't think they work (for now).
    QtLocation needs valid backend for work. LuneOS uses ls2 location service for this. I think it makes more sense that qt apps use webos location service than location service uses qtlocation with some other backend. Anyway someone needs to get geoclue to work.

    Quote Originally Posted by NuclearKev View Post
    Does this work faster than QupZilla on the TP? I installed Qup on my TP and it's pretty choppy when scrolling. Just curious if this is any better.
    Yes, it's noticeably faster. qtwebbrowser allows me to watch youtube videos in low quality, and scrolling is better too.
    I recommend to disable javascript for usual browsing, then the app is faster a bit more.
Page 1 of 2 12 LastLast

Similar Threads

  1. Request: An UpToDate Webbrowser APP
    By hfGermany in forum webOS Apps & Games
    Replies: 69
    Last Post: 03/19/2018, 10:01 AM
  2. QT Dev Days - Santa Clara
    By akitayo in forum Open webOS General Discussion
    Replies: 0
    Last Post: 12/12/2012, 08:59 PM
  3. Qt 4.7+ and Preware
    By marmistrz in forum HP Pre 3
    Replies: 0
    Last Post: 07/14/2012, 09:15 AM
  4. A-Browser QML and QT
    By Grabber5.0 in forum webOS Homebrew Apps
    Replies: 16
    Last Post: 03/28/2012, 06:22 PM
  5. compile qt 4.8 from howtoQT?
    By hkowalczyk in forum webOS Development
    Replies: 0
    Last Post: 02/25/2012, 04:01 PM

Tags for this Thread

Posting Permissions