Page 2 of 2 FirstFirst 12
Results 21 to 33 of 33
Like Tree8Likes
  1. #21  
    Quote Originally Posted by janthiemen View Post
    @mazzinia @Preemptive I'm having some trouble recreating on the pre3 emulator, it would be create if you could post or send me the logs (you can retrieve them using Lumberjack ( or using palm-log (

    I started Lumberjack to follow the log of NISI. Then I started the app.

    Note the following behaviour: It can often be slow to start and will show the last thing I had running in the NISI card (last app or view) even if I have closed the previous thing.

    The only entry in the log is:
    ! Uncaught TypeError:
    Cannot read property '0' of undefined, file:///media/cryptofs/apps/usr/palm/applications/$405$

    The app looks like the picture in the first post without any text below the buttons - only the animated spinner..

    I can switch the List / Archive slider. Tapping (Open) launches another card with the NISI app logo pulsing but never maximising unless I tap it. Tapping the three dots at top right brings up a bubble with, (Oldest \/) etc. I can select from these options & the display at the top. I opened a pocket account and I see switching from (pocket \/) to (readability \/) causes a authentication dialogue (once only). I can select from these options & some (title, newest, url) display at the top.

    I cannot access the drop down app menu at top left on the first card or the card launched by, (Open). Star, tick & dustbin do nothing - presumably because there is no content to act on.

    I've managed to get the above log entry to display a couple of times. Other entries have now appeared after fiddling (changed the square brackets to curly to post):
    ! Uncaught TypeError:
    Object main_serviceWindow {nisi.login.xauth} has no method 'sortChanged', file:///media/cryptofs/apps/usr/palm/applications/$405$

    There was also something about method filter that I haven't managed to recreate.

    It seems the UI is working, but maybe nothing is happening underneath. Or maybe as the app is seen on pocket's website, the UI isn't interacting with the rest of the app or something...?
    Last edited by Preemptive; 05/25/2014 at 03:20 PM.
  2. #22  
    Couple more on picking up the phone:

    ! Uncaught TypeError:
    Object #<an Object> has no method 'screenOrientationChanged', :1

    ! Uncaught ReferenceError:
    Mojo is not defined, :1
  3.    #23  
    Quote Originally Posted by mazzinia View Post
    I've used areslog, if it's ok. System log is attached... apparently the container for nisi is not mapped
    @mazzinia thanks, I've updated the app and I think the issue is solved, but to be honest, I'm not sure (as I haven't been able to recreate it), so please check if it is (also don't forget to delete the old version before updating).
  4. #24  

    removed , installed, reconnected.. no visible changes with pocket

    reconnected readability.. it took a lot of "clicks" to finally have it login

    I'm rebooting the device now, to test if a restart is required


    ok, rebooted. No changes ( but the readability part lost the login/pwd and is having issues logging again )
  5. #25  
    Add on

    the card under list/archive is empty , but I started pressing randomly.

    If I press just under List, it moves to the left view and says:

    error, we couldn't extract the content, please open the article in card view
  6. #26  

    the xauth is when moving to readability and getting the login screen ( nothing got recorded by inserting and pressing the continue button).

    The rest is by opening as pocket, or pressing the (open) aka invoking the new card
    Attached Files Attached Files
  7. #27  
    last follow up

    removed the previous content I put on pocket as a test ( was from this same forum ). Added a wikipedia article.

    Now pocket works


    the wiki page has pics and is long ( divina commedia ), it's not scrolling down , moving from left to right is visibly very slow, and after trying to scroll down the cpu is used quite a bit ( phone close to frozen )
  8.    #28  
    @Preemptive @mazzinia I added a fix for sortChanged being called in the last version, I also tried to make authenticating Pocket easier. I can't do a lot about the slow rendering though, that problem is mostly due to webkit i think, but I will try to resize the images so that you don't need to scroll to the right to see the them and to do some kind of paging, so the phone doesn't need to render everything.
  9. #29  
    to be fair, I'm feeling it's not the few images but the text amount. If I open that link inside pocket (in a browser) I get a lot of text to be scrolled down.
    The images are resized on the pre3 at what I think is the right dimension ( I can see just the topmost one anyway ), and personally I would not turn them smaller. Visually is right this way.
  10. #30  
    I was able to authenticate with Pocket but the app continues to only show loading circle. Also, the text of the app is all over the place and it looks nothing like the screen shot in the first post.
    I used lumberjack and receive the following error :
    Uncaught TypeError:
    Cannot read property 'altCharSelected' of null, file:///media/cryptofs/apps/usr/palm/application/$228$
  11. #31  

    I deleted 1.2 from the Pre3 & tried 1.4 on a Touchpad (via WOSQI) to see how it should work. It authenticated on Pocket OK, then I saw the two articles I'd saved to test with. So tapping on one displays it. I assume star, which turned yellow when tapped is 'favourite', tick (did nothing) is, 'read it' & the bin is... the bin! Nothing actually happened when I tapped these icons & I couldn't work out how to return to the list view. 'Open' opens the page in the web browser. Eventually, I closed the app and reopened it to find the article gone, so I suppose the delete button worked. It was the same with the second article.

    When I opened the app again, the list/archive was on the right and the main area prompted me to add more articles, so I did that on the web. The app wouldn't display them. I tried changing from list to archive and altering the sort order. Eventually I closed and restarted and that worked. So I looked at the web version and I see that 'tick' is archive. I can pull down a menu from the top and view the list, Archive and favourites. I favourited an article in the app and can see that echoed in the web version, as is archiving, but nothing (except yellow star)happens in the app. By now I've discovered that the list panel slides and I can slide my finger under the top buttons to restore it - there is no 'back'.

    I restarted the app again and now the list is refreshed: One in the list view & two in the archive. Selecting an article displays it and I see the list slide to the right which is a hint as to how to restore it. The star is yellow if it is a favourite. Changing the list order drop-down just results in a spinner - no change to the list. I can make it update and lose the spinner by sliding the button list/archive back and forward.

    Assuming this is working as intended, I'd make the following suggestions:
    • The article tends to 'slide around' in the viewport rather than scroll straight. Maybe that's the nature of things with reformatting, but sliding my finger from the right bounces the article around and I have to slide at a specifc point (unmarked) to restore the list.
    • Maybe a little arrow to show where to swipe to restore the list would help.
    • The app menu doesn't work or maybe there isn't one, but you could put use instructions there - it's a simple app, so should only need short instructions OR put a permanent 'help' article in the list panel.
    • I can see actions from the app on the web, but not in the app - it doesn't refresh properly. I either have to restart or use the slider. Does it need a refresh button?
    • Is there a way to filter for favourites?

    Basically, the app works and looks quite modern with the mochi stuff. I think you just need to neaten it up and get it to refresh properly - it's obviously doing it, just not displaying it. If my install is broken, let me know.
    Last edited by Preemptive; 06/30/2014 at 09:22 PM.
  12. MikeN68's Avatar
    339 Posts
    Global Posts
    340 Global Posts
    Is anyone else having issues using NISI?

    I have to log in again and just have the spinner 'forever'. I downgraded from .4 to .3 and the spinner disappears, but still does not log in. Has Pocket changed its login procedure?

    This is on my Pre3 - Touchpad is working fine
    Last edited by MikeN68; 10/06/2014 at 08:26 AM. Reason: device
  13. #33  
    This app works great on my TP!
    Just one thing.
    When I have read an article, how do I get back to my list?
    I can't see any back-button?

    Martin :-)
Page 2 of 2 FirstFirst 12

Similar Threads

  1. [REQUEST] Add readability button to web browser.
    By codecrumb in forum webOS Patches
    Replies: 3
    Last Post: 12/08/2011, 07:47 PM
  2. Replies: 32
    Last Post: 09/05/2011, 05:37 AM
  3. Read Receipts in Pocket Outlook
    By jbcross in forum Palm Windows Mobile Devices & Apps
    Replies: 0
    Last Post: 10/20/2006, 02:07 PM
  4. Read if your having problems with Pocket DVD 3
    By Magohn in forum Palm OS Devices & Apps
    Replies: 1
    Last Post: 02/02/2005, 12:39 PM
  5. about pocket tunes, please don't read unless you have patience
    By radiosimon in forum Palm OS Devices & Apps
    Replies: 6
    Last Post: 01/24/2004, 11:46 PM

Posting Permissions