Results 1 to 7 of 7
Like Tree1Likes
  • 1 Post By neiltice
  1. jwats01's Avatar
    1 Posts
    Global Posts
    2 Global Posts
    I recently tried to deregister my Touchpad Kindle App, and it froze at that screen. I let it run for prolly around 30 minutes or so before finally killing it.

    I checked Amazon's site, and they recommended deleting the app and reinstalling for that issue.

    I did that, and now, upon starting the app after a new install, I get the following message in the Kindle App:

    Deregistering Device
    The application was closed before this device was deregistered. Please wait while your device finishes the deregistration process.

    And that never goes away.

    I've checked my Amazon account, and the Touchpad is not registered. I contacted Amazon, and they had no fix.

    Anyone have any thoughts? All are appreciated.

  2. #2  
    Very the same problem as above, waiting for answers.
  3. kplo's Avatar
    1 Posts
    I have the same problem too. Someone please help!!
  4. #4  
    I fixed mine by:

    1. Uninstall the Kindle app
    2. Remove the /media/internal/.palmkindle directory
    3. Restart
    4. Install the Kindle app

  5. #5  
    My app froze up on the screen with the kid under the tree (not the first time for this), but this time I was not able to deregister it. I tried and got the same error message mentioned above.

    I checked Amazon and the tablet was not listed in devices.

    I tried the fix by sacreyy28 a few times and still get the error message; after the first time to delete the /media/internal/.palmkindle directory it never came back.

    Preware is able to re-install it, but not HP App Catalog ("not enough storage to download"), but it goes back to the same error message.

    I'd like to not have to do a full erase on the tablet, but with this and the occasional "running out of memory" error message, I may have to unless there are some suggestions out there.

  6. #6  
    BUMP for suggestions
  7. #7  
    I ran into this problem a few days ago and solved it, so I'm posting my solution here.

    After a lot of floundering around, it occurred to me that I hadn't emptied the browser cache, cookies, and history in over a year. The deregistration loop seems to be connected with an over-full memory in some partition or another. So I opened the browser, clicked the upper-left menu, selected "preferences", and cleared cache, cookies, and history.

    I had already deregistered the device on the Amazon "Manage My Devices" page.

    Next, I deleted the Kindle app and restarted the Touchpad.

    Next, I used the WoQI v4.6.0 to install the latest known Kindle ipk, downloaded from the link here:

    Restarted again, started Kindle, and got the "deregistration" warning. But I let it run for a minute or so and it went away, replaced by the Kindle registration log-in. Success! Now I'm reading books on my Touchpad again!
    Preemptive likes this.

Posting Permissions