Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 80
Like Tree4Likes
  1. #21  
    Maybe I am being dense, but I can't seem to import my laptop's xml file. I export from keepass 2.09, transfer to TP(os3.02), using same master key-keepassw 0.2.2 sees file but absolutely NOTHING shows after import. I have groups nested 1 deep, ie internet/discussion.
    Is there some step I'm missing like decrypting original file??? Do the groups need to be flat structure?
    Please help!!!
  2. jft
    jft is offline
    jft's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    @Rossley: I am currently struggling with the US restrictions for encryption algorithms and the registration (snap-r). I am trying to get the new version into the webos app catalog soon.

    @gizmo21: There will be no mojo port, sorry. Did you try KeePassW on your Pre3?

    @dotnet and @gizmo21: As far as I know KeePassX 0.x is dead and the author is rewriting it from scratch (I do not know if he will use the kdbx file format of KeePass 2.x). Therefore, I am focusing on KeePass 2.x support. I am very happy with it running on mono.

    The next feature will be the import of kdbx files. Do not expect any progress in the next days

    @PreJoeBloe: I only tested with KeePass 2.16 and its XML export. Could you please update your installation and report back? The XML generated by KeePass 2.16 is decrypted. You do not need to do anything on your own.

    A flat structure is not required. My original database is also hierarchical and it works like a charm. KeePassW flattens your hierarchy.

    The import takes same time, depending on the size of your database. Did you wait 10 to 20 seconds before killing the app?

    Do you have the SDK? KeePassW generates some log entries in the case of an error. Could you please use palm-log to check if there is any output from Unfortunately, I reduced the log outputs to a minimum to prevent the disclosure of information.

    If nothing of this helps I can send you a build with much more debug output.
  3. #23  
    jft, upgraded Keepass to 2.16, reexported xml, waited 5+ minutes for import to complete on TP, still nothing.
    I uninstalled keepassw and reinstalled. When I had version 0.1.0 installed it imported 3 of the 88 keys.

    Got the following from palm-log on keepassw 0.2.2
    Uncaught TypeError: Cannot read property 'firstChild' of undefined, source/XMLImporter.jsjsjs:$43$
    This error comes up almost immediately after starting import.

    Thank you for your attention
  4. jft
    jft is offline
    jft's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    Do you happen to have groups without a name (empty name)? If so, please give them a name and try again. This is a bug in 0.2.2 and will be fixed in the next release.

    Ok. Here is the new version with a rewritten XML import. Please try

    Last edited by jft; 09/18/2011 at 07:50 AM.
  5. #25  
    That worked perfectly. YAYYYY, now I have Keepass on the TP.
    Is it possible with webOS to target an application so that the user name/pw pastes where you last were? Don't get me wrong, just having the ability to c&p complex passwords is awesome. But auto-paste would be icing on the cake.

    To answer your question, none of the group names were empty.

    edit: I looked at the xml file and noticed that I have some keys without usernames. Upon further examination I see 3 instances of a particular key, only one having the username and 2 with the correct pw. The third had wrong pw & no username. It looks like Keepass is holding onto old iterations of keys.
    Last edited by PreJoeBloe; 09/18/2011 at 04:19 PM.
  6. jft
    jft is offline
    jft's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    @PreJoeBloe: Thanks for your feedback. The old 0.2.2 version also tried to import the deleted keys and groups :/ Currently, I do not know if auto-paste is possible. Are there any apps able to do this?

    My next steps are:

    * Submission of the encrypted version 0.2.4 to the app catalog
    * Support for kdbx files
    Last edited by jft; 09/19/2011 at 04:15 AM.
    Garfonso, dodnet and ericsche like this.
  7. #27  
    Cool. I really long for kdbx support!
    To all the KeePassX users: KeePass 2.x runs fine on linux with mono installed. With xdotool you can even have a full fletched auto type and everything (see website). It's just great.

    I really hope you can get it to support kdbx files.

    I don't know of an application that can do auto-paste... if that's not possible is there something like global hotkeys? Maybe one could do it the other way round (if you somehow can identify the app/webpage currently in focus).
  8. #28  
    Btw: I tried this today on my Pre3. Short: It's not working...
    - If you are in portrait mode, you can't see the keys slide at all (or is this intentional?)
    - If you select "Import XML" from the menu (which is only there in portrait) an empty thing will pop up and nothing will happen no matter what you do. You can tab everywhere, press any button you like, nothing happens. If you do a back gesture, the thing will disappear and you see the groups thing again.

    If you want me too, I can have a look at this.
  9. #29  
    I tried it out... so is there a way to change the password? The only way I found was to delete everything and start from scratch.
  10. #30  
    Hello jft... thanks for creating this program. I depend heavily on KeePass and was really struggling how to retype a pw with 64 karakters etc...
    So really a big thank you. I use both the Ubuntu version and the Windows version (they share the portable keefile I have on my USB stick) and now I can use it on my Touchpad. Do I understand correctly that there is no version planned (yet) for the Pre2?
  11. #31  
    @dodnet: Jft explained in this thread. You can't change the PW, because the PW is an encryption key. The only way to change that is re-encrypt everything and delete the old stuff.
    So not being able to change the pw more or less is a security feature in this case.

    -- Sent from my Palm Pre3 using Forums
  12. jft
    jft is offline
    jft's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    @MRdeJong: Sorry, but that is true. I just do not have enough time for that.

    @Garfonso: I just found the 2.2 emulator image and will make the adjustments in the next few days. It would be great if you could test the new version when it is done.
  13. tsl
    tsl is offline
    tsl's Avatar
    3 Posts

    I can test the software on WebOS 2.1 (Pre+) when (and if) you'll port it for this OS version...
  14. #34  
    Hello tested on HP TouchPad, it is working like a charm so far

    Good job

  15. #35  
    This is an awesome contribution to WebOS on the Touchpad. I'm happy to have most of my login info available in a secure form on the Touchpad although a couple of things limit its usefulness to me right now. Hence a couple of suggestions.

    - The ability to search. Preferably the search would match any contiguous text in the URL and description. I exported my LastPass data as a csv which I then imported into KeePass2 under Windows and exported as an XML file that I transferred to the TP and imported into Keepassw. I now have about 50 passwords listed as "Generated password for site_name" along with many more listed under the site page titles and it's often difficult to find the one I want to use by scrolling through the alphabetized listing.
    - I rarely use the stock browser since installing "Advanced Browser". Although it would be nice to be able to select Advanced Browser as the default for launching urls, at a minimum, I'd like to be able to copy and paste the url manually into Advanced Browser instead of the stock browser launching as soon as I touch the url field in the Keepassw entry.
    - I'd like to be able to view the user name and password in Keepassw for times I need the user/password for use on another device such as my iPhone or another computer while traveling. I guess there might be security issues here although I can paste them into another program on the TP to view them.

    I noticed there's an iPhone app named miniKeepass that seems to be able to import native Keepass kdbx files that says the source is available on github. I don't know if that could assist you in adding kdbx support.

    Again, my sincere thanks for your contribution. I'm better off now with it in its current state than I was before without it.

    BTW, I did find it confusing to get it setup with a password after just tapping login the first time I started it but eventually figured it out. I also had a hard lockup on my TP when playing around with the older version in the HP app catalog. That's the first time I've seen that on my TP. It was completely unresponsive and required a Center/Power, hold until reset to get out of.
  16. jft
    jft is offline
    jft's Avatar
    17 Posts
    Global Posts
    18 Global Posts
    I just completed the U.S. encryption registration process and submitted 0.2.4 to the app catalog. Hopefully, the review won't take long.

    @anotheruser: I also encountered one freeze with the old version. Unfortunately, atm the app is pure javascript and I believe there has to be a bug in the encryption or service API of webOS. Nevertheless, 0.2.x seems to be fine - no lockups on my Touchpad since weeks.

    I will consider your suggestions for future version.
  17. #37  
    Unless I missed it in an earlier post, I am not clear about how to create a login to limit access to keepassw. I'm not following what was posted earlier about how to create a group and key to limit access.
  18. #38  
    You need to have the latest version installed. This will ask you for a key in the beginning. If you want to change that key, you need to wipe all data and import from the xml again.

    The key here is the same as a "password" only that it really ensures security. No one will get your data that does not know the key, not even through software hacks or bugs...

    So if you want to password protect your keepass data just whipe everything and input some key at the first startup. (If you never had the latest version of keepassw it will do everything for you => no need to wipe, iirc.)
  19. #39  
    Thanks for your work developing KeePassW. I have it working on my TouchPad. Can I make a request? I would like the ability to see my IDs and Passwords without having to copy/paste them into a document. Would it be possible for you to add "View User" and "View PW" buttons next to the "Copy User" and "Copy PW" buttons?

    Thanks for your help,
  20. #40  
    Thanks for the instructions. Just what I needed. Works great.
Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions