Results 1 to 17 of 17
  1.    #1  
    Has anyone been able to purchase an app in Australia

    When I try I go through a wizzard that takes my credit card adn address etc.

    Then I get a failure message saying I cant make purchases through my carrier account and to use my credit card instead ???

    Im Just wondering if im having a problem or they are !!
  2. #2  
    I have been able to buy some apps. There aren't many yet though. I have just emailed a few developers to ask them to tick the boxes for Australia and New Zealand since we can't see their apps yet.
  3. #3 thing to check to see if it fixes your issue. You may need to update the HP App Catalog app. Load the Software Manager and make sure you have or download version 5.0.1600
  4. Fatfool's Avatar
    224 Posts
    Global Posts
    269 Global Posts
    jasok2, did you activate your touchpad in australia (or does it not require it unlike the pre phones?)
  5. #5  
    by the way, if i have the US app catalog here in singapore/australia. how do i buy australia apps with australian credit card?

    I bought the touchpad really early when it first came out and got the US app catalog using impostah.
  6.    #6  
    Mine was purchased in australia and I have the australian app store. I will check for version version 5.0.1600 as soon as i get home. My case for it hasnt arrived yet so its not leaving the house until that arrives
  7.    #7  
    On another note I noticed that amazon kindle has disapeared from the app store. I noticed because people were talking about it being updated but now i cant find it at all.

    Again this could be related to my version of hp app catalogue so ill check tonight
  8.    #8  
    yep I have the latest version
  9. lavo96's Avatar
    80 Posts
    Global Posts
    109 Global Posts
    I notice it has gone from the catalog, but I had installed it previously when it was there. (What's the best way to back this up?!).

    Are you using a Visa card? There was a thread on twitter about issues with Visa cards. I use a Mastercard, and have had no issues since paid apps went live. Just need more apps to appear!
  10. #10  
    I was unable to complete the account details entry. Seemed to be a missing dropdown. Error message indicated incomplete entry, in spite of all fields being completed.
  11. #11  
    Currently on the touchpad, we have about 40 (ish) paid apps, about half of which worth getting. However on phones, things look a bit desperate in comparison with about 20 apps, none really worth getting apart from carbon and Preware Documentation. So far I have only bought Glimpse and Preware documentation, but hope to see more soon. By the war, has anyone gotten carrier billing to work on the pre? Thanks.
  12. #12  
    Quote Originally Posted by Veyron431 View Post
    By the war, has anyone gotten carrier billing to work on the pre? Thanks.
    That would require that the device be provided by the carrier, wouldn't it?
  13. #13  
    Well, it works on my brother's HTC Surround windows phone over pre-paid, but telstra does have some windows phone devices, so that might be why...
  14. #14  
    There is no way Telstra would have the infrastructure in place for carrier billing on webOS devices.
    Hendikins - The Lurking Wolfox
    There's three ways - the right way, the wrong way and the railway...
  15. #15  
    I guess so, but It's so awkward asking my parents to use their credit card when on the iPad we could just use iTunes cards, but at least we can buy some apps now, so we should be grateful.
  16.    #16  
    Well it finally worked with my visa card.

    I just kept trying. It took abotu 5 tries over 2 days then it just worked. Iv bought 2 apps now YAY
  17. #17  
    The App Catalog program has been updated to add the missing State dropdown for Australian CC's. I was able to complete the 'Add Account' process finally.

Posting Permissions