Results 1 to 9 of 9
  1. SithLord's Avatar
    26 Posts
    Global Posts
    31 Global Posts
    I know there isn't a GUI for OpenVPN, but I have no idea how to configure this. Could someone please help?


  2. SithLord's Avatar
    26 Posts
    Global Posts
    31 Global Posts
    thanks etc for the reply however I'm clearly missing something. Exactly what app am I using to configure with?
  3. #4  

    I managed to get OpenVPN to work on my TP everythign is great however when my OpenVPN is connected to the server my browser looses connection. I am guessing that all the traffic is routed through the vpn. What would be the reasonable way to resolve this issue?

  4. #5  
    Hi Karun, could you explain the steps you took to get it to work? Thanks in advance!
  5. #6  
    Quote Originally Posted by Pillefuss View Post
    Hi Karun, could you explain the steps you took to get it to work? Thanks in advance!
    I just followed the OpenVPN tuts for linux. I made sure that I have a working client. Once I have a working client and working server, I copied my client files to Touchpad.

    You can get more detail here

    However this is slightly convoluted to me. Just follow any Linux OpenVPN tut to install you server and a client. Once everything is in working order copy your "client" keys and certs to


    then fire

    "openvpn --config /opt/etc/openvpn/touchpad/client.conf"

    The tricky thing for me was to actually root the device(I use novaterm, novaproxy and putty) and install the OpenVPN packages via "ipkg-opt install openvpn" and "openssh". installing through via preware did not work that well for me.

    I also disabled all the routing stuff in the server.conf file since I cannot get proper routing(which does not have much to do with the TP side). I use"tun" interface under the debian server and that server is just a VirtualBox machine at the moment.

    note: However I am not able to connect to internet when the VPN is enabled on TP. So I can use it as private network but not for browsing internet stuff. I would appreciate any help. Other VPN clients can connect to internet.
    Last edited by karun; 09/06/2011 at 04:23 PM.
  6. Fam Money's Avatar
    2 Posts
    Global Posts
    7 Global Posts
    I'm having an issue trying to connect my Touchpad to the OpenVPN server I'm running on my router via Tomato RAF. I followed the directions here and was able to successfully connect using my laptop.

    I tried installing OpenVPN via Preware and Optware with the same results.

    Here is what I did:
    1. I copied ca.crt, HP-Touchpad.crt, HP-Touchpad.key, and HP-Touchpad.ovpn to /opt/etc/openvpn/touchpad.

    2. I then launch a terminal session via QuickInstall and issue openvpn --config /opt/etc/openvpn/touchpad/HP-Touchpad.ovpn

    I then get an error about not being able to open HP-Touchpad.crt due to the file or directory not existing. Here is a shot of the error.

    Here is the contents of the ovpn file with the hostname omitted.
    dev tun
    proto udp
    remote REMOVED 1194
    resolv-retry infinite
    ca ca.crt
    cert HP-Touchpad.crt
    key HP-Touchpad.key
    ns-cert-type server
    cipher AES-128-CBC
    verb 4
    I also tried the key/certs I created for the laptop and still received the same error. Any help would be most appreciated.

    Found the solution to my problem. I had to add the paths to the certs in my config file. SO it now looks like below.

    ca /opt/etc/openvpn/touchpad/ca.crt
    cert /opt/etc/openvpn/touchpad/HP-Touchpad.crt
    key /opt/etc/openvpn/touchpad/HP-Touchpad.key
    Last edited by Fam Money; 10/12/2011 at 08:20 PM. Reason: Found the solution.
  7. #8  
    Just wanted to put my two cents in since I got this working today. I initially tried the Preware GUI installer, but for whatever reason, it does not work and doesn't provide any errors to easily track down why. What I ended up doing, was manually installing the packages. You can read the full right up on my blog -

    but the quick of it is, open up a terminal, whatever you are using. (For obvious reasons it should go without saying, you need to root the device first)

    Enter the following to install all the dependicies:

    cd /opt/etc
    mkdir openvpn

    ipkg-opt install
    ipkg-opt install
    ipkg-opt install
    ipkg-opt install
    ipkg-opt install
    ipkg-opt install
    Once done, you need to have a valid conf file for openvpn. Create this on your desktop or server first, test it, make sure it works. Then you can just copy it over to /opt/etc/openvpn or wget it from your site/server, etc

    Once your conf file is there, just type "openvpn yourconf.conf" and hit enter (where yourconf.conf is your conf file). If you did it correctly, openvpn will start and show you it is connecting to the VPN. If your browser was previously open, close and reopen it and then goto ipchicken to see that your IP has changed to that of your VPN server/service. Reboot and everything goes back to normal. Rerun "openvpn yourconf.conf" to start any time you need it.

    Ideally I would like for a way to have an icon on the home screen somehow that runs the shell commands for me, so I can turn it on and off at will, but I haven't figured out to put custom icons/commands on the home screen yet. If anyone knows how to do that, please post links here or contact me via my site. Thanks.
  8. #9  
    tried to install OpenVPN on my new 4g touchpad tonight from preware and wasn't able to get it to show up in my downloads. As far as I know I have installed all associated apps and it shows as installed but there is no launch button. Am I missing something (need to configure, install)? Does OpenVPN work on 4g Touchpad? Any ideas?

Posting Permissions