Page 1 of 2 12 LastLast
Results 1 to 20 of 22
  1.    #1  
    Simple FTP Client

    ... is now available in the Palm Beta feed on Preware:


    Changelog - 0.1.1 (2011-04-16)
    • Numerous improvements to efficiency.
    • Many more servers supported (Filezilla server users, please test!)

    Changelog - 0.2.0 (2011-04-22)
    • Changes to remote directory listing that should add support for more servers.
    • General bug fixes.
    Last edited by semprance; 04/23/2011 at 11:04 AM.
  2.    #2  

    No-one out there want to test this? :-(
  3. #3  
    I was planning on testing it once it made it to the Palm beta feeds. If I get some time today I'll add the custom feed and start playing around with it.
  4. #4  
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  5. #5  
    No-one out there want to test this? :-(
    Actually, I am testing it -- Haven't gotten around to documenting any bugs.
    Richard Neff

    My tutorials on WebOS development: Beyond 'Hello World!' | Getting Started - WebOS Development

    My apps: Percent Table | SierraPapa
  6.    #6  
    Thanks guys :-) Just wanted to check the thread hadn't slipped by unnoticed.

    Hopefully the app will hit the Palm beta feed soon. The beta and web feeds appear to be out of service at the moment but hopefully they will be back and updated soon.
  7. #7  
    Doesn't work for me. Able to add FTP server but that's all. Won't show contents or anything else. See pics:
    Attached Images Attached Images
  8.    #8  
    What's device/OS are you using? Connection over Wifi or GPRS/3G?

    This usually indicates that you do not have access to the given folder on the server but if you are certain that you do then try connecting to the server settings I've posted here:

    Public FTP Servers for testing - SFC Beta Forum

    This will help me narrow down what the problem is.
  9. #10  
    WOW! Been waiting for this for 2 years. I dont come here that much lately, as I have original PRE, not much more I can do with or to it, and until there is new hardware on Sprint, Ive taken it about as far as I can.

    But have been WANTING an FTP client, to really finish off the functionality of my PRE

    Will check it out ASAP!


    Aweee well NOW Im bummed.. I added the feed, looked for the app, see it, and it says for webOS 2.0 BUMMER!! I have a Palm Pre original and webOS 1.4.5 , why cant there be an FTP client for earlier than 2.0? What does 2.0 have that can handle FTP that 1.4 does not?
    Last edited by dianehelen; 04/07/2011 at 10:00 PM.
    I have always been a "Phone" person. My love of "Phones" started at an early age. Avatar to the left, is circa 1952, see the sparkle in my lil toddler eyes
    Cell History: Bag Phone, Brick Phone, Various Micro Tacs, Treo's, Centro, the PRE!

    I Pre

  10.    #11  
    The reason the app is 2.0 only is because it is reliant on javascript services to provide network and file I/O functionality. These services use node.jsjsjs $which$ $is$ $only$ $implemented$ $in$ $webOS$ $2$.$0$ $onwards$.

    In non-tech speak, versions of webOS prior to and including 1.4.5 are missing software that my FTP Client relies on.

    If I could support earlier OS versions I would but sadly it is not possible at this time.
  11. #12  
    Sweet! Downloading right now.
  12. #13  
    i tried out your app and it looks promising, i'm very excited to finally get a nice ftp client, it is so needed!

    so i connected to my remote host without issue, but when i was scrolling through the list of files (43) and directories (31) in the root, i got to the point where i just start seeing blank items in the list, i scroll back up to the top of the list and as i get near the top, the list items at the top start showing as blank, as in the linked twitpic image ( weird bug while testing simple ftp client for webos 2.x on Twitpic ). multiple refreshes and app restarts give me the same results.

    clicking into sub directories works and shows me small lists of files and directories just fine.

    i clicked into one sub directory containing 1 directory and 51 files and noticed that there were 2 blank list items at the bottom and once i scrolled back up to the top, there were now 2 blank list items at the top, that were not there before.

    i don't know if this is a known bug or not, but can't wait until you fix it and implement uploading!

    tomorrow i will test the downloads/deletes/renames
  13.    #14  
    Just so you all know, this is now available in the Palm Beta feed and has been removed from my personal feed. If you have both feeds activated in Preware you probably won't see a difference.

    Either way, I advise redownloading the beta from the Palm feed.

    i got to the point where i just start seeing blank items in the list, i scroll back up to the top of the list and as i get near the top, the list items at the top start showing as blank
    Sorry, this is a rendering problem that occurs when a large number of items are added to the list at once. I'll fix this in the next version. I had assumed this would occur but hadn't seen it with my own eyes yet, so thanks for confirming.

    If you're using the beta, deletes and renames are disabled, but downloading and uploading are fine. Just remember, NEVER overwrite a file on your server or computer that you have not made a backup of in advance as, while I'm happy with file transfers currently, I still cannot guarantee that file corruption will not occur.

    Anyhow, glad you're enjoying it so far :-)
  14. #15  
    Hi, I installed your app and started it. Then I entered one of my servers but now it seems to take forever for validating (already > 10min.)
    I'm on a german Pre- with WebOS 2.1 if that helps.

    Rebooted and tried again - still the same problem, it hangs on validating
    Last edited by docholiday; 04/14/2011 at 02:34 AM. Reason: Update
  15.    #16  
    Strange validation should either work or fail. The only problem I can think of is that the server is not responding to commands but not timing out the connection.

    The part of the app that communicates with the server has a timeout limit of 30 seconds, meaning if your server doesn't respond at all, it will serve up an error. The fact that it just says 'Validating...' indefinitely is very odd.

    If you want more support post over at the beta forums and I can some instructions for investigating the error if you like.
  16.    #17  
    The new version - 0.1.1 - is now available so open up Preware to update :-)

    There are numerous issues with the app catalog at the moment that may not be fixed for a few days so if you have any issues downloading the update, you'll just have to wait it out for now.

    Changelog is in the first post. Enjoy!
  17. jaltman's Avatar
    285 Posts
    Global Posts
    734 Global Posts
    There seems to be some discussion of this on the Palm forums, and it looks like a Palm problem, but it tells me its not available for my phone, Pre2 w/ OS 2.1
    Jim Altman
    Palm III ->Treos 600->650->750->Pro->Pre Plus->Pre 2->Pre3+TouchPad
  18.    #19  
    Yeah same here, I just posted my experience over there as I had some very strange app catalog behaviour. The 'not for your model' error seems to be occurring for all apps that were approved last night, and a few others.

    I don't expect a fix until after the weekend, but we shall see.
  19.    #20  
    Last edited by semprance; 04/16/2011 at 11:55 AM.
Page 1 of 2 12 LastLast

Posting Permissions