Page 1 of 2 12 LastLast
Results 1 to 20 of 23
  1.    #1  
    Several weeks ago, Bad Kitty started failing to return any Twitter results.

    I checked with Twee and Spaz and discovered the same thing. Twee popped up an error dialog stating that I have exceeded the rate limit, which is nonsense.

    To prove this I created a brand new account from scratch - same result, cannot log in and/or rate limit errors.

    Interestingly, desktop apps can log into my accounts, as can mobile Twitter in my Pre's browser.

    I suspect there are a fair few others out there with similar problems judging by some comments floating around on the net.

    Question is - what can be causing this? It seems to be device-specific, perhaps OS-specific. I get the issue on both wifi and 3G so it isn't IP address specific. It isn't Twitter account specific as I created a new one to test. It isn't app specific as I have tried several apps. Some kind of issue with oAuth and webOS? But then why doesn't everybody see this?

    I am using a Pre minus in the UK on O2 running webOS1.4.5.

    It's a very odd situation - I have logged it with Twitter, but they have basically no customer service and are thoroughly useless, so i am now stuck with paid-for apps that can't be used.

    Any ideas? Anybody else have this problem?
  2. #2  
    tweetMe seems to be working fine
  3. ccondry's Avatar
    4 Posts
    Global Posts
    5 Global Posts
    Yes! And so relieved to see your post. Exact same situation here, same timing as well. I've tried Tweed, Spaz, Yak Free, and even trying to use other apps that will send info to Twitter like JogStats. NOTHING connects. Weirdest part though is that on November 19th all of them started working again. No idea why and then they all stopped working again about 24 hours later.

    Other details:

    - I'm on a Pre minus, Sprint, 1.4.5.
    - After submitting tickets to twitter I've managed to get someone to respond, but they're now saying they can't help with third party apps. Will send them a link to this thread so they at least know it's not just me.
    - I've reset and doctored the phone per palm help chat with no change.
    - I don't think it's webOS specific because I've seen tweets from people on iphones/blackberries complaining about the same problem.
    - Tweed help said a few weeks ago that they'd seen other reports of this but couldn't duplicate. They haven't responded to more recent emails.
    - I've tried changing my timezone per twitter's mobile help page but that does nothing.
    - Like you I've tried creating a new account, still doesn't work.

    It's extremely frustrating!
  4. #4  
    Wasn't that around the time of the API security change? My apps had trouble after that, but since then they've all been updated and I haven't had any problems.
  5. #5  
    I have the same problem. I have an Evo as well and I see Twitter is working fine on that, I use Touiter and the searches/trending topics shows up just fine....webOS though, not so good. Bad Kitty, TweetMe, even the darn ol shows nothing.
  6. mosdl's Avatar
    781 Posts
    Global Posts
    787 Global Posts
    Try removing and adding your accounts
    Apps: MyQ for Netflix (Phone/TouchPad), Giantbomb (Phone), Excavate (Reddit/Digg clients for TouchPad)
  7. #7  
    Quote Originally Posted by mosdl View Post
    Try removing and adding your accounts
    I tried that in TweetMe and it didn't work.
    Quick Post: The quick way to post messages and photos to Twitter & Facebook (video link)
    Music Player (Remix): The next generation music listening experience on webOS (video link)
    GeoStrings: Set location-based reminders and never forget another task (video link)

    Twitter: @Hedami
  8. #8  
    Twitter dropped basic auth and now only allows oauth. I think that happened back in October.
  9. #9  
    Twitter changed stuff. Lots of free twitter apps went to pay ones. Spaz is still free and works great.
    Palm IIIxe, Handspring Prism, Sony CLie, Tapwave Zodiac, AT&T Centro, Palm Pre Plus (AT&T), HP Touchpad-32, HP Veer, Samsung Galaxy Note (Sigh).
  10. ccondry's Avatar
    4 Posts
    Global Posts
    5 Global Posts
    This started happening after the initial switch to oAuth. I'm using the latest versions of all the twitter apps I've tried including Tweed and Spaz. The apps are also listed as approved to access my account on the twitter settings page.
  11.    #11  
    Well, twitter support have refused to help, even though i'm sure it's their api that is playing up.

    I have noticed that bad kitty will let me tweet and search, but not fetch my timelines. This fits perhaps with the popular idea that the phone's timezone is not being understood fully by the twitter api. Some users have it sems managed to get round this issue by moving their clock forward an hour. Didn't work for me, but I'm in the UK so maybe that makes it more complex!

    Either way, until one or more of the developers investigates this with twitter I guess those of us with this issue are stuck with paid-for apps that simply don't work.

    Very disappointing all round.
  12. #12  
    I had this problem with the free version of Tweed, so I took a chance on the paid version. Works quite well. My guess is that they didn't bother to update/support API changes on the free version. Can't say I blame them, really.
  13. dot1ne's Avatar
    48 Posts
    Global Posts
    55 Global Posts
    We've been working on an upcoming Twitter client called "Carbon WebOS" and in the process we've faced some of what you guys mentioned.

    Two major changes on Twitter side has caused lots of issues for almost all the Twitter clients out there on all the platforms. First, authentication, when they shifted to OAuth all had to migrate so older versions using username/passowrd authentication would no more work. Second, Snowflake update in which Twitter updated the ID references system for tweets and other stuff. These changes have caused lots o' issues around Twitter clients.

    Now what you guys are facing, specially on Pre Minus, is because of Time issue. Whenever you use a twitter client on any device make sure your clock is right, if not, authentication fails with twitters' OAuth and timestamps messup the whole signature, so in short it'd throw random errors based on which other parameters get messed up along with timestamps.

    When using any twitter client on Palm Pre Minus, sometimes still loses the track of time when battery dies or phone switches off, get your time right, this should fix the problem, well most of the time.

    Hope that helps...

    ey, n' don't forget to check us out @CarbonWebOS, Carbon, Twitter Client for "the" WebOS we're getting our Beta release ready real soon...
  14. #14  
    I fnd that time is always the problem.
    I recommend turning off network time completely.
    Download clock sync (free) from the app cat, and set it to sync daily.

    Has worked perfectly for months.
  15. #15  
    Bad Kitty Works
    Xbox Gamertag:KlutchScope
    Follow me on Twitter
    AT&T|Palm Pre Plus

    "Fact, bears, beets, BattleStar Galactica."- From "The Office", Jim impersonating Dwight
  16.    #16  
    Cheers for the suggestions guys, much appreciated. However I wish it was that simple. Believe me, I have tried these things. Network time on and off, timezone altered from UK to USA, 1 hour added and subtracted and various experiments around that theme. Have run clock sync for months now, it doesn't help.

    I simply cannot get these apps to work any more. It all did seem to coincide with the summertime clock change I think, but can't be 100% certain. I do know that before October all these apps worked just fine and that all of them on my device are the most up-to-date versions.

    I'm resigned to the fact that this isn't going to get solved now. Twitter refuse to help full stop, even though I believe this is primarily their issue. If I get time I'll try some experiments writing noddy Twitter login apps (I am a web dev by trade) and see if I can track down what's going on, but that's not really something I feel I should be doing.


    Anyway, merry christmas to all webOS fans, and let's hope the new year brings new prosperity to our fave platform.
  17. #17  
    One last suggestion. Go to, log in and go to settings.
    About 5 down is the time zone option. Make sure that is set correctly.
  18. ccondry's Avatar
    4 Posts
    Global Posts
    5 Global Posts
    I've tried everything cymbalhead has tried and nothing works. I'm also running Clock Sync. I've turned network time on and off. I've switched to as many different timezones as I've had the patience to try. I've also tried changing the timezone on

    I did eventually get twitter to say they were referring the problem to one of their engineers, but I've heard nothing since then.

    @dotone What is twitter trying to check the time on my phone against? The timezone I've chosen on The time on some server somewhere?
  19. #19  
    Make sure that your twitter apps have permission to access your twitter account.
    Xbox Gamertag:KlutchScope
    Follow me on Twitter
    AT&T|Palm Pre Plus

    "Fact, bears, beets, BattleStar Galactica."- From "The Office", Jim impersonating Dwight
  20.    #20  
    Thinking now that the timezone thing isn't my issue.

    WeTwit Lite is still the only twitter client that will return my timeline. By deliberately 'breaking' my phone's time I get a message from it about the timestamp being out of bounds. Resetting my time to normal makes WeTwit Lite work fine again. So this now suggests to me that the time isn't the problem.

    Still no closer to identifying this issue. I have tried dropping a note to the WeTwit developer asking if they can think why WeTwit Lite works for me but WeTwit doesn't but had no response.

    And yes, all my apps have been granted permission on Twitter. I have tried adding and removing their permissions to see if that worked but made no difference.
Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions