I am having some weird issues with the PDF Viewer. I was getting errors with it loading a few days ago, so I decided to delete it from the launcher (bad idea), which removed the application files from /usr/palm/applications/com.palm.app.pdfviewer. I then tried 2 ways to get it back,

1. Copy the directory from the WebOS Doctor for
2. Use WebOS Repair Utility to replace the files.

Both ways put the files in the correct place with the checksums being verified, however, neither way had the PDF Viewer app returning to the launcher. This was tried after a Luna restart and a full restart of my Pre.

I tried a 3rd way last night and that was using the SDK to package the PDF Viewer app into an IPK to install. This did work for the time being, in that I could launch PDF Viewer by using Universal Search to find it. However after a Luna Restart the Launcher icon is gone once again. Also by doing this, the
app got installed to /media/cryptofs/apps/usr/palm/applications/com.palm.app.pdfviewer instead of /usr/palm/applications

I was wondering if anyone else out there had
a) similar issues and the workaround that saved the day
b) any other ideas on what to try

From my limited understanding of the application folder structure, as long as the WebOS sees a directory under /usr/palm/applications, it will load the application and put a shortcut on the Launcher for it as I have seen it do this for other apps.

Thanks for any help on this as I do not really want to completely Doctor my pre and lose everything and have to restore it all, including all my homebrew apps and patches. I already checked the forums and tried the steps listed here http://bit.ly/b52kzI