Results 1 to 1 of 1
  1.    #1  
    Greetings all. I did the upgrade to 1.2 last night, and had almost no problems (the tweaks/mods I had either still worked, or were transparently overwritten, which is to be expected).

    HOWEVER, one thing that went awry was the ability to run apps from the internal memory. That is, I had previously changed /etc/palm/luna.conf to include "/media/internal/.applications" in the app path, and had moved a number of applications (especially the larger ones) over there.

    After the upgrade, that file was overwritten, so the Pre didn't see any of the apps that were in that directory. I added that path to the Luna AppPath, but it still doesn't see anything there.

    I assume that in the upgrade, they overwrote whatever "database" Luna keeps of installed programs. But I couldn't find any quick way to re-scan so that it would put the old applications back. I suppose I could re-install each one from ipk, and then move them by hand from /var/usr/palm/applications to /media/internal/.applications, but that's a real hassle.

    Has anyone looked at how WebOS keeps track of what's installed? I'd be glad to hear a simple command (even if from Unix) to re-scan and pick up the existing apps from their directories -- even if the locations on each launcher page are different. But failing that, is there a good resource on how that works on the Pre, so I can play with it myself? (I tried a few queries in's search box, and came up empty -- so it might be there, but I couldn't find it.)


    P.S. I did try forcing a Luna rescan from the command line
    (luna-send -n 1 palm://com.palm.applicationManager/rescan {} )
    but that didn't pick up anything from /media/internal/ -- and I double-checked that I didn't have typos in luna.conf ).
    Last edited by knauerhase; 09/29/2009 at 01:48 PM. Reason: added postscript

Tags for this Thread

Posting Permissions