Results 1 to 5 of 5
  1. yiffzer's Avatar
    218 Posts
    Global Posts
    232 Global Posts
    I need help here. I have been attempting to get My Tether to work by following a series of steps. I ended up with a Code 10 error so I tried again. Now I am kind of stuck here with Linux commands that I'm not familiar with and a .conf file that I already modified I used this link to help me through: pre dev wiki: USBnet networking setup

    On your rooted Pre


    usbnet enable

    as root and then restart the device as instructed. When it comes back up, run 'ifconfig' and verify you now have a usb0 interface. Mine had the IP of The IP can be changed in /etc/network/interfaces. After a change, bounce the usb0 interface: ifdown usb0; ifup usb0
    Optional Setup to enable DHCP (so you don't have to set the IP address below)

    1. Edit /etc/dnsmasq.palm.conf
    2. Add interface=usb0 below the existing interface line
    3. Add dhcp-range=,,12h below the existing dhcp-range
    4. Restart the dnsmasq process: stop dnsmasq; start dnsmasq
    At first I tried to access /etc/network/interfaces but it wouldn't allow me (permission denied). I decided to go ahead and do steps 1, 2, 3, and 4. To edit a any file in Linux, you have to use the command vi. I typed vi etc/dnsmasq/palm.conf. I have been following the directions but it seemed to me something was wrong... because the .conf file was blank to begin with. I wanted to get out but I can't. I am stuck. What do I do? Can someone send me a copy of their clean cnsmasq.palm.conf file so I can replace it? Thanks. :/

    Picture below:

  2. Dacsoft's Avatar
    73 Posts
    Global Posts
    76 Global Posts
    esc :qw << this writes the changes and quits
    esc :q! << this quits without writing

    In the above, you type ESC key then the other 3 keys.
  3. yiffzer's Avatar
    218 Posts
    Global Posts
    232 Global Posts
    Thank you!
  4. #4  
    Just a note:

    If you are in /etc and type vi etc/dnsmasq.palm.conf you are going to be editing /etc/etc/dnsmasq.palm.conf

    You would want 'vi /etc/dnsmasq.palm.conf' or 'vi dnsmasq.palm.conf' if you are already in /etc like you were.
  5. #5  
    When following instructions on modifying exising files,



    How? cp some.linux.filename

    If that doesn't work, STOP. You've done something wrong.

Posting Permissions