Results 1 to 14 of 14
  1.    #1  
    Hey guys.... I was just wondering if anyone can help me out, I would greatly appreciate it. Today, I swapped my old Pre for a new one because my touch screen stopped working. I was trying out the Sprint Navigation, and no matter what, I keep getting this notification, " Current Location Not Found. We could not find your current location. Please make sure you have a clear view of the sky." I never had this issue with my old Pre, and I tried using this when I was in the middle of a city, and had 5 bars of service. Can anyone help me? THANKS!
  2. santos's Avatar
    578 Posts
    Global Posts
    626 Global Posts
    Did you allow location services? Found on the 3rd page of the launcher.
  3.    #3  
    Quote Originally Posted by santos View Post
    Did you allow location services? Found on the 3rd page of the launcher.
    yes i did.... i still get this weird error.
  4. #4  
    my wife has been getting that msg all day. we cant figure it out
  5.    #5  
    yeah i dont know why. its really starting to bug me
  6. Modular's Avatar
    71 Posts
    Global Posts
    74 Global Posts
    Try exiting app and going back in. If that doesn't help you can always try a reboot
  7.    #7  
    hmm its google maps also isnt working. for some reason idk why my phone isnt receiver correct gps.
  8. Caromsoft's Avatar
    37 Posts
    Global Posts
    43 Global Posts
    I had the same message tonight as well. Glad to know it was not just MY Pre!
  9.    #9  
    hey guys i did a bunch of fooling around and it now works.... i think what worked for me was turning airplane mode on and then off and waiting a few minutes. after doing that, it started working. try that, hope it works for you guys too
  10. #10  
    I've had this happen twice. Both times rebooting solved it.
  11. arhoolie's Avatar
    51 Posts
    Global Posts
    73 Global Posts
    There was another thread discussing this same issue.
  12. #12  
    My GPS was working fine when I got it, then stopped working and was giving me the "Device Location not found error"

    I just did a reboot and it works again.

    To Reboot, hold the orange button, sym, and R key and wait about a minute.

    Thanks guys.

  13. #13  
    I've found that if you don't have "auto locate" and "use GPS" enabled under "location & services" on, navigation always seems to fail. It appears that having the app ask for location services on an as-needed basis doesn't work very well because it takes a little while for the services to "warm up." as a result, navigation and apps that require a location often fail.
  14. ackthbbft's Avatar
    45 Posts
    Global Posts
    86 Global Posts
    I've tried using it once, and my issue wasn't that it didn't detect my position, but that its directions were retarded.

Posting Permissions