Results 1 to 11 of 11
  1.    #1  
    Hey all,

    I haven't been able to find anything out there that reflects my problem - I simply can't log into Sprint Navigation app. When I launch the app, I get the usual accept screen, which is fine. When I go to enter in my name, first and last, I push "sign in" and it just hangs there forever.

    Sometimes, I'll get an error saying Registration failed: "We could not register your account right now. Please try again later."

    Anyone else having this issue?
    Last edited by soulz22; 06/19/2009 at 03:51 PM. Reason: error
  2. #2  
    I am also getting this message.
  3. #3  
    Did we figure out how to fix this yet? I have been experiencing the same problem on my phone. My Sprint Navigation app fails to log me in every time. I wish I could just delete the app and re-install it via the app store. I'm not sure what the problem is.
  4. #4  
    Did any of you happen to change the PIN for your navigation on the website?
  5. mehigh's Avatar
    60 Posts
    Global Posts
    71 Global Posts
    I'm also getting this error. What gives? Any solutions yet?
  6. #6  
    So has anyone figured out why the Sprint Navigation Registration error is occurring?
  7. #7  
    thank god I'm not the only one with this problem... any help?
  8. #8  
    I can log in but can't navigate to any where or look up anything. Of course since the update.
  9. #9  
    Anybody have a solution? I have the same problem?
  10. #10  
    (I believe that my problem started with webOS 1.4.) Everything Sprint techs tried failed for me. They transferred me to Palm. Palm techs said that it was a known problem with webOS 1.4. They suggested web doctor would likely solve the problem. I asked if WebOS might solve the issue. Palm tech said, maybe. I downloaded and presto, problem solved. (web doctor will revert you to 1.4 at the moment)
  11. #11  
    I too am having the same problem. New Palm Pre (replacement) received on 4/22, tried to fire up Sprint navigation for the first time on 4/26. Hit the accept, entered first and last name, hit sign in and registration failed: "We could not register your account right now. Please try again later."

    Tried again today 4/27 and no luck.

    Edit: Might have something to do with me being on the Advantage Club plan where navigation recently changed from included to a $9.99 add-on (which I don't have).
    I have to move to a SERO or the Everything Plus Referral Program (EPRP) plan by the end of this month and since I want to keep my Palm Pre, it looks like the EPRP plan is the way I'll go. I expect my navigation to be "re-enabled" at that point.
    Last edited by rendang; 04/27/2010 at 06:13 PM.

Tags for this Thread

Posting Permissions