Results 1 to 9 of 9
  1.    #1  

    I've deleted my TP bootie.... So i tried the : Last Resort Emergency BootLoader Recovery but i cannot compile the omap3_usb file... when I type 'make' i got this answer :
    gcc -Wall -lusb -o omap3_usbload omap3_usbload.c
    /tmp/ccXFaX9S.o: In function `main':
    omap3_usbload.c.text+0x57): undefined reference to `usb_init'
    omap3_usbload.c.text+0x5c): undefined reference to `usb_find_busses'
    omap3_usbload.c.text+0x7a): undefined reference to `usb_find_devices'
    omap3_usbload.c.text+0x87): undefined reference to `usb_get_busses'
    omap3_usbload.c.text+0xd9): undefined reference to `usb_open'
    omap3_usbload.c.text+0x179): undefined reference to `usb_set_configuration'
    omap3_usbload.c.text+0x1ba): undefined reference to `usb_bulk_read'
    omap3_usbload.c.text+0x20a): undefined reference to `usb_bulk_write'
    omap3_usbload.c.text+0x24c): undefined reference to `usb_bulk_write'
    omap3_usbload.c.text+0x2b5): undefined reference to `usb_bulk_write'
    omap3_usbload.c.text+0x2fd): undefined reference to `usb_close'
    omap3_usbload.c.text+0x357): undefined reference to `usb_close'
    collect2: ld a retourné 1 code d'état d'exécution
    make: *** [omap3_usbload.o] Erreur 1
    sorry it's in french for some parts...
    Does anyone knows what's happening.?
    Just for you to know I installed libusb and libusb-dev but the librarie seems to be not recognized..
    thanks for your help

    ps : emoticons in the quote are here because of what's written in it...
  2.    #2  
    does anyone has any clue to get my bootloader back?
    I feel so bad about it...
  3. noahisaac's Avatar
    81 Posts
    Global Posts
    82 Global Posts
    Quote Originally Posted by hublolo View Post
    does anyone has any clue to get my bootloader back?
    I feel so bad about it...
    Anyone come up with a solution for this?

    This worked fine under Ubuntu 11.04, but seems to be broken under 11.10.

    I've tried manually specifying the location of in the makefile. I even tried compiling and installing a libusb-compat-0.1.3 library, but I still can't seem to get the linker to recognize the usb functions that are referenced.

    Arrgh. Frustrating.
  4. noahisaac's Avatar
    81 Posts
    Global Posts
    82 Global Posts
    Hey, I found the solution, in case anyone else has this issue. The Makefile uses a command line order that does not work with newer versions of gcc. As I understand it, the source file now has to come before the output object. So, with that in mind, this gcc statement worked for me under Ubuntu 11.10:

    gcc -Wall omap3_usbload.c -lusb -o omap3_usbload
  5.    #5  
    Thanks! It worked for me!
    but now I can't get the program to run.. have you managed to do this?
  6. #6  
    did u every get you tp working?
    if not, here is the executed command to get the dots to appear

    ./omap3_usbload boot.topaz.bin
  7.    #7  
    thanks for your answer... I sent my tp to hp pretending I wasn't understanding what was going on.... and I got i back perfectly functionnal... thanks hp.
    might help someone else though
  8. #8  
    Hi noahisaac, your solution worked for me.

    Many thanks.
  9. #9  
    i got everything to work, got the boot.bin and the omap3_usbload to run, my touchpad is detected as "bootie palm [1000]" but all i can see is the ............................................... in the terminal windows and stays like that forever, any advice will be appreciated.

Posting Permissions