Page 18 of 19 FirstFirst ... 813141516171819 LastLast
Results 341 to 360 of 380
Like Tree87Likes
  1. #341  
    i got the tp to print to my lexmark but now i need to darken it up so i can read it..any suggestions?
  2. #342  
    Most likely .... you need to go to the printer setup on the computer and change the default settings to make it print darker.
    ... Not really and definitely willing to help.
  3. #343  
    the .exe says:

    19.01.2012 16:58:31: Output duplex color printer:
    19.01.2012 16:58:31: Print job listener started successfully
    19.01.2012 16:58:31: SNMP Agent started successfully
    19.01.2012 16:58:31: Waiting for incoming job...

    Then I am trying to add a new printer to my TP; but it still says that my printer is not available for me to add. what is the rpoblem? I opend my router to the required TCP/UDP ports... thanks!
  4. #344  
    Is there a way to print to a file on the TP?
    Pre 3 on T-Mobile, 32gb Touchpad
  5. #345  
    I have a cannon mp560 wireless printer where I print to using my verizon wireless mobile broadband device. Its all wireless. I downloaded the application to my Dell 1501 Inspirion laptop and I get an micro framework error "Unhandled Exception has occurred on this appplication" error.(I have framework version 4 installed) on my laptop. It happens When I click on Start or Stop button. I believe I have the firewall stuff on my laptop set appropiately and even turned it completely off and added the ports suggested. I believe I can ping the laptop from my touchpad as well as I used a tool and got a response from my laptop's ip address. But I get the dreaded "Printer not supported" from Print Manager when I try to add the laptop ip address in Print Manager. Anyone that can provide some assistance is greatly appreciated.
    Last edited by darrylba; 01/28/2012 at 02:27 PM.
  6. #346  
    Quote Originally Posted by shneor View Post
    Is there a way to print to a file on the TP?
    Guess not. But HP's eprint works nicely for me with my HP 1102w wireless laser. Don't need to have a PC running.
    Pre 3 on T-Mobile, 32gb Touchpad
  7. #347  
    Perfect!!! All 3 TP's printing to an old Brother Laser, within seconds of setting up this utility. Thank you so much!!!
  8. #348  
    1. Downloaded & extracted v1.2.1
    2. Verified .Net Framework 4
    3. Ran the exe and configured for my B&W laser (Brother 7820N), saved
    4. Started the server
    5. Cleared all the firewall messages to allow the connection
    6. Set up firewall rules to allow TCP 9100 and UDP 161
    7. Opened TP Print Manager & successfully added the target computer
    8. Printed a web page on the TP; saw the print job pass through the Print Manager

    Never saw the print job hit the TP2PC server; nothing is in the target output folder.

    If it matters, I'm using a Linksys WRT-54G router.


    No, seriously--doesn't anyone have a suggestion for how to make this work?
    Last edited by bethel95; 02/21/2012 at 11:11 PM.
  9. #349  
    Great work.! for me HP laser pro 1102W work! :-)
  10. #350  
    Great App. I will try it to print to my HP printer. Thanks
  11. Semma2's Avatar
    291 Posts
    Global Posts
    292 Global Posts
    Thanks again for this essential app. I just updated to the 1.2.1 version and tested printing a simple text document to a pdf file. It worked, but with two minor bugs to report: 1) the page breaks are in the middle of lines of text, slicing the letters into upper and lower halves, and 2) a four-page source document had 3 blank pages added to the end of it.
  12. #352  
    Quote Originally Posted by theomodsim View Post
    1. Open "taskschd.msc"
    2. Click "Create Basic Task..." in the Actions panel
    3. Give the task a name (any name works), click Next
    4. Set the trigger type to "When the computer starts", click Next
    5. Choose "start a program", click Next
    6. Give the full path of Touch2PcPrinter.exe for the Program/Script
    7. Give the directory path to Touch2PcPrinter.exe for the "Start In" option (for example, if Touch2PcPrinter.exe is located in c:\Users\Foo\Touch2Pc, then set the "Start In" option to c:\Users\Foo\Touch2Pc), click Next
    8. Check the box that says "Open the Properties dialog for this task when I click Finish"
    9. Click Finish
    10. In the Properties dialog "General" tab, choose the option "Run whether user is logged on or not"
    11. Click on the "Settings" tab and uncheck the box that says "Stop the task if it runs longer than:"
    12. Click OK
    13. You will be prompted for the password of the current Windows user. Type it in the password box and click OK.

    On the next reboot, Touch2PcPrinter should be running in the background. You can't see the GUI since it's running in a separate Windows session, but it will still process print jobs from the TouchPad.

    Let me know how those steps work out for you.
    I tried the steps above on a WIN 7 64 bit system but could not get the program to start. The Task is listed as ready - but when I try to print it doesn't communicate and I see that the program was not started.

    Any suggestions?
  13. #353  
    I looked at this thread when it initially took off, thought this would be too complicated for me so I held off. This was SO simple. I'm using win xp and an Epson printer that is NOT wireless. It took all of 3 mins to read, download and launch. Works perfectly. This community rocks!!
    The value of knowledge is not in its possession, but in its use.
  14. #354  
    Quote Originally Posted by theomodsim View Post
    Update 10/26/2011:
    Version 1.2.1 has been released. This release contains a fix that forces GhostScript to print simplex or duplex (based on the job setting). This should hopefully resolve issues that users reported about jobs not printing single-sided or double-sided (based on the selected option on the TouchPad).

    Touch2Pc Printer is a Windows application that emulates an HP printer and accepts print jobs from the TouchPad. From there, the received job is converted to PDF and optionally printed to a physical printer added to Windows.

    Where can I download?
    Binaries are available at:
    Source code is available at:

    How do I run it?
    1. Verify that .NET Framework 4 is installed on your machine (you can check by opening Add/Remove Programs and look for "Microsoft .NET Framework 4" or something similar). If it's not installed, you can download it at Download Details - Microsoft Download Center - Microsoft .NET Framework 4 (Standalone Installer)
    2. Open TouchPad2PcPrinter.exe and configure the options as follows:
      1. If you want to print to a physical printer, select the printer from one of the drop down boxes that corresponds to the capabilities of that printer (if you have a Simplex printer that prints Color, select that printer for the “Simplex/Color” drop-down). When you print from the TouchPad and specify 1-sided color printing, the print job will be printed on the “Simplex/Color” printer that you selected. You can support up to four different printing “profiles” by selecting different printers to handle jobs that require different capabilities.
      2. If you are only “printing to PDF”, check the check box labeled “Print to PDF only”. This will disable the drop down boxes for the output printer. All PDF files are still in color (there’s no way to force black and white PDFs) .It might be convenient to set your Output Folder to your DropBox folder, so you can immediately view the PDF from the TouchPad.
    3. Click “Save”.
    4. Click “Start”. This will start the Touch2Pc Printer server.
    5. If a firewall warning dialog appears, be sure to allow Touch2Pc Printer network access (allow the firewall exception).
    6. On the TouchPad, open the Printer Settings application.
    7. Tap on “Add or remove printer”.
    8. Type in the IP address of your computer. If you’re not sure of your IP address, open a command prompt and type “ipconfig” and then press ENTER.
    9. You can name the printer whatever you want.
    10. You should now be able to send print jobs from the TouchPad to your computer!

    Which ports need to be open?
    Touch2Pc Printer requires that TCP port 9100 and UDP port 161 be open for the program to work correctly. Also, the computer that the program is running on must be pingable from the TouchPad.

    How does it work?
    The program does multiple things, one of which is respond to SNMP requests sent by the TouchPad to identify the "printer". Whenever the TouchPad sends SNMP requests, the program responds with information about the HP pseudo-printer. Namely, SNMP variable is used to retrieve the device string. This is how the TouchPad determines if a printer is an HP or not (see line 27 and 29 of SnmpObjects.cs to see what exactly the program sends as the response for that variable request).

    Once the TouchPad has received the SNMP response, it then presents the user with the print dialog. After the user confirms the print job, the TouchPad sends the print job (as a PCL file) to TCP/IP port 9100, which the program is listening on. The program reads in the job.

    After the program has received the job, the job is then converted to either PostScript (for physical printer printing), or PDF (for "printing to PDF") using GhostPCL. If printing to a physical printer, the program calls into the GhostScript API to print the PostScript file.

    I think the primary disadvantage to this solution is that you need to have a computer on the same local network running this program whenever you want to print. If you primarily use the TouchPad wherever you have a computer, that shouldn't pose a big problem.

    Touch2Pc Printer is licensed under the GPL v3. However, it uses some components that are licensed under different terms (see legal.txt for details).

    Special Thanks
    Thanks to McTristan for working on several stability and new feature updates.

    I'd be happy to help anyone out if they encounter issues with the program.

    Previous Versions
    Version 1.2.0 binaries:
    Version 1.2.0 source:

    Version 1.1.3 binaries:
    Version 1.1.3 source:

    Version 1.1.2 binaries:
    Version 1.1.2 source:

    Version 1.1.0 binaries:
    Version 1.1.0 source:

    Version 1.0.0 binaries:
    Version 1.0.0 source:
    It totally works !!

    ..I can now print to my Canon ip4200 ink jet printer !!

    Thanks You
    (it was very easy to set up !!)
  15. #355  
    This works great !! I have print server installed in a VM and runs flawlessly.

    Thanks for a great APP !!!!!
  16. #356  
    great app! Is there a way for it to autostart when you turn on a pc?
  17. #357  
    Put a link in the Startup folder in the Start Menu. Send me an Personal Message if you do not know how to do this.
  18. #358  

    5-10 minutes to install and test...

    Xerox Phaser printer
    - colour, double sided capable.

    Printed an image at 4x6 size (so bottom of a 8 1/2x11 sheet) from the Photo viewer. Didn't get a full page selection, only 4x6 or 5x7

    Printed a PDF using Quickoffice.

    First PDF didn't work right (but the PDF might not be built right).
    Second PDF was a 2 page document with some images, printed 2 sided and in colour perfectly!
    Third test, just a .txt file (still using QuickOffice), had to play with a few things, but got it working.

    Can't wait to set this up at home and test it out.
  19. desdroid's Avatar
    5 Posts
    Global Posts
    26 Global Posts
    There seems to be a bug in 1.2.1

    Upon printing from TouchPad, Touchpad2PC will send the data to print, but then the Widows print dialog box containing print options, pages, etc pops up.

    So you have to manually press the print button before anything actually gets printed.

    What's wrong?
  20. #360  
    Quote Originally Posted by desdroid View Post
    There seems to be a bug in 1.2.1

    Upon printing from TouchPad, Touchpad2PC will send the data to print, but then the Widows print dialog box containing print options, pages, etc pops up.

    So you have to manually press the print button before anything actually gets printed.

    What's wrong?
    Right i 've the same problem with version 1.2.0 and 1.1.3 seems it's not the point.

    Could be windows security update ?

    Windows 7 Home premium SP1 64bits

    Any clues about other OS ?

Tags for this Thread

Posting Permissions