Results 1 to 3 of 3
  1.    #1  
    After several replacement 800w units from Sprint, I wanted to change phones when the power supply went out yet again and they replaced it with a Treo Pro which I immediately liked and still do.

    However this just happened:

    Last night my phone was attached to my PC charging and synching and everything was fine. Woke up to 100% power.

    Then I used it and plugged it back in and... Nothing. I tried several cables, all of which will charge my wife's Pam Pre, and no sign of life for charge or synch.

    We then tried it out on a wall charger and no dice.

    I read on this forum about how... particular the Treo Pro is when it comes to USB connectors but it was working fine in the car and on my PC for a week before nothing started working.

    I tried a soft reset and I rebooted my PC.

    What can I do here? If I have to replace this phone after only a week, I might scream and switch to some crappy non-smartphone phone that actually works...
  2.    #2  
    A little help? Or off to the Sprint store am
    I going yet again?
  3. #3  
    Check the USB port on the bottom of the phone. It's possible that it physically broke. I had a TP and the far right prong got broken off (could barely tell) and the TP wouldn't charge or mount to the PC.

Posting Permissions