Results 1 to 11 of 11
  1.    #1  
    Well, main problem is; my Treo Pro for the past few days has been acting weird in regards to battery charging. About two days ago i would connect my phone to my Palm OEM charger (charger that came with the phone) and lets say when i connected it to charge the battery power was at 9%, it would stay charged at 9% and would not go up nor down, but showed the "battery charging icon" but would not charge, in fact it would go down!
    even when left charging for twenty minutes.

    I fixed it by pulling out the battery and letting it sit for a minute two days ago and it worked but now today i tried that and it just gave up. I connected it to the chrger at 4% percent and it would go down even when it said it was charging until it finally died and now it just keeps resetting itself when i connect it to charge.

    What i want to know is do you users think it could be battery problems?
    Or the micro usb cable being damaged or the micro usb port on my Treo Pro?

    Things ive ruled out:
    -Apps: I did a hard reset right before my phone died for the last time my phone died and it continued to have the problem mentioned above.
    -Palm Cylindrical Charger: I connected my phone to my laptop to charge via the same micro usb cable and it displayed the same problem as when i i connected it to my Palm Charger (hence the one that came with the phone) showing no defect in the charger.

    I am almost certain it is my Treo Pros battery that is the cause of all this but i am not completely sure because when i connect my phone to my laptop (which i can see because the phone keeps turning back on an off) it says "USB Device Not Recognized" and says device has malfunctioned and could not be recognized by windows. Which leads me to believe the micro usb port on my treo pro may be damaged and could be the cause of this. But i also have heard the Micro Usb malfunctioning has been common with the Treo Pro.


    Is it the battery or the micro usb port on my Treo Pro?

    Either or i will be taking it to Sprint to get checked upon.
    Treo Pro Owner! 8)
    Modder, hacker, and App creator!
  2. #2  
    It could be a defective micro-USB port. Is the Pro still under warrantee? If so, Perhaps Palm could send you a replacement unit.
  3.    #3  
    Yes, i have it with insurance with Sprint.

    But now i am thinking it is a deffective battery because when i connect my pro to charge without the battery in the phone, it shows the red charging light which would its not deffective.?
    Treo Pro Owner! 8)
    Modder, hacker, and App creator!
  4. #4  
    A battery would be easier to rule out. Bring it to a store and have them swap out the battery. You can test it immediately and see where the problem is.
    Be sure to check out SmartDeviceResource!

    Device Timeline: Palm III → RIM 950 → RIM 957 → Tungsten W → Kyocera 7135 → Treo 600 → Treo 650 → Treo 700p → Treo 755p & 800w → Treo 755p & Pro
  5. #5  
    Man, I'm thinking there may be a problem with the oem charger cause mine has been actin that way also. It only happens when i use the oem charger, my walmart charger never has any problems. Also I noticed that when i charge my phone with the oem charger it gets hot, but with the walmart charger it never gets hot plus it charges faster.
  6. #6  
    i now have the same problem, although the laptop seems to want to charge it but no wall sockets do. has anyone come to a solution with this yet?
  7. #7  
    How about the cable? My old 800w cable....results in device not recognized.
  8. #8  
    Similar problem here. I tried to charge phone using my pc's usb, it would show charging status, but battery was going down. Then I used genereic wall usb charger and same problem there. Lastly I tried Palm's AC USB charger, and it charged fine. This problem was not experienced using my laptop's USB. So could it be defecting devices/bug or voltage issue?
    Cingular Treo 750||ATT WM6 ROM||AT&T Blue SIM||1GB SanDisk Card||
  9. tt531's Avatar
    9 Posts
    Global Posts
    10 Global Posts
    I'm having some charging problems too. I took my phone to Sprint and they replaced the battery. But I'm still having problems charging and connecting to active sync with my pc. And sometimes my phone isn't charging when I use the wall charger. The red light is on but the battery doesn't charge sometimes I think it may be draining.

    I only have the oem cable so I know that's not the problem and I just started having pc connection problems a couple weeks ago. If this is a defect with device I may get a different phone before the warranty ends.

    I'm planning on going to sprint again this week to see if they can solve this problem.
  10. #10  
    i am using all Palm OEM parts. the OEM oval wall charger absolutely is not charging my phone from any outlet. i can only charge my phone using my laptop powered usb slot with the OEM cable. in fact, after seeing the my phone was completely charged by the laptop, i plugged it into the wall outlet charger to see if it would at least maintain full charge and it does not, the batter slowly drains as if it was not plugged in. never had this problem before, even after i received the current device as a replacement device due to cracks in the original device. this is the same battery i have always had. i only noticed the problem after my phone died suddenly one day while i thought it was being charged by my ps3 usb as it previously would in the past. i havent called palm yet. i really dont feel like dealing them treating me like im a treo rookie and going through their on-screen troubleshooting steps...."is the red light on? is there a lightning bolt under the battery?"...geez, seriously?
    by the way, the phone does have all charging indicators so it does pretend to be charging and recognizes being connected.
  11. #11  
    any new developments?

Posting Permissions