Results 1 to 6 of 6
  1.    #1  
    Hi, I’m hoping some on the WM networking gurus here can help me with the following: I’ve been trying on and off for months now to access an unprotected network share available over my local Wifi network from my Treo Pro. Finally today I got serious about it, but every time I would try to enter “\\Sharename\” in the Open Path box in File Explorer, I would receive an error “Cannot connect with current connection settings”. After playing around with the settings for a while, I realized that in the Wifi settings for each available wireless network in the Wi-Fi applet under Settings, you need to define the network as connecting to either “Work” or “The Internet”. Sure enough, changing the setting under my Wifi connection to “Work” made my network share accessible. However, once I made that change, I could no longer access any internet sites over the Wifi connection, the Treo would always try to bring up a cellular data connection when I access the internet.

    So, it seems that I must choose to have my Wifi connection access LAN sites without internet, or internet sites with no LAN share access. Given that 90%+ of LAN connections probably lead to an internet WAN router, this seems pretty stupid.

    Isn’t there some way of telling the Treo that I want all of both LAN and internet traffic to be routed over my Wifi connection whenever Wifi is powered and connected? Is the behavior I’m seeing normal?

    Finally, I see that under the “Network Adapters” tab of the Wi-Fi applet there is a section title “My network card connects to…” which is defaulted to Work. I tried changing this to The Internet, but it doesn’t seem to have any effect.

    Thanks much in advance for all replies!
  2. #2  
    I'm not sure of the direct answer to your question -- I hadn't even thought of using networking directly on Windows file explorer. However, I tought I would mention that I am using the Resco File Explorer app to connect to a shared network path over wifi, and I have the wifi network setup as an "Internet" connection. Not that you really want to buy a $30 app just for this, but if you don't find any better solutions, this may work.
  3. #3  
    Cisco has a program called Network Magic, that you load on your PC. I am sure you could do it with this. I could see my mobile phone on my WiFi with it. You can get a free 30 day trial, so it's worth a shot. It's a pretty amazing program.

    Cisco - Home Networking Software - Set up and Manage Your Network with One Easy Application
    My Phone & My Wife's Phone Two Unlocked GSM Treo Pro's

  4.    #4  
    Thanks for the replies. I'd heard of the Resco software, and I may give it a try, but yes it does seem like overkill for what I'm trying to do. FWIW, I've been annoyed by this Internet/Work dichotomy since at least the early WM5 days. It's a classic case of more being less. Just give me a dumb, unrestricted pipe to the Wifi network, and in 99%+ of cases the network router will do a far better job of figuring out what is local and what should go to the internet than the Treo will.

    Hoping someone pops up with a registry hack or the like to get around this.

    Thanks again.
  5. #5  
    I can connect to XP-hosted fileshares on my local LAN at home using wifi on my Sprint Treo Pro (using "The Internet" setting).

    I don't know, Windows networking is kinda finicky. It can behave differently depending on whether you are using XP or Vista, workgroups or domains, passwords required for accounts, or any of 10 different security settings you can set for network access.

    It could also simply be a problem with Windows-networking name resolution. Have you tried accessing the fileshare using the IP address? i.e. \\
  6.    #6  
    Quote Originally Posted by zbop View Post
    It could also simply be a problem with Windows-networking name resolution. Have you tried accessing the fileshare using the IP address? i.e. \\
    That was the first thing I tried. From other web searches, I learned that the WM File Explorer doesn't support accessing shares by IP address, only by computer name. Really stupid. I've got the computer name right, and it's on the local subnet, I don't see any way to set a workgroup name in WM.

    If you would be willing to post any more details of your various network settings, I would appreciate it. There must be some distinction between the configuration on your Treo and mine.

    Thanks again.

Posting Permissions