Results 1 to 12 of 12
  1.    #1  
    I am relatively new to this board as I just signed up today. I came across a post that might help me out. Does anyone have Treo 750 software version TREO750-2.27-RWE? I ask because my unlocked/unbranded phone crashed after loading WM6.1! I need to revert back to the old ROM detailed above and I can't find the software anywhere online.

    I hate to have to buy a new phone
    Any help is GREATLY appreciated! Thanks
  2. #2  

    I've searched my heart out and can't find it anywhere.
    It seems all the links, including xda-developers don't have it, or are expired.

    I think I have it somewhere on one of my ext-drives.
    If I find it, I will upload to 4Shared and post you a link.
    Just call me Berd.
  3.    #3  
    Thanks Berd! I really do appreciate it. Apparently the free upgrade expired last month - talk about bad timing.

    Has anyone tried upgrading from 2.25-ATT to 2.27-(Unbranded)? Will it work successfully?
  4. #4  
    I found it.
    I will upload with in the hr.
    If you're trying to flash over Att 2.25 it may require editing the payloads.xml
  5. #5  
    Here you go:

    If the installer won't let you update to 2.27 RWE.
    Try following these instructions:
    Just call me Berd.
  6.    #6  
    Thanks Berd. I'll give it a shot first thing in the morning and let you know the outcome.
  7. #7  
    Berd, will this work on a Rogers Treo 750? I tried to upgrade also to 6.1 and now I need to revert back as it did not work and I need to load from SD.

    What files to I transfer to SD to make the load work?

    Thanks in advance
  8. #8  
    Just call me Berd.
  9. #9  
    Thanks berd... I have been actually on the computer 10 hours straight trying to figure this out and did. I have upgraded successfully but have not been able to unlock my Rogers Unit.

    Any idea on what steps/methods I should use to do this? Again, I am already on wM6.1 but have not been able to successfully unlock.

    Thanks in advance
  10. #10  
    I get a message when I use the Cheetah method, steps 1 and 2 and then Magic Unlocker of 'SIM Lock- You have tried 30 times and has timed out' What does that mean? I know it still isnt unlocked....

    Your recommendations?
  11. #11  
    So you got the rom on ok, and now you're trying to sim unlock the device?

    I never unlocked my 750 so I'm not sure.
    Usually, when a device is locked to a carrier, you have to use a unlock code. And if you put the code in wrong more than 2 or 3 times, it locks down to where you would need a puk code.
  12. #12  
    Some carriers will give you the code if you've been with them awhile.

Posting Permissions