Results 1 to 5 of 5
  1.    #1  
    Alrighty. So I decided to try and upgrade my telus 700wx to WM6. First using Ebag's WM6 Full Rom final, then to nightshade's WM6.1 Rom over at

    Everything went fine, except that first off my data connection name turned into a hex code, and then refused to connect. I went through everything, including OTA re-provisioning, as well as re-provisioning with a support tech. All of the settings were fine.

    In fact, both the tech and the rep at telus informed me that upgrading your ROM will NOT void your warranty! However, my phone is out of warranty anyway.

    At first, I could only connect to my data connection after a soft reset. I tried flashing to the sprint firmware, to no avail. Now I can't connect to data at all. Research has lead me to believe that most likely somewhere along the line I had a bad NV backup and restore, compounded with the Sprint Data settings being coded into the phone.

    Is there anything I can do? From what Telus has told me there is no user-available firmware/ROM restore from them other than sending in for depot repair.

    Can anyone help? I'm able to do OTA PRL and MSL reprovisioning, and have all of the settings for ##DATA, but still nothing!

    **EDIT** Since doing a hard reset I can't update the PRL, so I'm suck "roaming".

    Last edited by nathor7791; 10/04/2008 at 02:45 AM.
  2. #2  
    Just create a new connection, then enter login:, password: esn in 11 digit decimal number.

    then disable the auto pick, and use your new "Connection 1" instead.
    6b 6f 63 6f 6d 61 6e 20 6f 66 20 63 64 6d 61 2d 64 65 76 2d 74 65 61 6d
  3.    #3  
    I tried the new connection (it was the first thing I tried!) and it didn't work. I suspect that my NVbackup is corrupt. I read the log for the firmware update, and in a number of places it states that it couldn't read the current nv.

    Also, I've noticed that there are quite a few references in the nvbackup to sprint servers. I'm wondering if perhaps after dialing into the telus #777, I'm being redirected to sprint for authentication (and therefore failing). Another thing that leaves me to believe this: the phone used to say "Telus" on the top. It now says "Sprint" (I believe this is due to the failed NV backup as well).

    ##Debug AN/AAA states Auth State authenticated, but if the phone tries to dial the "Wireless connection", it tries 3 times and then gives me the "Cannot connect for an unknown reason. To check your connection settings and change them if needed, tap settings. If the problem continues, reset your mobile device according to your manufacturer's documentation and try again."

    Message. Connecting in WM5 simply states there is no answering modem on the other side, to check my settings and try again.

    Last edited by nathor7791; 10/05/2008 at 05:13 PM. Reason: New information
  4.    #4  

    Anybody?... I fixed the roaming issue, but still cannot connect to data.
  5.    #5  
    Just as an update:

    I managed to get ahold of a friends Bell nvbackup.dat. Which is interesting, as it was only a 72kb file versus the 92kb file that I had grabbed off my phone once it became pooched.

    I edited the file (which also contained some sprint entries... which I found interesting) with some of my entries such as my ESN, data provisioning etc.

    It 'kinda' worked. But I was no longer calling on Telus's network (dial 411, it will say "welcome to telus" or "welcome to bell"). I don't think I want to experiment as to how my billing would look if I ended up with that.

    The good news: when connecting to data, it told me to check my username and password settings, instead of the "cannot connect for unknown reason" error.

    So, I'm back to square 1. I now KNOW that its the NVram. A word to the wise about using custom roms with telus and bell would be BACKUP YOUR NVRAM.

    In order to get my data back though, I'm going to need an nvram backup from a telus handset. Any takers?

Posting Permissions