Results 1 to 10 of 10
  1.    #1  
    During a phone call, my treo just turned off. I assumed low battery. I plug it in to charge and the red light at the top left blinks every 5 seconds or so...

    It won't turn on. I tried removing the battery and putting it back in... but nothing

    Anyone know what's up?
  2. #2  
    go to battery plus get a new battery and try.... happened to me once,,,,
    the new battery worked....
  3. sfox's Avatar
    20 Posts
    Global Posts
    39 Global Posts
    same response when I competely drained my battery once. I let it charge for a couple of hours and I was back in business...if that doesn't work.....go to Sprint and tell them to give you a new battery

  4. #4  
    Palm has issued a fix for this issue. I believe what they recommend is for you to do is charge your phone via the computer usb charger (trickle). That's what I did when my battery died. After about 10 minutes on that charger, I was able to get the phone to boot and then moved it to the standard wall charger. Here's a link to the fix if you want to prevent this from happening in the future (I have not installed it so I can't vouch for it):
  5. #5  
    I have the same thing, the posts say to plug it in but the light blinks every so often, i think it is trying to turn on which just kills the battery and starts all over again. I WANT A REAL POWER BUTTON! And so now I have a dead $600 cell phone and no home phone to call tech support. Great. Ask me again tomorrow, I'll say, "Palm who?" Never heard of 'em. (I haven't waited 15 minutes yet though...)
    Last edited by macsrule1; 10/03/2008 at 10:59 PM. Reason: Realized how impatient I am
  6. #6  
    I had quite a scare earlier today. I only had my Treo 800w unplugged from the charger for about 3 or so hours, and at lunch I looked at it and the battery was down to about 28%. I just figured I wouldn't use it until I got back to my car to plug it in, but by the time I got back to my car the unit was completely dead.

    I could not get it to come back up - I tried the car charger, the regular home charger, and even plugging it into a computer via the USB charger. Occasionally the red light would very dimly blink, or when I plugged it into the computer via USB charger the red light would stay solid and occasionally blink quickly and then stay solid again. But the unit would not boot up.

    I took it to a Sprint store, and they used a machine to give the battery some charge, and this finally allowed the Treo to start up again (I thought it had died completely and my data on there would be lost). However, after leaving it plugged into an outlet at the store for about 15 - 20 mins, it still shows 0% charge and when I unplugged it and walked to my car, it was dead again.

    I went to a battery store and actually bought a replacement Rayovac battery, and thankfully this battery had some charge to it and when I got to my car and plugged it in, it started charging (its up to about 30% now). Hopefully it was a battery issue - I guess I'll see over the next few days!

    And the worst is I thought I had the patch installed that prevented this...

    Sooo very annoying and frustrating!
  7. pwabbit's Avatar
    13 Posts
    Global Posts
    19 Global Posts
    I am doing battle with my daughter's phone too. She uses it for a day of so and the battery goes dead. It sits being charged for a couple hours and then it finally comes on. The whole time it is on the charger, the LED is solid red with an occasional blink. at 87%, she decided to use the phone. Later she plugged it back into the charger to finish the full charge. At that point the charger drained the battery down to 0% again. Bizarre, the phone should charge on the charger, not drain. This is the craziest phone. I have ordered a couple extra batteries and an external battery charger. That doesn't fix the phone but it does make it useable.
  8. 120inna55's Avatar
    1 Posts
    Global Posts
    4 Global Posts
    Quote Originally Posted by Dyno View Post
    ...I believe what they recommend is for you to do is charge your phone via the computer usb charger (trickle). That's what I did when my battery died. After about 10 minutes on that charger, I was able to get the phone to boot and then moved it to the standard wall charger...
    I just registered to thank you for this post. 3 years after you posted it, it's still helping folks. I just put a new (depleted) battery in my Treo Pro and was unable to get it to boot while plugged in to a wall charger after 10 min. Fearful I would lose my data, I did a quick google search and found this thread. I then connected the non-responding Treo Pro into my trickle car charger. After 10 min, it booted up with data retained. Now, it's charging normally via my standard wall outlet. Thanks a lot for this post.

    I am curious, though, as to how long will the Treo Pro retain data with a completely depleted battery.
  9. #9  
    Just got a new Treo Pro battery from e-bay, and right now getting the blink of death. Just trying to make it until Samsung Galaxy S3 is released on Sprint...
  10. #10  
    On the Treo Pro, using a small piece of paper to prevent the two middle pins from connecting allows you to charge without turning on the phone. After 30 minutes of charging that way, I can now boot up with the new batter...

Posting Permissions