Results 1 to 5 of 5
  1.    #1  
    It worked at one time, but when I tried to turn on the device today, it has been totally non-responsive. I've charged it for at least an hour and the red light is on at the top but nothing is coming up on the screen. I've tried a soft reset and a hard reset. Still nothing (other that the bright red light goes to a dim, pulsating light).

    Any suggestions?
  2. NRG
    NRG is offline
    NRG's Avatar
    3,657 Posts
    Global Posts
    3,665 Global Posts
    Exchange it.
  3. okashira's Avatar
    36 Posts
    Global Posts
    37 Global Posts
    ik had the dim flashing red light once.

    happened when I killed my battery while on the phone, plugged it in the charge, unplugged it and tried to turn it on too soon. got the flashing light as mentioned, and the phone was unresponsive, had to charge for 10 min or so and try again. worked since.
  4. #4  
    Mine went completely dead. I could not get it to respond with the wall charger plugged. Carried it to a Sprint Store, they exchanged my battery, and the phone has worked well since. I tried to charge with the usb connection overnight unsuccessfully. I had a charged Centro battery that has worked well all day. I will do a hard reset tonight and see if it will charge the battery afterwards.
    Update: Battery charged following hard reset.
    Last edited by rwhillyer; 07/17/2008 at 07:06 AM. Reason: Update
  5. #5  
    same thing happened to me, had to do a hard reset.

Posting Permissions