Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 75
  1. #21  
    In the past I've just used the grab_it tool to dump the rom to the sd card. Not sure if it will work with the microSD card. Guess we'll see.
  2. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    I found the grab-it tool too and have read that it works with micro sd (didn't try it yet). However I played around some more and did some reading about the diallookup dll (which is the one that I am most interested in as it give quick lookup AND dial from the today screen). Couple of things of interest -- it does alot more than that. It changes the soft buttons on the today screen and also handles the the carrier logo and communication icons in that line on the today screen too. I suspect this is why the old (it hid the carrier line on the today screen for the 7XX series) no longer works on the 800.

    Secondly and most interestingly it seems that the diallookup dll IS loading. Although I cannot see it, I can type stuff, press the green button and it dials what I had typed. So this leads me to believe finding the dll with the resources in it or some resource editing may be necessary at a minimum and perhaps some hacking in the worse case.

    This concerns me because Palm was very efficient in eliminating the extracted versions of this dll (you almost cannot get it now). If I can get get this fixed up, the distribution of the solution may find equal amounts of trouble.

    I am thinking I may be able to write my own lookup today plug and perhaps somehow disable Palms...

    Man all this really sux because the real 320x320 is sweetness -- applications images and everything just look so crisp. Plus all the scaling issues with apps (at least the ones I am using) have gone away -- not to mention the extra screen area....
    Last edited by insol; 07/13/2008 at 12:20 PM.
  3. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    I should also mention -- the 96 DPI dlls from realVGA (these I assume are the native MS WM6.1 dlls) make the 800w really sluggish. The Palm DLLs are definitely the way to go. For example loading messaging in 96 DPI takes about 4 seconds and then it still is somewhat sluggish to do anything. At 128 DPI (natively using the Palm dlls) it takes less than a second to load and things are snappy.

    I love the 96 DPI resolution and the application compatibility issues go away... It is such a beautiful device at that resolution. So close yet so far...

    *sigh* why Palm!!?? Why!!??
  4. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    Man... the grab-it tool did not work. However I was able to get everything extracted. See my next post for the notes on this. Sad thing is that renaming stuff to xxx.96.dll did not help at all.

    Even worse things were missing like the windows icon on the start menu the ok text in that button etc. So what I did was copy over all my 128 --> 96 files, then put the realVGA 96DPI stuff on top of that (most of the dlls were resource dlls) and now it seems to be faster.

    There were a few 128 DLLs that were not part of the RealVGA pack as 96. My next step is to take a look into these files and see whats there... The files all start with WLM and one of them is a contacts resource file... so we will see. In my next post I will give what I did to get things extracted -- hopefully saving someone some time.
  5. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    Thanks to XDA-developers and all the great Wiki info over there. Much of this is thier work,
    not mine. So credit goes to them. One other item, I did this using Windows XP and activesync 4.5

    * isutils -- which can be gotten from
    * imgfs tools -- which can be gotten from
    * A registry editor -- a free one is available here:

    1. Unzip the contents of on c:\itsutils and unzip the contents of to c:\imgfs_tools
    2. Connect your PDA to PC using USB cable, and make sure ActiveSync is running
    3. Start -> run -> cmd.exe
    4. cd c:\itsutils
    5. unless you already have a registry editor on your PDA, copy over regeditSTG.exe to my documents on your PDA
    6. Using the registry editor, navigate to registry key 'HKLM\Security\Policies\Policies' and set key/valuename '0000101a' to dword:1 and set key/valuename '00001001' to dword:1 (default is 2)
    7. Copy over isutils.dll from c:\itsutils to your device's windows directory (overwrite the
    one thats there). When you first run pdocread below it will prompt you on the PDA screen to run. Make sure to click yes on your PDA.

    8. First we are going to find the device handles for all the flash partitions, using:
    pdocread -l

    this will give output like this:
    251.75M (0xfbc0000) MSFlash
    | 2.12M (0x21f000) Part00
    | 2.13M (0x220000) Part01
    | 77.75M (0x4dc0000) Part02
    | 169.75M (0xa9c0000) Part03
    STRG handles:
    handle 86f364ca169.75M (0xa9c0000)
    ... some more handles and partition output

    Pay attention to MSFlash (this may be different for your device) and we will need it below. Also notice what Part02 is called on your machine it too might be different, and notice the hex code (0x####) for Part02. You will need all three of these things below to dump.

    If you get the following error, your device is probably application locked:

    C:\itsutils>pdocread.exe -l
    Copying C:\itsutils\itsutils.dll to WCE:\windows\itsutils.dll
    Could not update itsutils.dll to the current version, maybe it is in use?
    try restarting your device, or restart ActiveSync

    You wil need to make sure that step 6 is done and done properly.

    9. Dump the imgfs part of the ROM (note MSFlash should be the same as above, if yours is different use that name here). Also note the part02 and 0x4dc0000 (use what you have). This will create the file part02.raw which is a raw dump of the imgfs.

    pdocread -w -d MSFlash -b 0x800 -p Part02 0 0x4dc0000 part02.raw

    10. copy part02.raw over to c:\imgfs_tools, then change directory to that directory too (cd c:\imgfs_tools)

    11. run viewimgfs. This will put everything in a dump directory both the module and the reconstructed version of the ROM files

    viewimgfs.exe part02.raw

    12. All of the files will be in a dump directory there.
    Last edited by insol; 07/16/2008 at 03:40 PM.
  6. #26  
    pdocread doesn't work for me. I get:

    ERROR: ITGetStoreMgrList - Access is denied.
    ERROR: ITGetStoreMgrList - The system cannot find the file specified.
    ERROR: ITGetSTRGHandleList - Access is denied.
    ERROR: ITGetSTRGHandleList - The system cannot find the file specified.
  7. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    I followed those instructions above and it worked pretty flawlessly... Any more details on what you may have done differently? The signed app yes/no message gave me a bit of trouble... as I was not watching my treo screen. I am also using XP and activesync 4.5
  8. #28  
    I didn't get the signed yes/no message.

    Other apps seem to work as I can use them and get expected information.

    I'm using XP and AS 4.5

    I followed the directions exactly.

    I suspect my 800w may have issues. I have weird behaviour.
  9. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    You know, I have gotten some weird behavior too. For example last night I tried to back up with Sprite.... it wrote 512K then failed saying it could not read the filesystem. I eventually got used Resco backup and got a backup which I tried to restore today. That hung on restore... Interestingly enough, grab_it 9rom dump) failed at 512K too. I have been slowly re-installing all my applications again today.

    Anyway, back on topic. I got a good ROM dump. Played around with renaming files (but the resources are not sized correctly in the dumped dlls to be 96 DPI. Things weremissing like the ok button and the windows icon for the start menu. So I ended up using the realVGA dlls on top of the renamed dumped DLLs (as mentioned above). Then the in-call phone screen (the white one with the mute and speaker phone buttons) would not show up after getting that far.

    It does seem that the dialLookupPlugin.dll has the resources for the application but something in the code is setting things to a funky zero. For example I set the GPE registry setting to 120 DPI and that plugin was about 1/3rd its original size. The plugin has both, the carrier name/bluetooth/location icon line and the dial lookup line all in the one dll. This is why the hidelogocab doesn't work anymore. Well when I switched the DPI to 120 all of the icons normally at the right side were smashed over on the left and the plugin only took up about 1/5 of 1 line (it was about 1/3rd its normal size). So I can imagine that 96 DPI completely moves things out of sight. From what I can see the positioning is in the DLL code not in the resources.

    I am resigning to using the device at the crappy resolution. *sigh* at least I have GPS... If anyone want to try something I am willing.... but short of remaking all the resource images, I am out of ideas at this point.
  10. #30  
    Search for Samsung i780. You probably will get a lot of discussions going on with this fellow which has a 320x320 screen. Here is one talking about compatible softwares in ppcsg. xda forums also have lotsa discussions going on with this phone.
  11. #31  
    Thanks for your efforts insol. Yeah pdocread is what we used to extract the 750's palm messaging back in the day. Good to know it works with the 800w too.

    I was thinking there would be more work with the resource files then just renaming them. Maybe the RealVga developer might have some advice on what needs to be changed. It's amazing what you can do with a good resource editor, but it's time consuming.
  12. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    Yah... even if all that gets solved the stupid dial look up is still screwed. For me it is one of the features I like most and really need. BTW if you want to see what I am talking about (without harming your device), edit the two DPI-related registry DWORDs


    The default is 128 set them to 121. Both entries need to be the same. Once you make this change, soft-reboot and you will see exactly what I am talking about with the diallookup.DLL code doing funky things on the today screen.

    Shame, because 96 DPI solves most (if not all) application compatibility issues and the screen is beautiful. I really wonder why Palm did not just do this right, given how long the device was delayed and increasing font size is trivial.
  13. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    Think I have it figured out and it is working! In short I used the old WM5 diallookup plugin (which BTW may mean I can use hidelogo -- haven't tested that yet) But things are working. My only problem right now is that the call progress screen seems to be missing (the big white one with the I don't get it anymore.. instead i get status in the carrier logo line (I know -- odd).

    Without the call progress screen it seem conference calls may be difficult to make, but I may be able to get that back with the original dlls as I can vaguely recall seeing that at 96DPI (just need to find which one has it and replace) . Additionally the new diallookup plugin is much nicer

    Anyway 320x320 with RealVGA and diallookup is working now! I will post what I did in my next post, shortly. I have to do some other things right now... but I will post the method here soon.
  14. #34  
    Quote Originally Posted by insol View Post
    but I will post the method here soon.
    I'll be curious to see what you did. Post screenshots if you can too.
  15. wsu
    wsu is offline
    wsu's Avatar
    9 Posts
    Any progress on this? It looks amazing with Real Vga and the it!
  16. #36  
    Quote Originally Posted by insol View Post
    My only problem right now is that the call progress screen seems to be missing (the big white one with the I don't get it anymore.. instead i get status in the carrier logo line (I know -- odd).
    Make sure that these plugins are "Pinned" (via MemMaid or SKTools --> Maintenance --> Today Plugins)
    • Dial Lookup (Order: #2)
    • Active Call (Order: #4)

    Not having that order or having one or both unpinned will result in "odd" behavior like you are describing...

    WMExperts: News, Reviews & Podcasts + Twitter
  17. wsu
    wsu is offline
    wsu's Avatar
    9 Posts
    Yea that still doesn't work with the 96dpi. Hopefully someone can figure this out so we can run in true VGA!
  18. insol's Avatar
    268 Posts
    Global Posts
    269 Global Posts
    I will be posting instructions shortly... and some screen shots of it working. Sorry, I know what its like to wait on this kinda stuff, but I have a big deadline next week -- once I am done with that (and perhaps before - -just need to finish the PowerPoint presentation; 4 years of work into a 1hr talk [smh]).

    There are some bugs particularly with the speed dial editing screen and I have screen shots. The 96 DPI resolution is definitely working with the old WM5 diallookup.dll (BIG HINT here) you just need that dll and the palmutils.dll. I changed the type of today plugin from 6 to 4 in the registry so I could disable the wm6 diallookup.dll (using the today preference screen) and added registry entries for the wm5 dll (renamed diallookup_wm5.dll) to be the same as the current dll's registry items.

    In short, without a lot of explanation this is basically what I did with a couple of replaces on the RealVGA 96DPI resources to use 2 96 DPI dlls provided by Palm that already exist in the windows directory. I will provide a full explanation later in a day or two after I finish the work stuff I mentioned, but this oughta be enough to get the eager folks going...

    Malatesta can you give me more info on what you mean by "pinned?" The call progress thing remains an issue but is definitely "usable" even broken (it shows up half way on the today screen and if you know what button to push, you can even make it work). However it would be nice to get that bit of it right for call conferencing etc.

    EDIT:: NM -- I get it. Pinned is essentially type=5 in the registry. Funny thing tho the original wm6 diallookup plugin had a type of 6 and I have not changed the active call plug. Also the order I have messed around with some. Anyway I will try it tomorrow (3:00am here) and see if it works.
    Last edited by insol; 07/18/2008 at 09:16 PM. Reason: hehehe.... thought Malatesta was someone else -- I got used to your old avvy
  19. wsu
    wsu is offline
    wsu's Avatar
    9 Posts
    Wow...appreciate the effort. Hope your presentation goes good and I look forward to your instructions. I know what you are talking about I just don't know where to get the dll's from. Anyway thank you!
  20. #40  
    Good work insol! I have the same work issues. Must wait till weekend to have any fun. lol
Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions