Results 1 to 4 of 4
  1.    #1  
    Upgraded my unlocked 750 to WM6 using official updater. Now when I put my O2 sim card in it searches endlessly. it is not finding the network. I was using an Orange sim card previously and that was fine. I have tried unlocking again and that also ran OK and said it was unlocked.
    When I was about 120 miles from home yesterday the O2 card worked but now it is just searching
    When I put the O2 card in my 650 it works perfectly.
    When I put my partners O2 card in the 750 it works...
    what do you think is wrong?
    Tried running the Treo restore utility but it wont run, keeps disconnecting the WMDC.
    Stuck and hating it!
  2. #2  
    If another person's O2 card is working and your's isn't, then try contacting your service provider. Something may not be provisioned properly on your SIM's programming.
    Treo 750 | AT&T | WM6| TREO750-2.27-RWE | FW

    My Treo freeware apps -
    My favorite software picks -
  3.    #3  
    My bad, other O2 sim cards are not working. I have done another unlock (from Ebay)which was successful, but the network search goes on and on. Now gone as far as re-applying the ROW upgrade ROM and starting from an empty Treo to avoid conflicts. still no carrier signal, beginning to thing the aerial/signal part is fecked... or the radio is corrupt. Any tips on where to get a new radio programme to download?
  4. 47619's Avatar
    118 Posts
    Global Posts
    119 Global Posts
    ROW is already unlocked I think you are trying to unlock an unlocked phone.

Posting Permissions