The area that i live is just outside of the Verizon network. Its in an "Extended Digital" network.. Probably roaming off of Carolina West or Alltel.

Here's my question: Up until today, my phone has simply stuck with the Extended Network which usually gives me 2-3 bars. Today it is trying to stay on the Verizon network, which is 0-1 bar. Its so weak, i can barely make a phone call. Not to mention, it drains my battery VERY quickly.

How can i make the phone continue to use the extended network? How do i make it NOT try to connect to Verizon's?

I found the network settings: Home & Automatic A or B.. They don't seem to do anything when changed?!?