After a little over two months my Treo (unbranded, UK purchased) suddenly seems to have been struck down with a number of issues that others have reported. I've obviously been lucky until now!

Unresponsive Touchscreen
Firstly, I've become affected by the "unresponsive screen" problem. It seemed intermittent at first, and I thought it was just slow performace, but now it seems much the same as has been reported by others.

After a soft reset the screen seems to repond to the first touch, but then after that it fails to repond correctly. I say that it doesn't repond correctly because it does actually seem to repond to touch, but it just doesn;t register the selection. So a touch on the screen will cause the keyboard to light up, but the input doesn't seem to be passed to whatever application is open.

I've tried the "Remove the battery and put it in the fridge" trick, and this does seem to work, but only momentarily (as reported by many others). What I can't figure out is whether there has ever been any resolution to this. The thread on the Palm suport forum has posts from a few people who have had replacement models shipped, but since this goes back to April I was kind of hoping that it might have been fixed by now!

Intermittent Sync/Sync Failure
The other problem I've now got is a problem syncing. I have two different sync cables and two different laptops, and the problem occurs with any combination of laptop and cable. Basically, it's very difficult to get the Treo to be recognised correctly and then sync consistently.

When I plug the Treo into the laptop it makes some sort of connection because it vibrates (when on silent) and the LED lights. One of two things will then happen. Either ActiveSync will recognise the connection and show "Connecting", or I will get some kind of USB connection error from XP.

When I do manage to get AS to start "Connecting" then it sill often fails, as it doesn't appear to startup AS on the Treo itself. Sometimes the sync will start correctly, but then at some point during the 'Synchronising' process it will just fail and AS on the laptop will show 'Device Not Connected'

I suspect this is very much down to the extremely flaky looking connections on the sync cable (why, oh why could you not just use Mini USB Palm?? ). I have seen a number of suggestions about cleaning the connections with alcohol, or with a toothpick. I have tried this,and it seemed to work initially but after a single sync I'm still hacing problems. Has anyone found and 3rd party sync cables to be any better at making a consistently robust connection?