Page 1 of 2 12 LastLast
Results 1 to 20 of 27
  1.    #1  
    Hi everyone, i'm having some real problems with my phone. i'm using a treo 700wx from Telus. I have this weird issue.....everything works on the phone except when i make calls. I cannot hear through the phone's ear piece. As well i can connect with teh speaker phone once and then when i try and do it again it won't work. I've come to the point where is is 100% an software issue. The phones ear piece has been changed and it's not the problem. I've also done a SOFT, HARD and DEVICE RESET to the phone and am still having the same issue.

    I was wondering if anyone else experienced this problem. Does anyone know if there is a firmware upgrade for the phone yet or maybe a rom reset?

    The phone did work once again with the ear piece, but for a short time.
    This problem occured when i think i put a software on it. But doing a hard reset shoul dhave fixed it right? Anuhow my only option is to do a Rom reinstall or even a firmware upgrade, but palms website doesnot have a update on the phone!

    Can someone please help me with this issue? Thanks in advance!!!!!
  2.    #2  
    i really need some help here....thanks
  3. airibis's Avatar
    212 Posts
    Global Posts
    213 Global Posts

    if it was software like you said, a hard reset should have fixed it (unless you some how ended up with corrupted firmware, which i doubt)

    maybe it is hardware, and not the speaker. I wouldn't want you to go out and buy even more parts for your phone... See if there is anything palm can do for you
  4. #4  
    this happened with me once when I unplugged my headset, it got stuck in this weird mode as you describe. Plugging and replugging it got it working again for me.
  5. jas o's Avatar
    226 Posts
    Global Posts
    747 Global Posts
    This happened to me too. I lost all sound from the speakers. It would only work with my bluetooth head set. I tried everything and nothing worked. I finally called Verizon customer service and they had me try everything again. Finally he said that my phone was less than a year old and still under warranty and sent me a new one. Did you buy your phone from Telus?? Not sure what what their warranty is but worth a try to check with customer service. Worst they will say is no. Best case you get a "new" phone probably refurb no charge.
  6.    #6  
    Hey guys thanks or the replies.
    G-Funkster....are you sure that that fixed the problem? I will give it a try. I do remember that around the time it started doing this i was using the headphones from the jack.
    Just to confirm with you guys...your problem was when ONLY the speaker from the earpiece wasn't working....everything else was right. Like the speaker from the back of the phone had sound right?
    ANyhow i don't want to call telus....i have this really good deal with my plan. i might have to call palm and see what they can do.
    Guess no one knows if there is a firmware upgrade yet with telus huh, or a ROM reboot!
  7. #7  
    yep, it's exactly as you describe. the earpiece didn't work, but speakerphone mode worked fine. And yes, plugging in my headphones and unplugging them did fix it when I tried it later.

    edit: similar thread
  8.    #8  
    has your issue come back at all.....i did do the earpiece plug in and out and it worked....but the problem came agian. I'm not sure if its the plug port of the phone. Do you know if that part can be replaced? Please let me know if your issue came back or not thanks....I think i got too excited when it was working again!!!
  9. #9  
    It happened for a second time the very same day, lol! However, it has not happened since or before that day so I don't know. Your hardware may be a bit funky.. I just unplug my headphones a bit less forcefully and cross my fingers.
  10. #10  
    You should be able to get a replacement if it is the headphone jack issue (which I also think it is), many people here definitely have.
  11.    #11  
    does anyone know if there is any parts to replace the faulty earphone jack? Do you know if this part can be changed?
  12.    #12  
    hey this issue started acting up again. do i have to do a soft reset to fix it? I can't seem to get the earpice working again. I tried pluging the jack in and out a couple of ties.
    Is there any other solutions i can do?
  13.    #13  
    does anyone know if i change the earphone plug will resolve the issue? or do you think that it a problem on the mother board?
  14. #14  
    I have the same problem tool. Out of nowhere, the ear piece just stop working. I didn't drop it anything. I will try the earphone jack tricks to see if it works.
  15. #15  
    I too had this problem. It seemed to go away but I was able to work around it by activating the speakerphone and then deactivating it while on the call. That seemed to turn on the mic again.
  16.    #16  
    is there a fix for this...does anyone know? this is getting so fustrating....i had to now buy a plantronics 665 bluetooth to talk...and now i just read about the BT issues that this phone has.
    So does anyone know if the phone jack plug can be replaced or an alternate way to fix it?
  17. #17  
    Phone replacement notoriously bad earphone jack on Treos
  18.    #18  
    what if you can't go to telus and do a replacement? are there any other options that i can do? Is the ear phone jack the main source or the motherboard?
  19.    #19  
    does anyone know? Of all the people that have had this problem.....has your issue been fixed? How did you fix it?
  20. #20  
    I'm assuming it's broken, so you'll likely need to get it replaced. TC member 'nonobeez' used to do mods/fixing of treo audio jacks for a fee. I'd contact him, here's his profile:

    If you don't want Telus looking at your plan, what I do (because I don't want VZW to look at mine either) is I go to an official store, show them the very clear problem and they'll usually replace it without needing to go into the details of my plan. I call ahead of time also to make sure they have them in stock.
Page 1 of 2 12 LastLast

Posting Permissions