Results 1 to 3 of 3
  1. rfdillon's Avatar
    92 Posts
    Global Posts
    97 Global Posts
    Folks, I have had the 700W for ~ 9 months now. Just this past weekend, I realized that the when I had the phone docked, the battery wouldn't charge. I tried plugging the phone directly into the wall wart, and still wouldn't charge. I can take the battery out of the phone and charge it in the Palm dock, but whenever I have the phone plugged into a usb dock, the car charger, or any other charger, the battery is discharging, and not charging.
    I guess this means that I need a new phone, but I am not looking forward to reinstalling all my apps.
    I have tried swapping batteries, but with the same results
    Has this happened to anyone else? Any ideas on how I can get the phone to charge the battery?

    Does someone have a good process documented for taking a current phone, backing it up, and transferring all of your data/apps to a new phone?
    Thanks so much in advance for your advice!
  2. #2  
    My treo 700w is doing the exact same thing. I plug it in to various chargers and no light comes on. Phone will start up and then immediately give low battery warning and shut back down. I don't have the dock that charges the spare battery, so I can't charge it that way.

    Does anyone have any idea what is broken and can it be fixed? I really like this phone, and paid a bit for it, and don't want to lose it. Palm wants $169 to fix it, which is pretty high too.
  3. #3  
    check the pins on the unit first obviously to be sure u have not just bent and mangled them so they are un able to make contact and complete the charging circuit.

Posting Permissions