Results 1 to 9 of 9
  1.    #1  
    I'm so tired of this issue and can't believe nobody has found an answer for why it happens or has a solution for how to fix it. In hopes that someone has a solution I wanted to reach out again. Here's a screen shot of the issue I as well as hundreds of other people are running into:

    In summary, I am able to sync with my exchange server without any problems...then for no apparent reason and at no explainable interval, all the sudden my device (Treo 700WX) goes into "Waiting for Network" and will not come out of it. I don't know what causes this to happen and cannot link any activity I'm doing on my handheld to make it do this. I have tried doing soft resets, turning off the radio, taking out the battery for a period of time, re-installing Activesync, deleting the association with exchange and redoing it. None of this works for me. When I go back to the Activesync screen it is still stuck on "Waiting for Network" like the device is frozen there or something.

    The only way I can fix it so that this stupid message goes away and my device starts sync with exchange again is to actually sync it once with the USB cable on my computer...then mysteriously it will come out of "Waiting for Network" and start working again...for about 20 hours or so, then it will go right back to "Waiting for Network". What make me even more frustrated is that I can do everything else with my phone, including surfing the internet and reaching my OWA that way. So I know this is not a certificate issue or a server issue but am thinking it has to be a software issue, either with the treo or activesync. Could it be that those of us having this issue need to update their firmware or something? Could it just be that a bunch of us got a bad batch of phones??

    ANYONE HAVE ANY ANSWERS AS TO WHY OR HOW TO FIX IT??? I can't believe this issue is still a mystery. Having to sync my device on a daily basis with USB has become a PITA! Everything else about this phone rocks but this one issue has me about to throw this phone in the trash. Thanks in advance for any input.
  2. #2  
    I personally do not have this issue, but I setup my own Exchange server, SSL Cert and firewall so I have more control over the settings.

    I ran across the thread below where they have similar issues when SSL is enabled. I wonder if it has something to do with the cert or the timeout value on your firewall?

    I don't have time to look in more detail, but I found tons of hits for the google search: activesync "waiting on network"
    Treo 600 > Treo 650 > Treo 700p > Treo 700wx -> Mogul -> Touch Pro
    You may like to flash, but your phone shouldn't. LED Killer
  3.    #3  
    Thanks for the ideas however I don't know how this could be related to the server because I can sync just fine until my phone goes into the "waiting for network" freeze. Sometimes it works fine for over a day, then it freezes for no reason... I feel this is obviously an issue with the phone software as it freezes and won't ever come out of the "waiting for network" status until I reset it by doing a sync with my USB cable.

    I have checked out just about every other forum, post, article, etc. including the one you posted and they are all looking for solutions not giving solutions. Anyone know when they are planning to come out with a new release of Activesync? Maybe that will fix the problem...
  4. #4  
    Yah! Me too. I'm on Sprint. 700wx. Everything was fine and then Activesync stopped working and I can't access email. It is my own Exchange Server.

    On my 650 I noticed that Versamail would not work if there was a pending download of OS updates from Microsoft on the server. Install the updates, reboot, and all is well. I hope when i return home that this works.
  5. #5  
    Just an update here. We rebooted the server and the 'waiting for network' problem disappeared.
  6.    #6  
    Don't ask me why this has seemed to fix my problem but here goes...Until I discovered this wierd find, I was having the "waiting for network" issue daily. Now I haven't had the issue since as long as I do the below:

    I cable syncronize my Treo 700WX with my work laptop for Files (wirelessly for email, calendar, etc.). This is the primary computer that I get my exchange mail on also. As long as I leave my laptop at work on and outlook open on my desktop, my Treo does not get the 'waiting for network' error message. If I do anything at all with the work computer (close outlook, undock and go wireless, shut the computer down, etc) I eventually get the waiting for network error and exchange sync stops working. The only way to fix it is so that my Treo starts to wirelessly sync with exchange again is to do a cable sync with my computer.

    So, it appears there is some hidden link or tie to the computer your device cable syncs with when wirelessly syncing with exchange server and if you interrupt that computer or outlook, your wireless exchange sync also gets disrupted. I'm not sure I understand what is going on but leaving my work computer constantly on and outlook running has fixed my issue...very strange. If other people are having the waiting for network issue I would be curious to see if you doing the above also fixes your problems too. Let me know.

  7. #7  
    I too found this on many different devices at my company. The non-Treo devices seem to have a cache filled issue caused by when the device connects with the work computers and syncs. after a google search of the error code, I found a simple registry hack that fixed the problems for them. Keep in mind that for these non-treo devices, a soft reset would fix it (prior to installing the registry hack.) For the Treo 700wx, however, if someone attempted to do a cabled activesync synchronization, we would have to do a hard reset to get the device working again even after doing everything (delete account, etc).

    (m105 => IIIxe => VIIx =>Tungsten T => i705 => Treo 600 => T-MO MDA => HTC Tytn = HTC Tilt & T-MO Dash => HTC TouchPro & HTC S740 => Palm Pre)
    Man, I've spent a lot of money and time on these things!!
  8. #9  
    I just started having this problem today, awkwardly. I don't use Exchange or anything of that sort and Mobility Center in Vista tells me everything is synced and the phone tells me the same but it will not sync anything. It just tells me waiting for network.

    I tried the fix in the above post by creating the key but it did not work.

    P.S. I connect via bluetooth.

Posting Permissions