Results 1 to 4 of 4
  1.    #1  
    My treo 700wx won't power on. I'm assuming the battery went down to 0% because I forgot to charge it last night. I then plugged my treo into the supplied charger and nothing. The red indicating light doesn't show up as it would normally do when plugged into the wall and charging. I then thought well maybe it needs to charge for a bit and then I'll be able to turn it on, just like when it was new out of the box. Unfortunately nothing.

    I've read the sticky about the 700w not turning on because of an active sync problem, but it seems those people have been able to get the unit to turn on a little bit to change some active sync settings. Mine it appears to be completely dead!!!

    I've tried to hold the power button (red) and push the reset button on the back with no luck. I've tried to hold both for several seconds with no luck.

    I did sign up for mail2web's free push email service so I guess my phone does access their server to sync the contents of my phone to their servers. I set the 700wx to only sync when new things arrive. I'm assuming it is not all the time. Other than that, I wasn't running too many programs in memory.

    Any one else have this problem? I think it might sound like I need to head to a sprint store and get a replacement! Sucks. I hate dealing with sprint at a store.

    Any help would be greatful.

  2. #2  
    My phone did that last night, try taking the battery out then putting it on the charger and replacing the battery back in.
  3.    #3  
    Thanks for the help! The trick worked!

    I could have sworn I took out the battery and plugged the power cord in and it still wouldn't come up.

    When I got the phone running again, it said the battery was 100% fully charged. So I guess it was charging even though the light wasn't on. It must have been stuck in that dead battery state.


    Thank you,

  4. #4  
    I have same problem here I just flash my phone then just i cannot turn it on anymore

Posting Permissions